[] Phone app cannot access contacts

REPRODUCIBILITY (% or how often): Always
BUILD ID = OS VERSION (Settings > About product): (Koli)
HARDWARE (Jolla1, Tablet, XA2,…): Xperia 10
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


In Phone app History the waiting icon keeps rolling and it never gets the history page created.
I got a call now from a known contact but it didn’t display the name, only phone number.
Also, on Phone app People tab (empty), the pulldown menu has two notches but they are both empty.
Tried removing all contacts and importing them again from xfc file, did not help.
Also, on Xperia X with the same contacts, I do not have the same problem.


Updated from 3.4 where it worked as normal.





(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

I have the same issue with on my XA2 dual sim.
I have not tried reimporting the contacts.

Ok, for me this seems to be resolved after update to (XA2 dual SIM).

Yes, resolved with .48 update.

Sorry, i did wrong opening this bug again. The bug i meant is covered in [][XA2 plus dual sim] - sim not selectable

Issue still present on XPERIA XA2 dual sim with build using two german GSM-900 (D1 network) sim cards.
UI Language german
Issue first seen in 4.0 version
Reproducibility 100%
In phone app call history if you click a history entry select options dialog for sim card to call contact again displays only for ca. quarter a second and directly disappears again. No chance to select one sim card.

My Xperia X on now also refuses to show call history and contacts. Super annoying. Is there a way to see contacts and calls from the command-line so one can at least call people back?

Wit this command you can show the last communication history from the command-line:

sqlite3 -csv -header /home/nemo/.local/share/commhistory/commhistory.db 'select * from Events order by startTime;'

These error messages are shown when voicecall-ui is launched from the terminal:

Sailfish :: ~ » voicecall-ui                                                   
[W] unknown:0 - Could not open /sys/fs/cgroup/memory/noswapping/tasks for disabling caching
[W] unknown:0 - Could not open /sys/fs/cgroup/cpu,cpuacct/interactive/tasks for disabling caching
[D] unknown:0 - Using Wayland-EGL
[W] unknown:0 - "Unable to create semaphore /tmp/qtcontacts-sqlite-semaphore: Auf dem Gerät ist kein Speicherplatz mehr verfügbar (28)"
[W] unknown:0 - "Unable to decrement semaphore /tmp/qtcontacts-sqlite-semaphore: Erfolg (0)"
[W] unknown:0 - "Failed to lock key memory region for qtcontacts-sqlite"
[W] unknown:0 - "Failed to open contacts transient store"
[W] unknown:0 - "Unable to open asynchronous engine database connection"
[W] unknown:0 - Creation of org.nemomobile.contacts.sqlite engine failed.
[W] unknown:0 - Unable to retrieve contact manager engine
[W] unknown:519 - file:///usr/share/voicecall-ui-jolla/main.qml:519:5: QML DBusAdaptor: Failed to register service com.nokia.telephony.callhistory
[W] unknown:536 - file:///usr/share/voicecall-ui-jolla/main.qml:536:9: QML DBusAdaptor: Failed to register service com.jolla.voicecall.ui
[D] unknown:0 - Starting favorites query at 1498 ms
[W] unknown:0 - Unable to query reminder notifications QDBusError("org.freedesktop.DBus.Error.AccessDenied", "PID 3124 is not in privileged group")
[D] unknown:0 - (dial) GetAll() failed: "org.freedesktop.DBus.Error.UnknownObject" "Method \"GetAll\" with signature \"\" on interface \"org.sailfishos.ofono.mdm.VoiceCallFilter\" doesn't exist\n"
[D] unknown:0 - (incoming) GetAll() failed: "org.freedesktop.DBus.Error.UnknownObject" "Method \"GetAll\" with signature \"\" on interface \"org.sailfishos.ofono.mdm.VoiceCallFilter\" doesn't exist\n"
[W] CommHistoryDatabase::open:303 - Opened commhistory database: "/home/nemo/.local/share/commhistory/commhistory.db"

Indeed, the DBus service org.sailfishos.ofono.mdm.VoiceCallFilter does’t exist:

Sailfish :: ~ » /usr/lib/qt5/bin/qdbus org.sailfishos.ofono.mdm.VoiceCallFilter                                                   
Service 'org.sailfishos.ofono.mdm.VoiceCallFilter' does not exist.

Don’t really know why it complains that /tmp is full (it isn’t).

Any ideas?

Are you running voicecall-ui as privileged group (devel-su -p) in the above log?
Is the contacts database corrupted in some way (e.g. devel-su -p sqlite3 ~/.local/share/system/privileged/Contacts/qtcontacts-sqlite/contacts.db "pragma integrity_check;")?