[3.4.0.22] XA2 phone calls no audio

REPRODUCIBILITY (% or how often): unclear
BUILD ID: 3.4.0.22
HARDWARE (Jolla1, Tablet, XA2,…): XA2
UI LANGUAGE: English UK
REGRESSION: (compared to previous public release: Yes, No, ?): I’d recently downgraded to 3.1 as noted in [3.1.0 - 3.3.0][XA2] No audio in voice calls and at least for the past couple of days things were working on that version.

DESCRIPTION:

Call 901 (voicemail) or 123 (BT talking clock) no audio is heard.
Call my mobile from house phone, no audio in either direction.
Have tested this on both v17 and v16b binaries.
The issue persists over first reboot, fixed after second (at least in my case, seen the same mentioned elsewhere)

PRECONDITIONS:

STEPS TO REPRODUCE:

See description.

EXPECTED RESULT:

Audio in both directions.

ACTUAL RESULT:

No audio in either direction.

5 Likes

This happened to me as well. I thought it was caused by my Bluetooth headset. After a reboot everything worked as expected for me. (XA2+)

OK so calls started working after a second reboot (so upgrade, no call audio, reboot, no call audio, reboot, fixed).

I guess it may just be that the bug from [3.1.0 - 3.3.0][XA2] No audio in voice calls is still not addressed.

Will continue to monitor and report here.

2 Likes

This is an extremely annoying topic for me. With an XA2 Ultra, this happens up to twice…a day. I thought this would be solved by the early release of 3.4, but boy I was wrong. But FYI: someone listed a (temporary) workaround somewhere in the old together.jolla. I haven’t tried it out yet, but a couple of people in that thread report that it worked.

Yeah. This issue which appears to have been known for a long time is really putting me at risk of moving off Sailfish OS after years of daily driver usage :confused:

1 Like

I definitely will if they don’t fix that for the next release. I love Sailfish, and I don’t consider myself an annoying customer and specially, being an open source developer, I can really understand that nothing really always work 100% as it should, nevertheless, I do need a phone where I can…hear somebody talk over the phone. I really don’t think that’s asking too much.

2 Likes

Same here, after 2x restart got audio again. Earlier no voice or sound (only WhatsApp was working).

KK

Same happened to me - no audio in either direction, regardless if I call somebody or receive the call. Now this is annoying. Restarting didn’t fix it. After another restart just now it works again. Any ideas what causes this, and how to get rid of this behaviour??

I had the same problem today with my XA2. Luckily first restart helped. Same symptoms as in my previous post: https://together.jolla.com/question/225923/xa2-no-voice-and-microphone-doesnt-work-in-phone-calls-after-updating-to-33016/

I am using 10 plus i4293, this is a long time issue for me too, it happen randomly, and also not just no audio from call, also the sound of whole sailfish system is broken. Example: When play video , you can feel its lagging and no sound. There is some journal log when it happened, any guy know what it means? look like this is a kernel issue?

This happened to me again today. Reboot cleared the issue.

We really need some input from Jolla on this:

Maybe @jovirkku can chime in here (just flagging as seen you active on the other threads).

Thanks,
Matt

Is there any data about how common this is? I’ve been reading about it long time. Gathering bits over forum seem bit tedious and unspecific for that.

I’m procrastinating between staying with J1 and changing to XA2 because of different things almost year now. Currently overall other things look good but this worries me guite a lot.

Would it be ok to do poll with XA2 variant, operator, possibly Sailfish version and if problem is occuring to get rough estimate?

Same issue here…
Only restart is working…

Same issue here -for over a year!- with my XA2 single sim, KPN.

Already since Sailfish OS Seitseminen 3.1.0.11 when i wasn’t really aware so reboots might have solved it at that time.

Since than i went through every available update, right now i’m still @ 3.3.0.16 awaiting the fixed 3.4.0.22 but the “no audio in either direction issue” is always there !

Rebooting -even several times- doesn’t make any difference …

The only inconvenient way to make a phonecall is by use of the build in handsfree loudspeaker so everybody in my vicinity could join my conversation …

Pretty useless for a phone right ?!

Will this EVER get fixed ?!?

@Franksz:
Please, try the following if you are confident in using the command line and a simple text editor. If you have never used the developer mode before then do not try.

Find a short how-to in https://jolla.zendesk.com/hc/en-us/articles/202011863 and in https://jolla.zendesk.com/hc/en-us/articles/360010391013

devel-su     
cp  /usr/lib/systemd/system/pulseaudio.service  /usr/lib/systemd/system/pulseaudio.service.original    ## save the original - just in case
cat /usr/lib/systemd/system/pulseaudio.service  ## glance thru the file if you want
vi /usr/lib/systemd/system/pulseaudio.service    ## edit the file

Look for the following 3 lines in the editor (they should be from line #18 onwards):

Restart=always
RestartSec=1
Type=notify

Add the following command immediately after those three:

TimeoutStartSec=120

Save the change and exit the editor. Check the file content to be sure the editing session worked:

cat /usr/lib/systemd/system/pulseaudio.service

Restart the phone.

Should there be a need to return to the original you should give the following commands:

devel-su               
cp /usr/lib/systemd/system/pulseaudio.service.original /usr/lib/systemd/system/pulseaudio.service     ## get the original back (let it overwrite)
reboot
6 Likes

@jovirkku :
Thanks for yor detailed reply i sadly haven’t used developer mode before.

I know where to enable it , i’m not a digital moron but for now this might be a step too far.
I might need a little how to for this or will this become clear once i’ve enabled Developer mode ?

[root@XperiaXA2 nemo]# cat /usr/lib/systemd/pulseaudio.service
cat: can't open '/usr/lib/systemd/pulseaudio.service': No such file or directory

This is on a freshly flashed XA2 running 3.4.

These are the installed pulseaudio services, which one should I edit as per your suggestion?

[root@XperiaXA2 nemo]# find /usr/lib/systemd/ | grep pulseaudio
/usr/lib/systemd/user/pulseaudio.service
/usr/lib/systemd/user/pulseaudio.socket
/usr/lib/systemd/user/user-session.target.wants/pulseaudio.service
/usr/lib/systemd/system/pulseaudio.service
/usr/lib/systemd/system/emergency-call.target.wants/pulseaudio.service

Edit: looks like your intent is the systemd/system service (just missed it in your first step). I have tried this edit and will report back. It will also be good to know what the systemd/user service gets used for, if anything.

1 Like

Yes, indeed. Thanks for pointing it out. How embarrassing to have a clear mistake in one’s instructions… Arghh.

I have fixed the 1st command of my post now.

2 Likes

Yeah, it seems to be common enough. I have this issue I’d say on about 25% of my calls. I don’t make or receive that many calls so it’s difficult to say, but it has caused me significant issues by missing important calls that have taken some time to arrange, and that can’t simply be remade after rebooting.

It’s been happening for me on my XA2 for at least the past two major updates. When it happens, the problem is consistent, seems isolated to just calls (WhatsApp, media etc. still work fine), and doesn’t go away until I reboot the phone. I’m still on 3.3, and was hoping that this would be fixed in 3.4 but that doesn’t seem to be the case. I know voice calls aren’t what they used to be, but it’s still a pretty fundamental bug, that a phone can’t be relied upon for, you know, phone calls.

2 Likes

Thank you for your reply. So it seems quite common if it is happening with device. I hoped it could be something which I can work around with Audio Output Chooser like head phone problem earlier, but it seems not.

I’m wondereing if it could be depending on operator.
With my J1 I’m experiencing mobile data problems after changing operator. Even when mobile data is connected nothing gets transfered. After swithing mobile data off and on I get “Limited connection” status. After this I have to turn it off, enable and disable flight mode and then enable mobile data again.

This seems to happen in morning and possibly because Situations turns mobile data off and network mode to 2G over night. This is of course just a thought.