Xperia Tama port: AOSP10/aarch64 release

Cross-posting over here in addition XDA and TMO.

This is to announce the first release based on AOSP10 and using aarch64 for Sony Xperia Tama platform.

Release is based on 4.1.0.24 Sailfish and is using the latest AOSP10 as a base. I consider it alpha right now due to limited testing. Most of the testing was done on development device while fixing the port bugs. Now it is installed on my daily driver and I will be able to test it further.

This release has changed the base and switched to aarch64. As a result, you have to reflash it. In documentation, I wrote down the instructions for those who switch from AOSP9 based port.

The port was started in the end of February, including the development of TBuilder to automate the builds. There are still some rough corners, see issues labeled with hybris-10 tag in the issue
tracker. While it is not using OBS, future OTA are supported (see documentation for details).

Compared to AOSP9, I couldn’t make hardware acceleration work on Flatpak apps. So, right now, Flatpak support is not there. Not sure whether I can make it work.

I would like to invite others to test the release. For XZ3 device owners - please check whether your phone calls work as expected. I have reverted some changes introduced in AOSP10 to cancel echo during
the phone calls (issue 125) and it worked fine on XZ2 and XZ2c. So, please pay attention and test it by calling others, check whether microphone levels are OK and whether there is any echo in the call. Please report back your findings.

I plan to maintain only one base. If AOSP10 will work fine, it will be used as a base for the port.

Release available at: Release 4.1.0.24 AOSP10 alpha1 · sailfishos-sony-tama/main · GitHub

See release notes and read the documentation before flashing.

Update 2 New release based on AOSP10/aarch64 is out, switching to it as to the supported base.

14 Likes

Reporting back:

Flashing was a bumpy ride since for whatever reason the flash.sh script couldn’t find fastboot which was installed. Commented out the part that was looking for it and deleted the md5 sum from the corresponding file and all went well.

The only issue i seem to have is that i cant access the store. I get a “Your Jolla account needs to be updated Go to settings|accounts and sign in again” but i cant find a way to do that.

1 Like

Which OS was that? On Linux it seems to be doing fine.

Re Jolla Store: try to remove your account and add it again. If it still fails, please send

ssu s | grep model

While reporting, make sure you don’t post IMEI which is shown as device UID.

Arch Linux.

Removing and adding the account again fixed the store issue. I’ll test more and report my findings.

BTW some apps from the store (SailOTP) fail to install. Is it because they don’t have an aarch64 version yet or something else is going on?

I don’t know how to check whether an app has aarch64 version in the store. I presume that’s a reason.

Re Arch Linux - no idea why it cannot find it. Script should be the same as used in the official devices or close to it.

I also noticed that some repositories “allow” to install a package but then installation fails because it’s on a different architecture. Usually when you refresh the repository it should not allow installation option.

If I remember correctly, for the TAMA port it was technically possible to take the Android runtime from a XA2 device and it was functioning on the TAMA device. If now the TAMA port switches to AARCH64 and the XA2 does not, does this mean this transfer is no longer possible? I am not affected, I just would like to know out of curiosity.

I haven’t tried to make such a switch. But yes, you would probably need AARCH64 based port support.

Although, note that Jolla is considering to allow unofficial ports to get the extras, such as Android support. So, we could probably ask to make it available for Tama/Aarch64

4 Likes

Thank you for your answer. Interesting news.

Installed today Sailfish to my Xperia XZ3. Flashing went smoothly (using Linux Mint) and so far everything what i have had time to test works. Not tested all functions eg. bluetooth and battery consumption but so far all good shape.

1 Like

Bluetooth seems to work the same as in the aosp9 port. And i didn’t see any bugs reported. So its probably fine.

True - I have been using AD files on XZ2c that I pulled from XA2, but won’t work anymore. I guess since AD source is unavailable, would have to pull files fro aarch64 device, whic is only Xperia 10, I think…

There are issues creeping up that look to be caused by underlying BLOBs used by AOSP10 and, via that, SFOS port. In particular:

  • relatively large idle drain
  • probably GPU driver causing low performance while interacting with Lipstick
  • wireless charging broken

Full set of current issues for AOSP10 based port listed at Issues · sailfishos-sony-tama/main · GitHub

When discussed with Sony AOSP developers, words AOSP10/4.14, ODM (aka BLOBs), Tama, and FUBAR have been used in close relation to each other.

So, a word of warning, you may want to see how it works out and not flash yet on your daily driver.

For me power consumption on idle on one night was 5% (~23:00-8:00, airplane mode on).
Glitch on screen while swiping or unlocking are seenable and sometime after reboot screen is fully pixelated.

1 Like

I’ve seen that once for few sec in the first boot after flashing, swiping and unlocking from time to time it shows a glitch line usually close to the top of the screen, it does not affect apps.

Does this pixelation occur immediately during the boot or after success boot with all PINs entered and screen switched off / on?

If pixelation occurs later after the boot screens have passed, GPU frequency bumping may help. If early in the boot then it is some other issue which I have no idea how to resolve. Assuming that it is rare, XZ3 users will have to live with it if we switch to AOSP10.

It has only happened to me twice so far and it happens before I enter the lock code when i boot the phone.
Only way to get rid of pixelation screen is force shutdown (long press power button and then normal boot).

1 Like

I will write about it in the docs. As well as mention that we do not have any plans to fix it.

New AOSP10/aarch64 based release is out. I am going to switch the port to this base and support only it.

The images are uploaded and available as usual on the port project page. Those are needed for AOSP9 base users as the only way to switch the base is to reflash.

For alpha release users, see specific OTA instructions as described with the release notes.

2 Likes