WayDroid on SFOS?

OK i will ask there but assuming it will not work can i just remove the waydroid from chum or must it be done through terminal, and then with what command?
Thank u for your quick replies anyway, greetings from Indonesia.

Hello there, was curious if u have the package gbinder_python available for download for my xa2 ultra, thnx.

Hello, have a question regarding Waydroid on a Volla phone @ SFOS 4.4.0.64:

With much help from community :smiling_face_with_three_hearts: (see posts # 137-152 and also following, in this thread) I could make Waydroid running, install my needed Android apps and it’s still running fine after a few days now. But I have to start the virtual Android UI from the SFOS app grid and then I have to operate the phone like a ‘real’ Android phone. Despite everything works fine now from the viewpoint of function, it’s not very beautiful. I don’t like to work on a Android-like looking GUI!!! Therefore my questions:

Can I use Waydroid in a way and appearance like AlienDalvik does?
Can I do some ‘setup’ or ‘configuration’, in the configuration files or somewhere, to let Waydroid stay invisible and work in the background without a full Android UI, and start Android apps from the SFOS App grid?

If yes, what have I to do to make this work?

Does it make sense to deinstall the ‘waydroid-runner’? In Chum I saw, that Waydroid has 3734 downloads and Waydroid Runner only 1 (one). But before deinstalling the Runner, i better ask before damaging the system…

Thank you much for every help!

If you install waydroid-settings instead of waydroid-runner, you can have Android run in the background. It could then be started/stopped from a menu entry in Sailfish Settings, like AlienDalvik.

You could open individual apps directly from Sailfish app grid. But, be advised that waydroid multi-window option doesn’t work in Sailfish, so you can only see one app (better said android window) open. Well of course you can open the Waydroid Full UI and use as an Android phone like it is now. Another catch is that it is not possible to open the same app consecutively after it is closed, the window wouldn’t appear.

i.e. open Whatsapp → close it → open Whatsapp again fails. Will have to open some other app before you open Whatsapp again.

1 Like

I can’t find waydroid-settings in Chum or in Storeman, and tried also to set Chum on several repositories from 4.3.0.12 + 15 & 4.4.0.58 + 64 while searching, but found no waydroid-settings to install.

Where can I find it? and, do I have to deinstall waydroid-runner before installing waydroid-settings? or may they be installed both at the same time, when launching only one of them at the same time?

I typed the package name (when installing using zypper). Try searching “waydroid settings”, without hyphen, in Chum app.

It is fine to keep both Waydroid Runner and Waydroid Settings, and use based on your requirement. Although, if you open Waydroid Runner when a session is active, it would ask to restart the session I think.

1 Like

Waydroid settings is nowhere to find, but a ‘zypper install waydroid-settings’ as devel-su in CLI installed it. In settings menu, the ‘Waydroid’ item occured immediately, above the Sailfish Utilities, with options Start session on bootup, Start and Stop daemon. I started the daemon manually. A second ‘Waydroid’ icon occured on the app grid. They look identically, but can discern them by the position on the app grid.

The first one (the Waydroid UI, Android GUI) works as always IF the other one (daemon) is switched off.

If the Waydroid GUI is off, and the daemon is turned on by ‘Waydroid’ in ‘Settings’ , how can I now start an Android app from the installed ones? There’s no extra icon (starter) on the SFOS app grid until now! What have I to do to create icons on the SFOS app grid for the Android apps?

edit:
unfortunately it crashed seriously. With Waydroid in Settings I could switch Waydroid daemon on or off, but without effect or function. The new Waydroid icon also did nothing. But the old Waydroid icon still started the Waydroid UI. But this is now history, nothing more works AND the browser and AllRadio again had no more internet access, while mail and the 3 app shops still have. So the network itself works. Why is always Sailfish Browser’s and AllRadio’s network access blocked if Waydroid has a problem, while other network depending apps still work?

Several reboots and network resets by Sailfish Utilities, that helped at installation time (a few days ago) to bring back the network, didn’t help anymore!

Now it’s not possible to deinstall the rests of Waydroid from the phone, and browser and AllRadio have no network. What can I do?

I have no idea why is the network affected. I haven’t experienced something like that.

You need to disable Sailjail restrictions in the new Waydroid icon desktop file that showed up with installing waydroi-settings, for it to work.

To do that, add
[X-Sailjail]
Sandboxing=Disabled

To the desktop file (will need to be root)
/usr/share/applications/waydroid.desktop

Now that clicking that icon should open a UI if the waydroid service is running.

To have Android app icons in the sailfish app grid, have to run the unmodified waydroid script by cloning the waydroid git repo manually at least once from the terminal. Waydroid packaged in Chum has this icon creation part removed so that it doesn’t clutter the Sailfish app grid with android apps, is my understanding. Anyway, even after getting all the icons, will have to further modify every waydroid app desktop file that gets created under ~/.local/share/applications to bypass Sailjail restrictions for it to run. I do not know if there is some other easier way.

It crashed and did nothing more, eternal spinning circle. I tried to deinstall and reinstall. But there are rests of the old installation and so Chum reports Waydroid as installed despite it is not. Browser and AllRadio get still no internet conection, other apps get. Rest of the apps are working.

With my limited knowledge, I am at the end. Please can somebody help?

Configure, disable or remove dnsmasq.

2 Likes

Reference this post, removing dnsmasq brings back connectivity in browser.

1 Like
pkcon remove dnsmasq

and restarting the network with SF Utilities brought the browser back. Allradio also playing again. Thank you very much!

edit: but I have damaged the Waydroid by trying to deinstall it and deleting folders in the system as devel-su. How can I restore Waydroid and make it work again? or deinstall it restless from its present unknown state and then reinstall in a clean way?

edit: presently it shows a spinning circle and ‘Starting Android Session’ eternally on starting. Sandboxing is disabled in waydroid-runner.desktop.

edit: Browser not connective again, so I did ‘pkcon remove dnsmasq’ again. Result: Waydroid icon on app grid disappeared.

edit (the last one in this post): installed Waydroid again to make my A* apps work again (I want them!), and start Browser and AllRadio by CLI shortcut, that works. I’m curious what will be found as the reason for this bug.

It is available at https://repo.sailfishos.org/obs/home:/heng/sailfish_latest_armv7hl/armv7hl/python3-gbinder-python-1.0.0+git1-1.1.1.jolla.armv7hl.rpm

3 Likes

does SFOS waydroid work on any Sony Xperia devices aside from tama?
say, just as a random example, the Xperia 10 iii?

i would assume no, since the kernel needs to be built with a bunch of options and modules, but maybe it already is? or there’s a nice easy way to drop-in replace it?

i got so used to waydroid i dont wanna go back to aliendalvik, but tama is no longer an option unless jolla+community somehow gets volte support for it in the next 2 weeks…

2 Likes

Does anyone.have a.hint.for.tvat issue ?

volla phone
4.4.0.58

Did you try this already?

Yes, i did disable dnsmasq and now i did also modified dnsmasq conf
nothing

i do not get stuck in init session but wait for ui :frowning:

I had the very same effect, and eventually gave up. There obviously is a way to break things in ways the packagers of the software did not have in mind.
Inspired by this thread, I simply uninstalled the settings package and re-installed the starter icon. It immediately worked and is very reliable now. I hope you finally reach this state, too! :slight_smile:

1 Like

I did also uninstalled all once.

did you install settings or rummer ?

I only installed the runner. It seemed to do all the things I did to manually start Waydroid UI from the terminal in a sensible manner but it didn’t work in the first place.