WayDroid on SFOS?


I read the whole thread but as I’m not a pro in compiling and dealing with scripts, may I ask if there is a newbee-friendly guide for installing waydroid on my sailfish phone? I love sailfish os, but I just need some Android apps as well. Since there is no aliendalvik upgrade for Xperia X, WayDroid seems to be a good Replacement.

So maybe you can help me… What exactly do I have to do to installwayDroid and get it running (idiot-friendly^^)?

THX very much :slight_smile:

If I ubderstand it right from previous discussions, Waydroid may not work by default on Xperia X unfortunately.

Nevertheless, the easiest way would be to install Chum GUI and install Waydroid and Waydroid Runner from there.

You would still need to run a command from terminal for waydroid initialisation before you could run it. This step downloads and sets up Waydroid image files. That would be “devel-su waydroid init”.

Is it possible to update the Gemini Kernel and run Waydroid then?

If you can build kernels… I think it’s just one flag.

Check this post, and a little before and after - maemo.org - Talk - View Single Post - Full linux distros on Sailfish OS


I don’t know if I should make a new thread or not. I explain:

I installed waydroid(-runner) on an XA2 DUAL following the github page.
Installation went good. Small a difference with the github readme: reboot was needed before being able to waydroid init.

Question: when I try to start it from the app grid, it spins forever (tried 5 minutes) saying it is starting but does not start.

Also, the browser seems not to find the internet connection any more since WD installation.

I was about to restore a backup of my system as I have no idea of where to search to solve this browser issue.
But maybe will it be an evidence for one of you.

Try this:

From here: https://github.com/sailfishos-open/waydroid

Thanks, yes I installed from this page and tried this.
But have to do my homework. Read the pages/wiki provided here and try on a fresh install…

Well I didn’t succeed fully. Container and session start, but not the UI part.
I reflashed, reinstalled storeman + chum, waydroid and waydroid-settings, downloaded with waydroid,init. I set it to start at boot.

When I launch WD from the app grid, it spins for a while (cover) and disappears.

So, if I reboot and do:
# waydroid status gives:

Session: RUNNING
Container: RUNNING
Vendor type: MAINLINE
Session user: defaultuser(100000)
Wayland display: …/…/display/wayland-0

# systemctl status waydroid-container gives:


● waydroid-container.service - Waydroid container
Loaded: loaded (/usr/lib/systemd/system/waydroid-container.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2022-02-18 23:43:11 CET; 6min ago
Main PID: 5966 (python3)
Memory: 9.6M
CGroup: /system.slice/waydroid-container.service
├─5966 python3 /usr/bin/waydroid container start
├─6007 dnsmasq --conf-file=/dev/null -u nobody --strict-order --bind-interfaces --pid-file=/run/waydroid-lxc/dnsmasq.pid --listen-address --dhcp-range, --dhcp-lease-max=253 --dhcp-no-override --except-interface=lo --interface=waydroid0 --dhcp-leasefile=/var/lib/misc/dnsmasq.waydroid0.leases --dhcp-authoritative
└─6009 waydroid-sensord /dev/hwbinder

Feb 18 23:43:11 XperiaXA2-DualSIM systemd[1]: Started Waydroid container.
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq[6007]: started, version 2.86 cachesize 150
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq[6007]: compile time options: IPv6 GNU-getopt DBus no-UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-cryptohash no-DNSSEC loo
p-detect inotify dumpfile
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq-dhcp[6007]: DHCP, IP range –, lease time 1h
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq-dhcp[6007]: DHCP, sockets bound exclusively to interface waydroid0
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq[6007]: reading /etc/resolv.conf
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq[6007]: using nameserver ::1#53
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq[6007]: using nameserver
Feb 18 23:43:12 XperiaXA2-DualSIM dnsmasq[6007]: read /etc/hosts - 2 addresses

waydroid app launch com.android.settings gives:

[00:01:25] Failed to get service waydroidplatform, trying again…

I didn’t touch dnsmasq as container starts. (But uncommenting #bind-interfaces in
/etc/dnsmasq.conf + rebooting didn’t solve either)

EDIT: I apologize. Realized that the “hide details” is not working in the Forum reader app, making a huge horrible list.
So I moved the output of waydroid logcat here.

Try manually in terminal. Once gou get waydroid status “running”, type

  • waydroid show-full-ui

Hmm, it says repeatedly
Failed to get service waydroidplatform, trying again...

Although container + session are said running,
If I do

'# waydroid container start

as root, and then in another term as user, I do

$ waydroid show-full-ui

The output is

[06:43:12] Starting waydroid session
[06:43:12] XDG Session is not “wayland”
[06:43:14] Failed to start Clipboard manager service, check logs

Not the first time I see this complain about “wayland”…

Then, waydroid log, as user, outputs (rm’ed dup. lines):

EDIT: I apologize. Realized that the “hide details” is not working in the Forum reader app, making a huge horrible list.
So I moved the output of the log here.

I have been searching about this Failed to get service waydroidplatform, trying again... on the net. They talk about something related to sensors but I don’t figure out the whole mechanics enough to imagine the way to go.

Do you have Waydroid sensor package installed?

also, have you checked waydroid log? Maybe post it here …

Jeez. It’s been a long, long time since I’ve been in Michigan. Sometimes a map is not just a map.

Looks to me that a service isn’t starting in the logcat, audioflinger? Do you happen to use Matrix or Telegram. If yes, might be worth joining the waydroid channel and asking there.

@Levone1 Yes, the logs are linked in my previous post. Sensors pac is installed.

@lal Ok, I’ll see how I can manage this.

To clarify, I could use, of course AD. I have it installed on two other XA2 but am very curious about libre/open/community projects.

Many thanks for your answers.

Does waydroid lives along AppSupport/AD?
Would be nice to contain some apps in a different android-world.

Can you repost the logcat … possibly logcat will show unable to connect to vibration service, which is normally disabled. On supported ports, we enable it, so you may need to do the same.

1 Like

Thanks, very kind.
Yes, logs joined in one single file here

(When files will be deleted again, logs are also readable in my posts edit history #113 and #116)

after a few months of using it on my XZ2c, i gotta say, i love waydroid and i wouldnt go back to aliendalvik if i could.
the speed improvements alone are worth it, but having a full native-like android install instead of a closed source emulator is so handy.

problem: when i open using am start from waydriod shell, the application starts in freeform window mode, instead of normal window mode (non-immersive fullscreen).

nothing ive tried has helped, including disabling freeform mode from system settings, trying to run-as the same user as the launcher, setting different intent flags (setting windowed mode flag DOES work, for everything EXCEPT getting it to start in normal mode), reflashing SFOS + reinstalling waydroid, etc.

has anyone experienced this? any ideas for something else i could try to fix it?