WayDroid on SFOS?

did you uninstall via chum gui, that is rather painfull with the depending packages

Actually I don’t remember. There’s so many ways to install or uninstall applications these days … shell history suggests I used pkcon, but the packages of course came from Chum initially:

$ history | grep pkcon.*waydroid 
 233 pkcon search waydroid-runner
 235 pkcon remove waydroid-settings
 236 pkcon install waydroid-runner

hmm, i have no waydroid-settings installed

waydroid status says:

session and container are running
vendor type : HALIUM_10
session user: defaultuser(100000)
wayland display: …/…/display/wayland-1

and waydroid log

failed to get service waydroidplatform

[nemo@phone ~]$ waydroid status
Session:        RUNNING
Container:      RUNNING
Vendor type:    HALIUM_10
Session user:   nemo(100000)
Wayland display:        ../../display/wayland-2

Looks similar to me …
If the status says that both session and container are running, have you ever tried starting the UI with waydroid show-full-ui via a terminal/ssh? This is actually how I used waydroid until the launcher worked.

Yup i did


The May Image is working on sailfish os but the Image updated in July dont work at all. Logcat is showing some error in opening launcher , as there is no update to chum repo package will downloading waydroid from git to /opt/waydroid work?

1 Like

i think it should be possible to define which image to load in waydroid init, only i did not find the proper channel etc.

1 Like

You can download an older image, unzip it and use it

how do you do it?

I tried to go to sourceforce, download the imatge vendor & system, and replace it on my sailfish here: “/var/lib/waydroid/images” But still is not working.


you have to unzip the images and follow Using custom Waydroid images - Waydroid

That way, I have been able to use May '22 images.


I redownload the images, and now seems working, only that I saw one problem, I’ve got a popup saying trebuchet keeps stopping, and I cannot do anything to leave, force close or app info ends with the same popup again

Try to rm -rf /home/defaultuser/.local/share/waydroid . See also discussion at Waydroid quirks · Issue #1 · sailfish-on-fxtecpro1/droid-config-halium-qx1050 · GitHub

Yes, now it works! I was looking, because I saw it was permission… Now I’ve got an android inside sailfish!

1 Like

One question, is there some way to share a folder between waydroid and sailfish? maybe some config in lxc?



Latets waydroid arm64 images work again with Sailfish. Work was recently added to support our old compositor, and that is now in the released december images. (halium 11)


I’m new to sailfish. Installed it on an XZ2 compact as per XDA thread. Added CHUM repo as per github readme. Unable to install waydroid however. Error message (in dutch)


Fatale fout: niets levert ‘/usr/bib/make’ nodig voor het te installeren waydroid-1.3.3+git3-1.8.1.jolla.noarch

What am I doing wrong?

I installed waydroid in the terminal with the following commands on gemini:

devel-su pkcon refresh
devel-su pkcon install waydroid-runner

however, since my device doesnt have the missing kernel modules I got an error after running:

devel-su waydroid init

I got error messages I could search online.

did you get chum from here: https://chumrpm.netlify.app/ ?

Hi jbj, yes I did get chum from that link