WayDroid on SFOS?

They’re both in Chum. You can also find more info on the PinePhone SFOS telegram group and the github for waydroid, but documentation is limited.

1 Like

I believe you need the waydroid-gbinder-config-hybris, since it is a Volla.

You could install it by being root and executing: zypper in waydroid-gbinder-config-hybris

By the way, what is “Hilfsprogramme”?

1 Like

@lal On executing the command, it reports ‘‘waydroid-gbinder-config-hybris’ ist bereits installiert.’ (is installed yet)

Hilfsprogramme is the german name of the additional ‘helpers’ in the settings menu. There are buttons for restart network, restart GUI, restore app registry, restore media database and restart fingerprint service. I don’t know the english name because I’m running the phone in german language.

Sailfish Utilities

It’s Sailfish Utilities i think.

1 Like

Did you initialise waydroid? Waydroid has to be initialised first so that it downloads the images. if you didn’t initialise already, do a “waydriod init” as root as instructed in the waydroid GitHub page.

If you already initialised and it wouldn’t start, you could try starting the session from terminal using the command “waydroid session start” to see the error messages. Also verify if the waydroid-container service is successfully running.

1 Like

I did run ‘waydroid init’, and it downloaded 681 MB, validated and installed.
Next, it downloaded 35 MB (some ‘HALIUM’), extracted, then prompt came back.

Then I rebooted as requested. Further it needed 4 or 5 reboots and restarts of the network, until browser again found the network and was able to load some i’net pages.

Now, Browser, radio, network working again, and I can start the Android GUI.

Now I have to find out what to do with it, how to install apps from existing .apk files.

On Which SFOS you are. I don’t get waydroid working on Volla Phone

@monkeyisland SFOS

Okay … How did you get it can you send me a short workaround
Did you first install waydroid an then upgrade ?
i flashed the phone with Version
I managed it under great.

1 Like

I did install with UBports installer. Then update to by CLI command, later to System was running fine. Then installed Waydroid from Chum onto the system.
Then I saw that the network didn’t work as it should, and asked here, please see the whole story beginning from my post # 137 and following, and could proceed step by step with the help from @miau , @defactofactotum , @lal - Thanks very much!!!

Between all steps it was necessary to multiple reboot the phone and reset the network with Sailfish Utilities.

Now I am at a point where I have a Waydroid icon on the app grid. Can start Android session. But I’m not sure if everything is OK and have to learn to get familiar with it. E.g. how to install an app from an .apk file in the downloads folder.

As said, all Waydroid stuff installed onto SFOS .

edit: testing now, working: contact app starts but is empty, Browser OK, Gallery OK. E-Mail starts, too, but don’t want to create a mail account on Android. Closing apps by swipe up works…

The whole Waydroid seems to run fine now! But I have no idea how to install new apps from downloaded .apk files on it!

Installing APKs by downloading them inside android (android browser etc) works for me

1 Like

Thank you much @HengYeDev , that worked fine and i could successfully install the app I wanted!

Now another problem occurs: I want to copy a data backup for this app from laptop to the ‘Download’ directory of the Waydroid Android subststem. The app accepts the data backup file only in this folder, and allows no access to the ‘normal’ SFOS downloads folder.

But I can’t find the Waydroid subsystem’s download folder to copy the backup there! Where is it?

The app says: No backups found; and asks for: Copy the backup to ‘/storage/emulated/0/Download’ and try again.
In the moment the backup is in the SFOS Downloads folder. To where shall I move it to make it work?

don t you have a nexcloud account or some folder in the cloud ?
copy your backkup there, then go into waydroid and download it to waydroids download folder, that should work

i honestly do not know if waydroid container mounts any folder of host system …

1 Like

It is possible to mount folders to Waydroid, look into the documentation

1 Like

Unfortunately i had no success with a shared folder. So I tried to solve the problem from the other end and installed a FTP client on the Waydroid subsystem. (Total Commander with SFTP extension) So i could get the backup file on the Volla and everything’s fine now. Many thanks for helping!

Hey there , im using a xa2 ultra and latest build sfos, installed waydroid and runner with chum, indeed my sfos browser has an internet error along with some sfos apps like webpirate and sfos forum app, i tried to uninstall waydroid but cant, any solution u maybe have or used?

There are some tricks on the github page but I don’t remember how I solved it.
Did waydroid work on your XA2?

Waydroid installed through chum, same as runner, have image dld and rebooted several times, sfos apps wotking again but waydroid keeps hanging on waiting for Android UI.

Any help here would be apriciated, thnx in advance.

I cannot help, alas. I was not able to make it work on my XA2 either but I did not contact the Waydroid telegram channel. Maybe there is a chance there.
As it is not made for devices where Android Support is available, I think there is less experience on these devices.