VoLTE provider support

i suggest to remove Telstra (Australia) from the table, the 10 III info was pointed out to be wrong in one of the replies

i just tried soo many different things on a 10 II, no luck so Telstra does NOT work

The provider already sent me multiple texts that without VoLTE i will not be able to place calls, because they have “4G only areas”, and as far as i can tell the old <4G networks will be disabled in the future. Which would make the whole country >=4G only and VoLTE being not just “nice to have”. With that info and the fact that my SIM card is like 2 weeks old … the service must be enabled on that SIM. However the provider does not list any Sailfish OS capable devices.

Sorry to hear you’re having no luck with the 10 II on Telstra Australia and thanks for sharing your experiences. Would you be able to link to the post that said it wasn’t working on the 10 III? I had a brief look but wasn’t able to find it.

Please do feel free to put a line in that shows the 10 II not working with Telstra (I’d be very happy to add it on your behalf if you prefer but it’s always best if it comes from the person who tested it).

Can you please provide more information about the essential IMS services?

I tried to build my own .mbn file by following the instruction there without success.

You can add a line that telstra on 10 II does not work, baseband “59.1.A.2.192” in case that matters.

You try that double ctrl+f trick to find the other comment ;). You will see how it does not work because replies are folded and hidden no matter how far you scroll. Use the internal search and look for “elstra”, not trusting case on that first letter.

Even the internal search did not find it unless i scrolled through all. Maybe the new AI thingy would be able to find posts in that forum.

Any experience in/for Portugal?
It seems 3G is gone for MEO, and it seems 2G has too many drops…

No Sony in https://www.nos.pt/content/dam/nos/assets/pdfs/Equipamentos-compativeis-tecnologia-VoLTE-NOS.pdf

In addition; we can see on the forums of that operator that VoLTE support is limitative to the list. This is indeed bad news for the Sonys; operators will never bother to validate devices that are not sold in the country. https://forum.nos.pt/telemovel-101/como-ativar-o-volte-21684/index4.html Only hope is if in a few years VoLTE becomes more common, operators will blanket allow all models.

1 Like

Just tested VoLTE with Play operator (Poland). With first install, it got automatically enabled but I could not hear anyone - after disabling and enabling again, it seems to work fine. I can hear other people, they hear me and don’t report any problems, also I can send and receive SMSes. Didn’t check MMSes yet.

But 2G (and even 3G) still here so far

How did the sound quality compare? Could you hear improvement when using VoLTE?

I am testing a new SIM : Bouygues Telecom in France, using Xperia 10ii
A first try at enabling VoLTE in the SFOS parameters resulted in a blinking button so not apparently working.

The command “getprop persist.vendor.somc.cust.modem0” gave S7.2

if I go through the directories under
/vendor/firmware_mnt/image/modem_pr/mcfg/configs
I can find a reference to ‘Bouygues’

and if I go through /vendor/oem/modem-config/
I can find S7.2
and the modem.conf file seems to report correctly the line “mcfg_sw/generic/euro/bouygues/vlvw/fr/mcfg_sw.mbn”

So I wonder what to do next to try and enable VoLTE ?

Indeed, the generic configuration file seems to work with Free mobile in France, see Add modem config for French provider Free mobile by dcaliste · Pull Request #915 · sonyxperiadev/device-sony-common · GitHub

I’ll continue to test it for several days, particularly about SMS reception and emission, before considering it a success. But after some hours, without trying tower switching or passing through uncovered areas…, I can still emit and receive calls.

2 Likes

After playing with the config for Free mobile, some feedback:

  • most of the received calls are on LTE, and mobile data is available during the call ; but sometimes, the phone switch back to 2G/3G for the incoming call. I didn’t find any pattern.
  • sending SMS is not possible when VoLTE is registered. One needs to unregister and then SMS can be sent.

Playing with GitHub - fenrir-naru/mbn_utils: Utilities for Qualcomm mbn file to unpack mbn files, I indeed notice that /nv/item_files/modem/mmode/sms_domain_pref is set to use SMS over IMS (value 01), which doesn’t seem to be the prefered way for Free mobile. I tried to set it to 00 without success though : -( Ressources on the Internet on these tens of configuration options and values are quite few though… Some interesting links in case:

Experience with VoLTE in the o2 network Germany.
Addition to the entry from 2024-05-10 in the table above.

I can register VoLTE and according to NetMon voice and SMS also work. But then there were problems when making calls. At first, everything worked, except that there was no ringtone, I could make calls. A little later, the connection no longer worked at all. When I called someone, the phone went silent. There was no ringing tone and no speech. The other person’s phone rang and was picked up, the connection was established, but they couldn’t hear anything. Meanwhile, my screen showed that the number was still being dialed. I deactivated VoLTE again. Which is a shame because the connection speed was good, and the quality was much better when it worked.
One more comment. It worked in a small town with a radio mast and good reception. It no longer worked in a big city with many buildings.

Just to report that VoLTE seems to be working fine now with 4.6.0.11

edit: SMS appears stuck though and not leaving the phone anymore when VoLTE is enabled

Since updating to 4.6.0.11 (Sauna) 4G(VoLTE) is now registered on 3UK. Haven’t experienced any issues as yet.

2 Likes