VoLTE provider support

I used the white SIM. The black one is still stuck to the card, never put it in any phone. I’ve never gotten the 10 II to register with T-Mobile or USMobile by just putting in the SIM. The first SIM I tried on the Sony first, nothing happened, tried on pinephone and it started working. Put it back in Sony and it registered OK for a few days then went to denied about 4 days later. At this point it didn’t work in either phone.

I got a replacement from T-Mo from a retail location, but that one did the same thing – I tried it in the Sony, got nowhere and then put it in the pinephone and it worked. I have not dared put it in Sony for fear of killing it, too.

Third attempt I got USMobile SIM and put it in Sony. It’s been in there a few days now and I’ve never gotten anywhere but Denied. I haven’t tried it in any other phone yet.

Sending you a PM with IMEI

@robthebold I went ahead and ran global checks and TMobile specific ones. It is indeed clear. When you created your US Mobile account did you port in a number or use a new randomly assigned one? Also, I did notice this is the dual SIM model. Were you putting the SIM into slot 1? I’ve had a lot of trouble with SIM slot 2 working here. Barring that, if you do have an active US Mobile SIM, can you slam that into SIM slot 1 and create a support ticket with them. Be sure that ‘Prefer 4G’ is selected, ‘Select network automatically’ is checked/enabled and ‘Roaming’ is set to never for now. That phone is absolutely supported and we can make it work. Cite that you’re getting a denied and the settings I’ve indicated. Don’t tell them you’re using SFOS- this will confuse them. Just say you’re using Android as it will be denied in the same manner. I’ll PM you your results.

1 Like

It’s a brand new (to me) number I got with USMobile. I’ve got the SIM in slot 1. I did try it for a few reboots in slot 2, but the results were equally unsuccessful. :frowning: So it’s back in slot 1 for several days now.

I’ve only got the brand new USMobile SIM, and I don’t know of anyone else using that carrier to borrow another from. I could try putting it in the pinephone till it starts working (hopefully) then swap it into the Sony. I suppose the risk is “killing” it as well, but that would be data I guess.

the MMS work with this config (XPERIA 10 III and B&YOU)

But it seems that VOLTE not work for outcoming call.

salut Rocks

thanks for configuration sharing. unfortunatly it didn’t fix mms straight. maybe issue is with simcard (it’s the one i used with xperia X), or that so many mms are pending i didn’t see it’s fixed :slight_smile:
VoLTE seems working fine with defaut configuration one my side:

have a nice day !

1 Like

OK, I have a new-to-me OnePlus 6T, the T-Mobile version, now carrier unlocked. It’s running Android 11. I put the USMobile SIM that had been not working in the SFOS Xperia 10 II in there and it started working in short order. After verifying function for about a day, I’ve moved the SIM into the 10 II, and after a minute or so I got network connection and 4g voice working. For now it’s still running.

So I’ve tried 3 brand-new SIMs in the Sony 10 II running SFOS before putting them in another device, 2 T-Mo and 1 USMobile (running on T-Mo network). None of them started working in the SFOS device before being in another phone. The first T-Mo SIM worked for three or 4 days on Sailfish after a short time in a pinephone before getting “denied” permanently in the 10 II. The second T-Mo SIM is still in the pinephone, still working, and hasn’t returned to the SFOS device due to my paranoia. The USMobile SIM has only been working with SFOS for a half hour.

Update: sometime overnight, the US Mobile SIM got “denied” in the SFOS Xperia 10 II. I put it back in the Oneplus 6, and it came back to life. Hmmm.

1 Like

SIM1 T-Mobile: S264.8
Sim2 Disabled: N/A

Xperia 10 II / SailfishOS

Similar bug happened to me on T-Mobile, had to reset the SIM by hot-swapping to my Pixel 4a

1 Like

Would I have to do a full re-image of the device like some have had to do?

I’ve been using the SIM switching trick for a day and a half now with a OnePlus 6, but the SFOS 10 II only works for something between minutes and hours before losing network. Shortest was less than 10 minutes, longest run it worked for almost a full day from last evening to this afternoon. Every time it has been reset successfully by putting the SIM back in the OnePlus, but not too practical to carry an extra phone around for random SIM fixes. :frowning:

1 Like

Yeah, it is irritating… I tried the fixes, they did not work, and worse yet, ADB and Fastboot do not function at all from what I’m seeing.

ive been using my Xperia X10 III on T-Mobile USA for months now, and it’s great, but without LTE channel 12, i dont have coverage everywhere. plus, the camera is useless, so i decided to try out a 10 II

i took the same SIM card, stuck it in a new Xperia X10 II, set my modem to mcfg_sw/generic/euro/dtelekom/vlvw/de/mcfg_sw.mbn, and VoLTE registered like a charm.

outgoing calls and texts work seamlessly on VoLTE, while simultaneously mobile network downloads at 3mbps (fastest in my area).

BUT. i cannot receive incoming calls, at all, on VoLTE. (turn off VoLTE, and it works fine)
im gonna try other modem configs, i guess

(side note: the 10 II was bootloader unlocked: no, so i bought a qUnlock token and SIM-unlocked it. might be related somehow…)

1 Like

one, or possibly both at the same time, of the following TEMPORARILY fixes incoming calls. everything works, and then incoming calls stop working:

  1. switch from detelekom to this mbn: mcfg_sw/generic/common/default/vl/global/mcfg_sw.mbn or back and reboot
  2. swap my sim card into my X10III, register volte, and swap back

everything works great on 10III…

Update: I went and replaced both my SIM cards (Saunalahti and Elisa, both new SIMs are branded Elisa and show as S256.1 now) with new ones, and both register just fine now! Had only one call yet and didn’t really think if it sounded better or connected faster or whether the connections dropped, but will keep an eye on that.

I never edited any confs so it appears the whole issue in my case was due to older (couple of years max) SIMs.

I am not familiar how other dual-sim phones handle VoLTE. If I understand correctly, at the moment in Sailfish I need to pick one of the two SIMs (in mobile data), and only that SIM can have VoLTE active at one time. Is this only a temporary stage and will it be changed (so that one could pick either card for mobile data, but have both SIMs VoLTE enabled for calls and SMSs)?

Also a note; I’d like to have an indicator of VoLTE being on at the top bar.


Oh, wow. I’ve seen numerous broken/glitchy SIM card during the years, I didn’t think the age of the SIM card would matter (especially if they were only a few years old), but apparently there can be significant differences. This is an important piece in the puzzle, thank you for sharing it!

VoLTE indicator would indeed be nice. Could you make a separate post about it in the feature requests section?

1 Like

I’d also like to know! On vacation in France (02 Germany client) I actually ended up using prefer 3G in Southern France ( Occitania ), so I wasn’t even thinking about Volte.

I just want to leave a note to say that I have working VoLTE with Swedish provider Telavox.
Needed to edit service_provider_sim_configs.xml (the same as for Fello), both Fello and Telavox seem to be using Telia as their upstream carrier.
This is on a Xperia 10 II phone running SFOS

1 Like

This is great to hear, and thank you for sharing the info @sunkan. Would you mind please adding the info to the wiki (the very first thread)? If you can’t edit it, please say.

1 Like

Well for VoLTE FreeMobile have activate it… only Sony do not add support for Xperia 10 2&3…
Look like Xperia 1 IV is full supported…

May be we only nead de find the good config… but don’t know how…

Without reading the whole thread I want to add that VoLTE on O2 Germany and X10II registered and worked at the beginning but is not being able to register anymore. I have no clue when it stopped working, but rebooting and re-inserting the SIM didn’t help.
Any ideas?

edit: thigg solved it with a hard reset of the device and this also solved it for me. VoLTE works again.