Volla phone in bootloop

my volla phone crashed and went into continuous boot loop on the last day of my vaccation.
phone was in flight mode with gps on

the last time that did happen i had to reflash it, lost some of my data etc.
would love to avoid that this time.

thanks !


after the crash, phone went into bootloop and got hot.
i have tried to remove the sim card, but that did not help.

phone went out of battery after some hours.

two days later, yesterday, i pluged it to a laptop. it again went to bootloop
i did remove sdcard then too, still bootloops

then suddenly it started up, said 1% and shutdown.
had to fiddle a bit to get charging working again, but then one would see the sailfish charging symbol rather then androids.
i let it charge to some 30 procent and then started
it loaded to sfos, i could do a backup etc.

i have rebooted then phone and it started up successfully.
now will add sdcard → success
i have included sim card → success

but on charger unplug → goodbye and shutdown
this happens now on every unplug, any ideas ?

i have installed batttery buddy and it shows correct battery level, state is charging but shows charger as unplugged.
i will let it now charge till 100% and hope that resets something

and the bootloop is back again :frowning:


I also have boot problems with Volla phone. Not booting SFOS or operating it, but if i want to boot into flashing mode, it doesn’t work.

If trying, result is booting into SFOS, hanging, reboot or dead Andriod. With luck it was always possible to reboot SFOS by long pressing power button.

I read something about a bug that alleged exists on the unlocked Volla phone’s boot loader.

Does anyone know something about this?

i was able to flash it from an windows pc after the last crash.
windows and flashing tool was able to connect and flash it with org android image …

but back to my original problem please :slight_smile:

  1. i get now the goodbye message and consequently shutdown quite frequently esp. on disconnection the cable
  2. the start does sometimes succeed, sometimes ends in bootloop, being connected to windows seems to help and phone starts into sfos

it starts i login, it says goodbye :frowning:

the phone shows 100%, battery buddy shows that too, but still i fear the phone thinks it is no havin juice and shuts down when the cable moves a bit, that is my assumption
i have installed lnav (log file navigator) but it says no logs found …

i have flashed stock rom on it and was still in bootloop for an hour or so …
suddenly it would boot. phone is now running android 11. i will check the behavior for a day or so
that was quick, a restart and reboot loop again …
seems it is related to hw or something lower then os. it reboots now regurarly.
i will stop it here and send the phone to some refurbisher.

1 Like

Time to request to Jolla for an official support of Gigaset phones? Since Sony is only selling devices wih a deviant ratio we should have a choice. I would go for a GS5, but I am not able to port myself.

1 Like

Full agree! (20 charakters)

so finally had to buy another gs290. first attempt to install sfos failed already. (i did use the old 4.2 image and during update to 4.3 lost calls) may use the other one as spare part device.

is there a way to reflesh a volla phone using the script after sfos was installed ?
currently i always have to reflash it with flash-tool with gigaset image, then volla os then sfos, that is a little inconvinient.

1 Like

i am now on the gs290 on and have now the same waydroid behaviour: stuck with circle on start. did you ever found any solution for that problem ?

I have to admit that I’ve always done either:
ubports installer (if I wanted to get the ‘correct’ android base installed) or
piggz script in the downloads from his CI (if reflashing with a correct android 10).

This has never failed (except once when I had ubuntu installed and forgot to install the android base).

my problem is: once i have sfos installed, ubports nor e-installer will recognize my device thus no reflash
how do you bring your phone to fastboot / bootloader with sfos ? in my case it fails

I just boot with volume up, select fastboot, (phone plugged into laptop, usb 2 port) and run the script from piggz ci generated archive. I’m running ubuntu 20 and 22.

What do you mean, it fails? Either you get to the menu and can select fastboot or not?

Huh. Just to see if I’m blowing smoke, I tried it and now I can’t boot to fastboot :slight_smile: vol+ doesn’t work and vol- doesn’t either. I’ll try with the ubports installer

Ah, I was in the wrong usb port (3-1). Ran ./flash-volla.sh, stuck the cable in the correct USB port, depressed Vol+ and power and bingo.

EDIT: damn and I just re-flashed :slight_smile: Ah, what the hell. It’s dev device 2.

the menu pops up for a second and moves on to normal start

sorry for that.
setup of a phone will all always takes ages …

this time i was able to get up whisperfish running with mybackup at least

That’s good to know. I need to make myself tickets to implement that in all the apps.

Just to re-iterate what seems to ‘always work’:

  1. Shut down phone from SFOS
  2. attach to USB2 port
  3. run flash-vola (fastboot flash …) or ubports installer
  4. start with Vol+ and power depressed.


1 Like

Not for me, but might be a cable, port issue too.

allways for me is: flashtool for android :\

Ah, but it’s interesting if the port usb standard, for instance, is irrelevant depending on the tool. ah, well.

maybe different drivers ?

i was not able to connect flashtool on linux laptop, or to get the drivers …
so the flashing rom i did on windows pc, with drivers and flashtool

ubport installer and sfos script i did on linux laptop

but now that we are chating … waydroid starts but says forever: waiting for android ui
any idea how to re-install it ?
re-init -f does not much