GS290 installation

Thanks very much, I will try the update again following the posted steps when I have some free time. Video also does nothing here with 4.3.
Pleased to read that some others use the GS290 :slightly_smiling_face:

1 Like

I am on 4.4.0.58 now. The Jolla camera works (stills), the advanced camera does not. I first tried the procedure of post 16 but got a warning: something like “…ssu.ini maybe not writeable…” I then used the commands of post 9 - with success.

1 Like

i have just made

devel-su
ssu release 4.4.0.64
pkcon refresh
version –dup

to move from 4.4.0.58 to 4.4.0.64 and now i got stuck in volla boot logo.
during the process i had an error due to out of space (failed, retry 1 of 9) , but i cleaned browser cache and the 2nd retry seemed to work
settings said i am on latest
then i did reboot
and now i have brick with logo

a very very long button off+vol-up brought dead-android, so recovery but it says no command ?!

when i do power+vol-down it seems like for a seconds the recovery menu would show up. but just like a flash and done

yup, press buttons and 11 seconds after screen goes blank recovery munue flashes up
if i release the buttons 10 secs after screeen goes blank, i see just standard startup and ogo

3 Likes

https://spflashtool.com/download/

hmm i was in the bootloop and could not even charge properly, i had to install usb drivers for mediatec, that was easier on windows, then i did install sp flashtool, then downloaded rom from above
started tool, clicked on download, then rebooted with power+volumedown and luckily it got recognized and download went fine

on first start it showed boot load options, went for boot now and gigaset os went slowly up

then went for ubports installer as piggz install says start with vollaos10, just to see the sailfish option there so clicked on that .

and that was a mistake, after flashing gigaset rom, you need to flash vollaos first, then only proceed to sfos

another issue: when you try recovery with the above gigaset rom: you will end up in some chinese screen. so better it is to, while you are on vollaos, to use: adb reboot fastboot.
other option would be to replace recovery image but …

update: removed wrong statements, did not find a way for strike throu, see final flow for a working example

4 Likes

Many thanks for sharing your experience. I am still on 4.4.0.58, everything works smooth. I did not try to upgrade so far. BTW what is the advantage of 4.4.0.64?

fuck: on the last run i did not enable sim card in volla os and now almost finished setting up all apps in sfos, i’ve realized no mobile network, due to no simcard.
so important: do not skip the step to enable and check sim card !!

final flow:
flash gigaset rom using sp flash tool
i did that on windows due to usb drivers for mtk
flashing rom was easiest on windows
tryout sim
enable dev mode (about phone-> build number 7times)
enable usb debugging
flash volla using ubports installer
this again worked fine on windows (but can be also done on linux)
test sim
enable dev mode
enable usb debuggin
flash sfos using ubports installer
that worked best on linux (windows did not want to get connection and recovery is in chinese so not an option) on linux i have adb running so ubports installer can connect and if you use piggz script you can send device with adb reboot fastboot into propper mode
after flashing i am on 4.3.0.15 again test call and mobile network
enable dev tools / remote / untrusted and follow piggz instruction for waydroid:
https://www.piggz.co.uk/sites/pgz/blog/volla-manual-install

install storeman installer from store while you wait for waydroid image download :slight_smile:
a refresh i chum gui helps now and then when installation does nothing or no package found comes …
do NOT apply patches while downloading :slight_smile: did that, not good

after reboot try out waydroid if it fails head to: https://github.com/sailfishos-open/waydroid for trouble shooting
i did option 1:
devel-su systemctl disable --now dnsmasq
devel-su systemctl restart dnsmasq
devel-su systemctl restart waydroid-container

test again waydroid , i had to reboot to be able to start it

then update using zypper. i am cautious so i did write down all the versions from 4.3.015 which is the initail os version if u use ubp, if you use script it is 4.2…

while zypper is running use the time to install f-droid, then aurora from f-droid

then install signal
install signal from openrepos
i did head again to windows as easyssh would not pass the whole register string … i used winscp for that following this instructions: Registration Workaround · Wiki · Whisperfish / Whisperfish - Signal on Sailfish OS · GitLab

and now i have a functional volla phone again - a piece of cake :smiley:

2 Likes

I had SFOS 4.4.0.64 running like a charm on Volla phone, including Waydroid and had also the conflict between dnsmasq and the connectivity of Browser and AllRadio app, but could live good with workaround by starting these apps via CLI, better said, qCommand.

After updating the Volla from 4.4.0.64 to 4.4.0.68 with the commands
devel-su
ssu re 4.4.0.68
ssu ur
zypper ref
zypper dup

upgate worked but a lot of bugs occured:
Camera, Advanced Camera and Code Reader all not working after the update, no camera image, black screen, pixel resolution not selectable.

Volume control didn’t work. Volume is on a middle level and not changeable. Also screenshot by pressing both vol buttons at the same time doesn’t work.

Dead Beef Silica not working, starts, stucks and does nothing.
LLs Video player works and plays videos, but spinning circle remains endless spinning over the image while playing.

(all this works perfect on the Sony X10, bugs occur only on the Volla)

additional info: On the Volla there is also Waydroid installed, and since that time another bug occured - Browser and AllRadio doesn’t find network (dnsmasq conflict). But for this there’s a workaround. But there may be a context between this all bugs…

Fortunately I could set the Volla back to 4.4.0.64 using the commands
devel-su
ssu re 4.4.0.64
ssu ur
zypper ref
zypper dup

so it’s working again now. But as I read that 4.4.0.68 is a stop release and requirement for the following updates… What shall I do now?

i thought, set back is something you should never do.
lucky you, guess did work thanks to only patch version change

1 Like

btw i am on 4.4.0.64 only
@piggz , are you on .68 with your volla phone ?

Maybe you didn’t complete the upgrade?
I upgraded my X10ii using sfos-upgrade and I noticed a lot of packages were only installed after reboot and invoking the post-install script.

1 Like

Never went.into details here: do the scripts also work for community ports ?

The Volla did not postinstall anything after updating via CLI and also didn’t ask for postinstalling something, neither after the first reboot after updating nor after a few reboots later while tinkering to make the failing apps work.

Shall I repeat the update and can I initiate some necessary postinstall by CLI before a new test of the apps that didn’t work after the first try? Or deinstall the failing apps and reinstall them after the update? Waydroid is deinstalled at the moment, but was installed at the first update time.

i think the post-install script is part of sfos-upgrade from olf
so you will not see that during the update procedure you did.
look here:

there is a post_sfos_upgrade …

1 Like

Thanks, @pawel.spoon , I made no post_sfos-upgrade, so this may explain why it was not working. Tomorrow I will install Olf0’s sfos-upgrade and retry, and then report about the results.

Now I repeated the update same way as in Post Nr. 30, with Waydroid not installed. Everything seems fine until now. Update is ready, Volla boots successfully without error messages.

After update, i executed ‘post_sfos-upgrade’. There were also no errors found.

Good news: all accounts survived. 3 Mails, Jolla, Storeman. Browser + AllRadio have network, GPS very fine, most apps are working. System appears to be a little bit faster now.

Bad news: Storeman updates sources forever,
the same apps as mentioned in post no. 30 still not working, also Fotokopierer, because it also needs the camera.
Volume buttons not working, not for any ringing or media volume and not for screenshot. No feedback from Vol. buttons on screen.

It’s the same as on my first try.

How can I fix this? How can I contribute to find the bugs? Or am I the only one who has this? Are further details or info required?

Hi 7o9
it would be interesting if piggz is actually on this version himself. Else start apps from cmdline and collect logs

maybe they start from cmdline but not from grid ?

i had that issue with weatherapp
maybe its the changed config settings paths ?

1 Like

Now I tried to start apps from cli:

Starting deadbeef reports on CLI:

[defaultuser@VollaPhone ~]$ deadbeef
starting deadbeef 1.8.2
server_start
searching for GUI plugins in /home/defaultuser/.local/lib64/deadbeef
searching for GUI plugins in /home/defaultuser/.local/lib/deadbeef
searching for GUI plugins in /usr/lib64/deadbeef
load_plugin_dir /usr/lib64/deadbeef: scandir found 37 files
found gui plugin ddb_gui_silica.so
added silica gui plugin
load gui plugin
checking GUI plugin: silica
found selected GUI plugin: silica
loading plugin /usr/lib64/deadbeef/ddb_gui_silica.so
[W] unknown:0 - QObject::startTimer: Timers can only be used with threads started with QThread
loading plugins from /home/defaultuser/.local/lib64/deadbeef
loading plugins from /home/defaultuser/.local/lib/deadbeef
loading plugins from /usr/lib64/deadbeef
load_plugin_dir /usr/lib64/deadbeef: scandir found 37 files
loading plugin /usr/lib64/deadbeef/aac.so
loading plugin /usr/lib64/deadbeef/adplug.so
loading plugin /usr/lib64/deadbeef/alac.so
loading plugin /usr/lib64/deadbeef/dca.so
loading plugin /usr/lib64/deadbeef/ddb_dumb.so
loading plugin /usr/lib64/deadbeef/ddb_mono2stereo.so
loading plugin /usr/lib64/deadbeef/ddb_shn.so
loading plugin /usr/lib64/deadbeef/dsp_libsrc.so
loading plugin /usr/lib64/deadbeef/ffap.so
loading plugin /usr/lib64/deadbeef/flac.so
loading plugin /usr/lib64/deadbeef/gme.so
loading plugin /usr/lib64/deadbeef/in_sc68.so
loading plugin /usr/lib64/deadbeef/lastfm.so
loading plugin /usr/lib64/deadbeef/m3u.so
loading plugin /usr/lib64/deadbeef/mms.so
loading plugin /usr/lib64/deadbeef/mp3.so
loading plugin /usr/lib64/deadbeef/mpris.so
loading plugin /usr/lib64/deadbeef/musepack.so
loading plugin /usr/lib64/deadbeef/nullout.so
loading plugin /usr/lib64/deadbeef/opus.so
loading plugin /usr/lib64/deadbeef/psf.so
loading plugin /usr/lib64/deadbeef/pulse.so
loading plugin /usr/lib64/deadbeef/sid.so
loading plugin /usr/lib64/deadbeef/sndfile.so
loading plugin /usr/lib64/deadbeef/supereq.so
loading plugin /usr/lib64/deadbeef/tta.so
loading plugin /usr/lib64/deadbeef/vfs_curl.so
loading plugin /usr/lib64/deadbeef/vfs_zip.so
loading plugin /usr/lib64/deadbeef/vorbis.so
loading plugin /usr/lib64/deadbeef/vtx.so
loading plugin /usr/lib64/deadbeef/wavpack.so
loading plugin /usr/lib64/deadbeef/wildmidi.so
loading plugin /usr/lib64/deadbeef/wma.so
starting plugin Silica GUI plugin
starting plugin AAC player
starting plugin Adplug player
starting plugin ALAC player
starting plugin dts decoder
starting plugin DUMB module player
starting plugin Mono to stereo
starting plugin Shorten player
starting plugin Resampler (Secret Rabbit Code)
starting plugin Monkey’s Audio (APE) decoder
starting plugin FLAC decoder
starting plugin Game-Music-Emu player
starting plugin SC68 player (Atari ST SNDH YM2149)
starting plugin last.fm scrobbler
starting plugin M3U and PLS support
starting plugin mms vfs
starting plugin MP3 player
starting plugin MPRISv2 plugin
starting plugin MusePack decoder
starting plugin Null output plugin
starting plugin Opus player
starting plugin PSF player using Audio Overload SDK
starting plugin PulseAudio output plugin
starting plugin SID player
starting plugin WAV/PCM player
starting plugin SuperEQ
starting plugin tta decoder
starting plugin cURL vfs
starting plugin ZIP vfs
starting plugin Ogg Vorbis decoder
starting plugin VTX player
starting plugin WavPack decoder
starting plugin WildMidi player
starting plugin WMA player
starting plugin stdio vfs
streamer_set_output
selected output plugin: PulseAudio output plugin
INFO: from file /home/defaultuser/.config/deadbeef/playlists/0.dbpl
resume: track -1 pos -1.000000 playlist -1

(process:7370): GLib-GIO-CRITICAL **: 19:26:23.688: g_dbus_connection_emit_signal: assertion ‘G_IS_DBUS_CONNECTION (connection)’ failed
[D] unknown:0 - Using Wayland-EGL
library “libpq_cust.so” not found
streamer_set_output
selected output plugin: PulseAudio output plugin

Then the Deadbeef starts but no user interaction, screen stucks.
Then a black pulldown comes:Deadbeef doesn’t react?, wait or close.

Waiting brings nothing, after closing, the following adds to the cli output:

Beendet
[defaultuser@VollaPhone ~]$

Is this helpful to find the bug, al least on this app?

It reports that ‘libpq_cust.so’ could not be found. In fact, this lib is not listed in Settings/ProductInfo/InstalledPacketsInfo. Can I get it from somewhere?

another thing that doesn’t look good is:
[W] unknown:0 - QObject::startTimer: Timers can only be used with threads started with QThread

edit: Another important thing is, the volume up + down buttons do nothing since the update to 4.4.0.68. Nothing, never, also not with the working apps.

nope:
start of harbour-olive-goes-shopping …

[defaultuser@VollaPhone ~]$ harbour-olive-goes-shopping
[D] unknown:0 - Using Wayland-EGL
library “libpq_cust.so” not found

you see missing libpq_cust.so is pretty standard
the dbus connection is more interesting
i am really no expert and dont want to fuck up my phone. somewhere in the forum is stated how to start from command line using the sailjail args
i would try that just for the fun
and i would try to modify the desktop file of deadbeef that it does not use sailjail

Adding the magic

[X-Sailjail]
Sandboxing=Disabled

to the desktop file didn’t help. With disabled Sailjail it still doesn’t work and libpq_cust.so is still missing.

I’m still on 4.4.0.64 - I’m monitoring this page:

https://repo.sailfishos.org/obs/nemo:/testing:/hw:/volla:/yggdrasil:/

2 Likes