Unable to use mobile data on Sony Xperia 10 III

I have been traveling in Norway and during the trip I have noticed that the xperia 10 III ( phone does not work on a foreign network. My other phone xperia 10 II ( worked fine. My operator is Finnish Saunalahti. 10III didn’t connect to network in Norway.(only network awailable, not connected).

How do you interact with a Sim pin code in SFOS?

In settings, under Security you have PIN Code menu where you can enable/disable or change it.

The same for me.
Muved twice to Bosnia and Herzegovina from Serbia, no internet after cross the border.

My Xperia 10III had a bad day too. It didn’t want to leave mainland Finland to Åland islands I guess… Same country but here on the islands there is not my home network available, have to do roaming.

I have I can’t remember anymore the android version/binaries flashed, it was May this year I did the flashing.

First connection to roaming network killed the mobile data. Everything else worked, sms, calls, Wifi and so on, but not the mobile data.
An interesting thing what I noticed was that when phone contacted network it showed 4G for a one second. But then “gave up” and went to 3G for some reason. If Jolla reads this, that might be an interesting tiny bit of information.

I tried everything described on this thread (except reflashing).

What I did was I switched SIM cards with my work phone.
Dna SIM card / work iphone >>> my X10III.
Saunalahti SIM card / X10III >>> work iphone.

X10III didn’t like the other SIM at all and Mobile Data was off.
Then I rebooted multiple times and tried many things from this thread trying to get mobile data alive on X10III with the “wrong” SIM. No luck at all, mobile data stayd dead.

Mobile data worked fine on work iphone (not really surprised). I used it for a while just to see that I’m not seeing things and it’s not via Wifi.

Then changing back the SIMs to their rightful phones.
I wasn’t waiting anything anymore.
But…WHAT? X10III mobile data rises from the ashes.
There is another interesting tiny piece of information here;
this time the 3G comes up first and THEN throws after couple of seconds to 4G.
(physically exactly same location)

I don’t know if this helps anybody, I hope so.
I feel that this thread is not really solved although it is marked as solved.

Hello Lumen,
The combination SW binaries v8a + unlocking the SIM pin code is what resurrected my mobile data. Since then i did not have data connection issue, although i have not tested roaming yet.
Flashing only SW binaries should be safe and should not alter data (no promises here, do it at your own risk), so it is up to you to try it.

1 Like

Hello Cedric,
Thank you for your message. It seems that I have written kind of not-so-clearly my case :face_with_hand_over_mouth: because I have gotten it sorted out, I got mobile data working again. That’s what I meant by “mobile data rises from the ashes”. Could have expressed myself better :face_with_hand_over_mouth:
But my case became solved by switching SIMs between two phones. I didn’t have to reflash at all.

So I have kind-of-a-“solution” for this problem too…

1 Like

Some more news: once back to the home network ( FR/FreeMobile), mobile data stopped working.
Moving the SIM card to otherphones then back doesn’t change anything ( mobile data ok in other phones)
Two requests:

  • can anyone tell me what the ownership & mode flags of var/lib/ofono directory ? I have mistakenly removed the directory itself. It is not recreated by ofono, which prevents from persisting SIM card settings.
  • @Cedric : can you please detail how you flashed v8a binaries? You mention it here once as fastboot command and once that you changed flash-config.sh and md5.lst.
    Did the last reflash wipe your data? ( ie, do you remember if you had to start over with encrypting, etcetc?)
1 Like

I cannot confirm regarding if the SW binary reflash will wipe the data as i did everything (flashing binaries but also sailfish) at the same time.
I would think that since binaries are flashed in a different partition with fastboot, it should not touch existing data but i cannot confirm.
the single line command to flash only sw binaries is:
fastboot -s HQ618J3443 flash oem_a ./SW_binaries_for_Xperia_Android_11_4.19_v8a_lena.img
The HQ618xxx should probably be replaced by the output of fastboot devices.

Following may be a hint

The only way to get mobile internet working on the Xperia 10 III ( is to boot with another provider and then reboot with mine.

I tested following:

Xperia 10 III on
1.) Insert Salt.ch SIM and boot → no internet
(Salt.ch is owned by Xavier Niel, owner of Free.fr, could be also a hint)
2.) Insert Yallo.ch SIM and boot → internet OK
(Yallo.ch os powered by Sunrise.ch)
3.) Reboot with Yallo SIM → internet OK
4.) Re-reboot with Yallo SIM → internet OK
5.) Insert Salt SIM and boot → internet OK !!!
6.) Reboot with Salt SIM → no internet
7.) Re-reboot with Salt SIM → no internet
8.) Insert Yallo SIM and boot → internet OK
9.) Insert Salt SIM and boot → internet OK !!!
10.) Reboot with Salt SIM → no internet

Xperia 10 II also on
1.) Insert Salt.ch SIM and boot → internet OK
2.) Reboot with Salt SIM → internet OK
3.) Re-reboot with Salt SIM → internet OK

All other solutions from the forum have failed. (Having Yallo and Salt together didn’t work either).

Otherwise, the Xperia 10 III seems to work fine with, apart from the additional camera lenses not being selectable.


On my 10 iii on, mobile data may or may not work at boot, and I routinely “lose it” (i.e. the infamous “limited connectivity” issue) when I move from wifi to mobile, or when I move for long distances (e.g. when I am on a train, I suppose because I’m changing cell tower, or maybe when coverage is not so good and I lose/gain signal), or sometimes just seemingly randomly. So far, so bad.

Yet, I can consistently get it to work simply by switching to 2G only in settings, waiting for connection to get back (and it consistently does), then I can set it back to “prefer 4G” and enjoy mobile connection… at least for a while.

I didn’t see anyone report such method yet.

I’m not capable of getting/sharing logs to help identify the issue, but I’m more than willing to do so if somebody can kindly explain me how to :smiley:

1 Like

Despite trying the method above, I’ll didn’t manage to restore today the connection at first.
After a while, I was successful, and I did a speed a test, clocking at 756 Mb/s. But after a second test, clocking at some 600 Mb/s the connection broke and 3G re-appeared on the top right corner.

Then I retried with my Xperia 10II, also with Connected and speed was clocking at 150 Mb/s, the same speed as Xperia 10III with Yallo.
So, I’m asking myself if with Salt, I don’t connect with 4G, but 4.5G or even 5G? And that’s what crashes? Because while sill on Android, I got pretty much the same speed of 750Mb/s on 5G, in the same location.

1 Like

For reference, I have created a bug report for this topic: Xperia 10 III Mobile data stops working
So far it didn’t raise too much attention ( it doesn’t look like Jolla is tracking it).

1 Like

Hello @Cedric, downgraded to v8a.
Good news - no lost data.
Less good - no improvement either wrt Mobile Data. Ofono produces the same Unexpected data call status 4100

I got this same experience on Xperia 10 ii on and I fixed it in this way:

Mobile data was working fine
I messed up /etc/connman/main.conf by adding “usb” in the preferred protocols
Mobile data connection was not working.
Wifi SSIDs were all disappeared (all SSIDs, all passwords)
Hotspot option was blanked


  1. I restored main.conf file
  2. I rebooted the whole O.S. (mobile was now active but no connection was available)
  3. I activated the “mobile data” in the setting menu (still not connected to mobile)
  4. I pushed the “connect to internet” shortcut in the top menu switch
    4.2. I selected “SIM 1” instead of “wifi connection”
  5. Mobile data was back

I hope this can help, best regards,

I’ve studied my case a bit further when I got second time this issue;

  • Happens now every time phone goes to roaming network

Somehow phone refuses to accept 4G eventhough it is available.

I think I have a success recipe now for my case:

  1. Stop ofono and delete its folders as Jolla instructs (trick nr 3):

  2. Shutdown phone

  3. Do the “Sony reset”, while phone is shutdown hold both volume buttons pushed down and at the same time push power button as long as you feel three times vibration. I don’t know if this step has a relevance or not, but it’s not so big thing to do either.

  4. Switch another SIM card into the Sailfish phone
    Play a bit with internet, for example browser

  5. Switch back the original SIM card, start the phone

  6. Mobile data revives and phone accepts 4G again (…until I go to same roaming area again)

1 Like

@lumen: Tried with a different SIM ( MVNO operating on a different network) . The SIM works on Android ( Xperia X) , 4G/LTE+ connectivity ( subscription doesn’t include 5G).
On X10III + SFOS => stuck in 3G, no data, ofono log Unexpected data call status 4100
I will try the reset steps you describe and report back.
In my case roaming ( abroad) worked with a specific operator ( either auto selected or manually forced ).
I wonder if there’s a condition related to MVNOs or some special roaming cases (warning:conjecture ):

  • FreeMobile FR has no 2G/3G network, but only 4G/5G => there’s a special roaming agreement to use the 3G network owned by Orange ( ex: for non-VoLTE voice calls).
    Result: no data, Unexpected data call status 4100
  • Auchan Telecom is a MVNO operating over Bouygues (2,3,4,5G) network. Auchan doesn’t offer 5G access.
    Result: suck in 3G, no data, Unexpected data call status 4100

Thanks !!! That solved my problem !!!

Hello ppl!

I recently changed my contract from Cosmote to Vodafone (Greece), and IMMEDIATELY started having this no-mobile-data issue. In fact, I never got it to work, whatever method I used. Always getting “Limited connection”. In general, I had absolutely no problem with the previous company (Cosmote).
I tried (1) changing to SIM tray 2, (2) killing ofono and erasing all settings, (3) going back and forth to flight mode, (4) changing to IP4, IP6 and both, (5) different combinations with WiFi and BT ON/OFF, (6) inserting a Cosmote SIM, where data still work just fine, and then replacing it with Vodafone, (7) inserting both companies SIM cards simultaneously (8) reflashing with base Android rom version .109, (9) flashing different OEMs (v7, v8, v9), (10) turned roaming ON and OFF. Nothing works… :confused:

I tried all methods I could find in the forum, but had no luck with getting mobile data to work. I noticed that most ppl having this issue use Vodafone.

I wonder, is there anyone with a Vodafone connection who managed to solve this problem (or never had this problem at all)?


This is definitely a carrier-related issue. I am on Vodafone IT and I haven’t yet found a solution.