Unable to use mobile data on Sony Xperia 10 III

In my case SIM1 doesn’t work(t-mobile NL) and I have to use SIM2. That means i’m unable to use SDcard(that is since the III has 128GB internal not a problem at all).
Other then that, it’s running fantastic. My old 10 I was incredibly slow on some websites, and the III’s battery lasts at least 2x longer.

Yes indeed i totally agree with your conclusion, i had the same problem on my XA2 Ultra, tried several options and ended up deciding to go back to andy, but even that was not easy in my case.
Now i m using Lineage 19.1 with android 12 on this old xa2, sofar so good.
II was supriced sfos still had vey annoying bugs on basic functions even after 8 years , so guess ill wait another 8 for sfos is matured lol.

1 Like

Actually it’s getting worse. The current version of SFOS on XA2 has some serious bugs, including Android support that hangs when panning the map on navigation apps or connectivity that fails when switching from WiFi to mobile data and vice versa.

The XA2 behavior is off topic here…


Yep u are right , sorry only mentioned the bugs that are similar to the 10 III also on the latest build and still not solved by Jolla, so it was worth to mention , thank u.

After being hit by the no data issue on my new Xperia 10iii, i did some experiments and now the phone is connecting ok to the network, with data.
I think the main change is to use the SW binaries for Xperia version v8a instead of the latest, but could not confirm doing only that will fix the issue since i did much more. If someone wants to try on a phone with the issue, just download SW_binaries_for_Xperia_Android_11_4.19_v8a_lena.img on Sony developper websie and flash it in fastboot mode with command: fastboot -s HQ618J3443 flash oem_a ./SW_binaries_for_Xperia_Android_11_4.19_v8a_lena.img

Here is the complete process i did:
Flash with emma to restore to version 62.0. A.3.109 (Android 11)
Check the phone is connecting ok in Android.
Do a factory reset in Android to remove all data/settings
Turn off the phone
Do a wipe data in recovery mode (Vol- + Power to start the phone)
At this point, i assume the phone is in a ‘fresh’ state.
Flash Sailfish with the v8a SW binaries. I had to modify flash-config.sh and md5.lst.
Reboot the phone once install is done.
Make sure both SIMs are enabled (if i disable the non used one, the network connection is lost)
Phone was connecting ok on boot, but after finishing the installation, i flashed again the SW binaries one more time.
From that, phone is working ok, network is connecting ok even after several reboot.

Hope it can help


Sadly, but following your way and after instering SD card to slot 2, doesnt work anymore, even flashing binaries. Mobile data survived only 2 reboots. FYI now i tried wiping data in recovery mode, reflashing sailfish os (without reflashing android from emma) didnt help, flashing biniaries either.

1 Like

Some followup:
The following sequence

  • Android 12 ( 62.1.A.0.617, newflasher) => SFOS (Mobile data ok till self broken) => same android 12 (newflasher) => SFOS
    brought the mobile data back in SFOS. It worked fine starting with 1st SFOS boot, survived several reboots. I had no WIFI configured during this time. Then after a while it stopped - see below.

(I mention the sequence because I also tried Android 11 => SFOS (mobile data broken) => Android 11 with EMMA (mobile data ok) => SFOS - but that did not get Mobile data back)

In all cases the phone shows 4G connection, with data “enabled”. The data symbols in the status are ok (they don’t display unless data truly works).

So: after reflashing, it worked ok until rebooting the day after => then back to the repeated Unexpected data call status 4100 from ofonod with no mobile data.
It ceased working a bit before taking off so left it like that => after landing, surprise! It started working just fine once abroad with roaming enabled (4G, Vodafone RO).
At some point it auto switched to Orange RO, worked a while then got stuck in 3G with the same error. I could force it back to Vodafone RO - and it kept working ever since.

I will try to structure a bug report - but aside telling that in some circumstance it reliably breaks itself, I don’t know what to describe. I can provide ofono/system logs as well.
As opposed to other reports:

  • it works ok starting with boot (while it lasts) with Dual IP (default settings)
  • Once broken, switching slots, IP setup, etc - won’t help
  • VoLTE is NOT activated so no interference.
1 Like

Could you please enable only 3G and switch Dual mode to IPv4 only. Use SIM1 slot.
And then enable Flight mode and disable in a 5 seconds.

It seems you lost the data after adding the SD card. I forgot to mention that i put the SIM card in slot1 and SDcard while in android mode, and never touched them again.
Also i did not change SIM settings (enable/disable) after getting the data as i saw some weird behavior before: when disabling SIM2, i still have a network icon, (top right of the screen) but no connection at all. If i disable SIM1 and enable SIM2 i do not have any network icon on the top right.
Not sure if it is related, so far not touching anything related to SIM or network, the phone has still data (i can turn the wifi on and off keeping the connection), so i am not making any new experiment.

Tried while in roaming with the phone chosen operator (OrangeRO) => no difference. Hand chosen Vodafone RO works (in either 3g or 4g, with Dual or IP etc)
I can’t test now with “home” network.

I should not have posted this, as this brought bad karma to my phone.
This morning the data connection did not survived reboot, and i was back to initial stage :frowning:

But i was able to revive it quite easily:

  • turn on the phone → no data
  • go to Settings → Pin code: turn off ‘Require PIN code’
  • reboot
  • Data is back.

Not sure if this is reproducible, if someone can confirm, it would be appreciated.


I just tried that, no luck for me. I keep getting “limited connectivity” and mobile data do not work.

Hello Jameson,
Could you please let me know if you are using the SW binaries v8a (from my initial message) or v9a (default from the Sailfish flash script), to understand if it makes a difference?

Also do you have 1 SIM in SIM1 + 1 SDcard on SIM2, or a different config?


sorry, that’s too much of a hassle to handle for me now, moreover it’s clear from your tests that it does not solve the problem.

Hi i have the same problem while roaming, the status bar shows 4G but there is no real connection. Switching to 3G it actually drops to 2G, hence impossible to check further.

Okay, got something. Its first time im able to make several reboots and mobile data survives.

What i did:

  • inserted sim card into slot 1
  • slot 2 empty
  • flashed 109 Android
  • flashed sailfish 64 with binaries 8a
  • after fresh install i started to play with system.
    Wifi was all the time disabled
    Enabled/Disabled flight mode - success
    Disabled/Enabled moblie data - success
    Disabled/Enabled slot1/slot2 - success
    Changed Protocol IP/IP6/Dual - success
    Enabled/Disabled Roaming - success
    systemctl stop ofono
    rm -rf /var/lib/ofono/*
    systemctl start ofono
    Had to select Use sim card 1 on mobile data to activate it without reboot as mentoined here
  • success
    (you can omitt these steps, was test purpose what will happen on fresh install to confirm if im able to break it. As result it didnt break it and gave me hope that after reboot shouldn’t also, was true)

Its 4th reboot and i still got mobile data. As i mentoined before i was able to reproduce broken mobile data after every first reboot on Sailfish OS 68 with binaries 9a and not matter if sim card on slot 1/2 with or without sd card.


Mobile data still survives after:

  • removed sim card for 1 minute, inserted again on slot 1 and rebooted - success
  • removed sim card, inserted again on slot 1 and sd card on slot 2, rebooted - success

Hello Akikyo,
Thank you for your update, sound promising. Seems your phone is now behaving more or less like mine, so i would like to confirm two items:

  • are you in an area with 5G coverage when you reboot? (i agree it is difficult to say from Sailfish, but if you have checked before while running Android)
  • Is you sim card pin locked?

In the case you end up loosing data, could you try the SIM pin unlock to see if it helps recovering data?


  1. I have 5G enabled on my router
  2. I dont have pin in sim
  3. Ill try

I have question to you, becasue you didnt say anything about this. What version of Sailfish OS u have?

First i wanna thank you guys for testing and reflashing.
But tgese tests don’t proof anything. Many people including myself had mobile data working correctly after a reflash. Mine was gone after updating to .68.
To trst your solutions, i think you should reflash at least 3 times and see if it still works using your method.
But if it is working now i wouldn’t risk breaking it by reflashing.
I hope for a fix by Jolla.