Unable to use mobile data on Sony Xperia 10 III

Thanks, @flypig, for boosting the bug report – keep us posted!


Okay, if anybody facing problem with mobile data. I had to reflash system. But first i checked version of Android in Emma. My version was .70 in the end. 2 updates away from 62.0.A.3.109. I flashed Android with version 62.0.A.3.109, went thru system etc. Then flashed once again Sailfish OS and now works like a charm! (on sim1 slot) @flypig would be nice to precise what version should be in installed before flashing Sailfish - if thats the case.


To add some extra information about my situation in case it helps. I hadn’t updated android at all before flashing with sailfish, I don’t know what version of android 11 it had but it’s whatever it came with when I bought it new from elgiganten in Sweden.

Nice spot, @akikyo. I have reflashed with .109 but I don’t know which version was on earlier, probably an older one since I never updated it. I still have to re-test though.

No problem anyway, after reflashing SailfishOS mobile data do not work. Only with Vodafone. WindTRE works.

Based on reports of the wifi toggle interference with 4G, I’ve had some success by turning off wifi, going into airplane mode, restarting network connectivity via Sailfish Utilities (installed via Jolla store), then connecting to internet via 4G data again. Restarting the phone also does the trick, if I go straight to connecting via 4G. A plug for NetMon VoLTE checker (installed via Storeman or OpenRepos) which is a big help.

Hm, I re-flashed twice with 62.0.A.3.109 (as indicated here) and I am still having this problem…

The issue appears to be weird.
As I said, reflashing to Android and then to SFOS again did not help.
Reflashing once again to Android, testing 4G connectivity under Android and then reflashing SFOS once again got the system working.
But I cannot get a clear pattern of reproducibility of the issue.

Yes. When i bought phone half year ago, i didnt update nor test it truly - i didnt put sim card. So in my case, the phone had old Android 11 with directly flashed on it Sailfish. Updating to latest Android 11, testing, confirming it works with sim card, flashed once again Sailfish.

To add some extra information about my situation in case it helps. I’m used to stream audio on my commuting way where there is a tunnel with no connection, Xperia X had some issue, but now it reconnects fine. With first use of Xperia 10 III today, I had to restarting network connectivity via Sailfish Utilities (wifi logo state was connection ongoing).

SIM2 is used by sd card and VoLTE not enabled.

Have a nice day.

I added this issue to the list to discuss at next community meeting. It’s in the middle of the night for me; is anyone else able to make it as a substitute to ensure the issue is brought up? @jessica @miau @ender ?

Unfortunately I’ll be travelling so won’t be able to make it either.

Just for completion sake: All my issues are gone since switching to sim2 (haven’t tried enabling volte on it) and at least for me mobile network connectivity on XIII works better than on jollaC which from around 4.x started having hiccups that would require turning mobile data on/off to get going again every now and then



Sorry, i can’t make it either to the community meeting.

Switching to SIM2 made no difference for me and this is also not an option for everyone who wants to use an SD-card.


Just want to point to this issue that might be related:

I’m not 100% sure if I stumbled around the same issue, but please have a look at my bug report too. I didn’t change the SIM card from slot 1, but with some tweaking, I am able to have full connectivity with VoLTE enabled.

Thanks to @cyberlyra for connecting these issues!

Thanks for showing up, @direc85 !
If the issues are indeed connected it could solve a lot of problems in one go.

1 Like

i get this issue constantly as well. about half the time, the cause is that i have two default IPv6 routes. removing the incorrect gateway fixes it. the other half of the time, i have no idea what causes it, but i have no mobile network

disabling VoLTE and restarting ofono fully breaks my mobile network stack, tho, and i must fully reboot to get mobile data working again.

disabling VoLTE and NOT restarting ofono fixes it sporadically.

also, i cannot just remove IPv6 routing as my telecom (T-Mobile USA) requires IPv6 for MMS.

The same issue with my Xperia 10 iii.
For me this did the trick: disable 4g and choose only IPv4. Enable roaming. Reenable internet.

for the last two days I have no “limited connection” issues. I am keep looking.

No VoLTE, SIM1 slot, Yettel.


1 Like

Hi! I have same problems. Now while I’m travelling I cannot connect mobile network. My trip started Finland then Estonia, Latvia, Lithuania. All these countries mobile net worked well. Then Poland mobile doesn’t work at all. Then Czech worked and Hungary also. Now in Croatia it don’t work. My sim is Finnish Elisa saunalahti. I tried all whats in this tread. Help is needed.