UI-Themer missing from OpenRepos

sorry but on my Xperia 10with 3.4.24 its working. Theme_pixel_ratio without any problem.

Strange. I’ll do a reflash then, something must have went wrong. I am having some other issues, too.

I have the same issue 3.4.0.24 on XA2. Please let me know if flashing the device helped you.
I already had to reflash because alien dalvik wasn’t working anymore, really hope to fix that …

forget it - do not go through the trouble of reflashing, it does not work:
I reflashed
I updated to 3.4
sailfish-configs.txt in locks could not be commented out, even with setting chmod to 777
I set the vendor.d folder to 777, so I could delete the files and created them new with 777 rights
no chance, still locked :frowning:

something locks that string. Maybe it works in recovery mode, but I am sick of trying now. I’ll use an old android or windows phone in the meanwhile until ui themer is back :frowning:
EDIT: of course it does not work in recovery mode since no comments are accepted - its just a recovery
EDIT2: i wont give in: strange thing: after setting the pixel ratio manually in the config file in vendor.d (not in locks dir) to 1.45 it did not change anything after a reboot. Now I just did a devel-su dfcon read … and a devel-su reboot.
after reboot the dfcon write command worked, but only if used with the number in the silica config file. another devel-su reboot and VOILA, pixel ratio changed.
I do not get it, but it worked that way.
I used WinSCP and putty for all this mess.
But now I still need the right icon sizes, nothinng shows up

!!!
#EDIT3: do not do that, I messed up insanely. no icons or symbols, device is unusable -> reset.

Thanks for the details.
That’s sad, i’m going to flash back on 3.3 until someone find how to fix that.
I doesn’t want to use the device with these pixel ratio settings, that’s just awfull.

1 Like

See here, maybe this is of help to you before downgrading the OS;

To sum it up on 3.4:
Dconf write definately does NOT change the setting in the vendor.d config file.
Also something locks the file in the locks dir, it cannot be commented out, even with rights. If one makes all changes with workarounds like I did, the device needs to be reflashed again.

Maybe someone from Jolla can tell us, where the pixel ratio settings file is located in 3.4??? Please.

Oh No. I just had to reflash and wanted to use my “My Data Transfer” backup.
Now i realise the rpm is gone :frowning:
Does someone have the rpm?

1 Like

Well, I have used it since forever and sort of miss my previous themed look. I’m not someone who can help you develop it though, just a feeble user

I did some experimentation to get DPI changes working on 3.4 (I’m on the very latest 3.4.0.24), and I’ve discovered a way to make it work since dconf write no longer seems to work, even with the vendor locks disabled:

First, make sure you have the sailfish graphics packages installed:

devel-su pkcon install --allow-reinstall -y sailfish-content-graphics-default-z1.0-base sailfish-content-graphics-default-z1.25-base sailfish-content-graphics-default-z1.5-base sailfish-content-graphics-default-z1.75-base sailfish-content-graphics-default-z2.0-base sailfish-content-graphics-closed-z1.0 sailfish-content-graphics-closed-z1.25 sailfish-content-graphics-closed-z1.5 sailfish-content-graphics-closed-z1.75 sailfish-content-graphics-closed-z2.0

Make your edits, for example, I edited /etc/dconf/db/vendor.d/silica-configs.txt and set it to the following:

[desktop/sailfish/silica]
theme_pixel_ratio=1.25
theme_icon_subdir='z1.25'

After saving, I used dconf compile to recompile the keys directory into a binary, like so:

dconf compile /etc/dconf/db/vendor.new /etc/dconf/db/vendor.d

Then, backup the old vendor file:

devel-su
cd /etc/dconf/db
mv vendor{,.bak}

Then move your new vendor file into place:

mv vendor.new vendor

After rebooting, your DPI will be set, and your icons will show up since you have the graphics packages installed from earlier.

I just tested it on two XA2 Ultras, one fresh flashed, and one OTA’ed.

I hope this helps someone, at least. Let me know if you run into any issues.

8 Likes

THX a LOT! really! much appreciated.
Pixel ratio changed that way, strangely icon size in the grid did not.

1 Like

Working ! Thanks a lot for your help.

1 Like

My pleasure, hope it helped to some degree at least.

Still working on some other experiments, we’ll see where they wind up.

Awesome, glad it helped!

I am trying stuff, too. I think it would not be too hard to create an app, at least for DPI change and icon sizes. I am just looking through the SDK. I will also bring it up in one of the next IRC meetings to include it in settings.

1 Like

Something about dpi settings for aliendalvik guys ?

fravaccaro - seems like it couldn’t hurt to at least leave the current versions accessible as they are, or maybe at least provide a link to rpms… Many devs choose to stop developing certain apps, bit still leave repos accessible.

Thanks for your work.

Anybody else who has it installed able to biild a shareable rpm yet for themepack support?

1 Like

I think the interest is here, what license were you considering?

This is the one thing that works for me, (@deprecated’s solution)… Question - why does it work this way, but just changing the values in the silica config file has no effect, even though the changes are persistent, (just curious)?

I’d also like to know. Maybe ask at the next meeting. Sadly I never have time at 9:00 am. When this is solved, making an app should not be a lot of work I think.