Two troubles with stores

Trying to install the correct stores as described in Security relevant issue: what store is trusted and how to know, I have run into troubles. They may be somehow device specific, but maybe also not.

I’d be curious if someone else has had (or solved!!) them. Since stores are essential for a few apps, it is a bit troubling not to be able to use them. Tried many times also reinstalled all involved apps.

We have two phones with to different difficulties (sailfish is up to date):

  1. Sony Xperia XA2, FDroid appears in the Jolla store, but when trying to install it, it waits and then fails.
  2. Sony Xperia X, FDroid works fine, Aurora Store installed, but when trying to get an anonymous session, it notifies that all worked (“no error”), but then fails to connect. It seems pointless to need a Goggle account on sailfish, but that would at least go one step further.

Could it also be a jolla account issue?

Any clues are welcome!

For F-Droid, try installing its apk from its official website : https://f-droid.org/

The Aurora store app sometimes needs updates. Try to refresh packages in fdroid.

Now for some feedback, thanks for your comments.

Indeed after a complete reinstall of FDroid and Aurora, all went well and works now.

On this phone, still no way to install FDroid. Other apps are fine, I’ve just installed FileBrowser without a problem. “FDroid couldn’t be installed” (no further reason given).

Any idea what I could try? It is a bit of a show-stopper, because of the dependence of Aurora on FDroid. Could it be connected to a problem with the sailfish licence (it is an android support thing)?

You could try to install the apk directly, there are download sources on the web (of course only install from sources you trust).
On the other hand I am pretty sure that it must be possible to install from fdroid

I’ve downloaded F-Droid.apk on my laptop from f-droid.org, transferred it via sftp to the /Documents folder and then used the file browser app to open it. All that happened was that another version of the same file was downloaded. How to do this? (this suggestion to just tap didn’t really help)

I’m sorry, this is really puzzling and beyond my understanding.

Just for my understanding: normally, when you go to the f-droid website with the jolla browser, you should be able to directly install the store from there?

You can download the APK from here without installing any other store.

https://www.aurorastore.pro/

Download the apk, go to Downloads folder, tap on the apk, then pull down menu + install.

Try to always have the latest version, older versions will not work.

Yes, first thing you see on the website is the download button, and when you tap the downloaded file it will be installed (in case you allowed third party apps)

This gives

Error 1020

Ray ID: 6ee502adfaa892c5 • 2022-03-19 08:59:10 UTC

## Access denied

Very strange. I checked with laptop just now, clicking the link from your post above. Homepage is available and download (for testing) worked. Have now a fresh downloaded apk on my harddisk.

I recommend download the apk with computer, copy to the phone and install local. Other ways may not work now because of early access version mess.