The Volla 22 (Gigaset GS5) Thread

Maybe I’m a bit silly, I cannot seem to run any other but the stock os on my rephone, neither ubuntu touch, nor volla os, nor droidian nor sailfish os works, I only get to fastboot or even the mtk preload after flashing any os.
Might it be a problem that the phone was upgraded to Android 12 before trying to flash a different ROM?

I got the same problem,
I have update on gs5 of May 2023 kernel ver. 4.19.191

I have started my attempt, using the rephone as my daily driver, so I’ve donated @piggz some beer.
Anyway I’m not completely sure if it really gets my DD, even so most things work not too bad. So I have to weigh out the downsides of the rephone vs. the downsides of the X10 II.

So what are the points which let me doubt a little bit:
In the end I can bring it down to two things: Network and some strange performance problems.

Network - There are some Issues with network: On the first view just minor things but alltogether somewhat annoying, especially with the

  • Not working sailfishconnect
  • All WLans show up three times and I’m not sure if it makes differences which one I choose
  • There are two WLan interfaces showing up when looking on networks with ifconfig. The device always connects with wlan1 whereas wlan0 is most of the times not connected, which leads to an empty field when you look on the developer-tools in settings.
  • Until now I never had problems with the Simcards regarding SIM-Card registration. But unfortunately I have as well a strange issue. I have no clue, how good or bad the signal is, because the indicator ALWAYS shows just on line. It doesn’t matter if the signal is good or weak.

Regarding the Performance. It is generally speaking good (much better then the Xperia), but i quite often have strange lagging periods, where the device is hardly to operate.
If fingerterm is open this issue is 100% reproducible. But sometimes as well without knowing at all what lead to this behaviour.
Yesterday evening I had a more then one minute long period with just 2 apps open, where the device was so laggy, that it hardly accepted any input.
Here is a output of dmesg, when the lagging happens:

Are you using waydroid when it gets sluggish? It was reported that there could be a memory leak in waydroid-sensors, and closing/opening waydroid gets around it temporarily


and thx for the donation :slight_smile:

Thanx for all your porting work. :slightly_smiling_face:

I haven’t installed waydroid yet. So this can’t be the reason.

1 Like

Strange that this SIM issue is not happening to all. Maybe dependong of the country/operator…

I also made a donation to @piggs some weeks ago for the porting(s) big work.

I indeed had these mini-lags on the phone. But very short, like 1/4 of second.

But still wondered to see SFOS on it!:heart:

1 Like

What is sailfish connect? I’m probably being thick.

It just works without choosing, but if you do, choosing the first one works for me :slight_smile:

Strange. I get this on the GS5 but not on the rephone.

I noticed this, too, but since 4G signal is generally ‘good’ it hasn’t bothered me. Where the signal degrades (village where my inlaws live), I often (but not always) get dropped to 2G (2.5g?)

That sounds very strange. I’ve not experienced that on either GS5 or rephone. Lagginess that I have experienced is similar to that on the xperia 10iii.

@piggz, the android install should be 11, or? And a safe way to go would be to use the VollaOs install first and then install SFOS (that’s what I do)?

This is Sailfish connect:

Yes for me it works as well, but having problems with Sailfish connect and the issue, that The device is most of the time connecting via wlan1 I thought I ask, if it make technically maybe makes a difference

It was until now just once, that it reacted that badly anyway lagging is quite often. Mostly not really bad but still quite annoying and worse than on the Xperia 10II. And always present, when Terminal is running in background.

That was exactly the same what I did.

Ah, ok, kde connect. I wonder if it might be related to an issue I have with the GS5/rephone that I forgot to mention. That is, QML debugging does not work as on other phones. Somehow, though the qmllive service are active and the port open, the SDK does not connect. If the service is on the wrong interface, that would explain it! My to-do list is growing long :slight_smile:

I had noticed a LOT of activity and battery drain, which ‘seemed’ to abate with but I’ll need to look again. EDIT: just checked and it’s a lot less activity with .21.

I’ll have a look a the extra wlan0 device and see if I can finally get qmllive working.

1 Like

I’ve send you some beer, so you can look more relaxed on this list :yum:

By the way. I’ve installed waydroid in the meantime. And the performance compared to my Pro1 is much worse. Is this normal and has this to do with the memory leak which @piggz has mentioned? That’s not an big impact for me, because I hardly use Android apps. Just wanted to ask.

And further by the way: At the moment it looks like i stay with the rephone as DD. I have listed things which do not work properly, but I should have mentioned as well things, which work (at least so far) much better than on the Xperia 10 II:

  • Fingerprint sensor works flawless and without hicups.
  • I often had problems booting the Xperia, because of the encrypted home partition. I sometimes needed up to 5 or 6 boot processes for having a running system (I had that on my Pro1 as well). The rephone boots so far very reliable without any hicups.
  • To run Puremaps and OSM Scout I always needed to switch on frame rate view, to avoid these apps constantly crashing. On the rephone they simply just work.

So all in all, yes, there is still some work to be done, but the port quality is not worse than the official builds. Great work!

Heh! Thanks!

I really don’t have any waydroid experience. @teracube or @Pasik2 or @Seven.of.nine I’ve lost track who has what device!

I’ll see if I can get to rephone / gs5 debugging tomorrow. The network and video issues (documenting the lives of children!) are keeping me from using the rephone as a daily which is a bit sad since it’s extra ram is nice.

1 Like

I also have a Pro1 and Waydroid’s performance is much worse on the Volla 22. The whole phone is more sluggish when Waydroid is running.

1 Like

Thanx for this info. So i see that as given at the moment.

I’ll ditto that. Not sure if I can help on that front since I don’t use android stuff. But @piggz seemed to be aware of a memory leak so that sounds like a plausible avenue of investigation.

Can someone tell me if Hotspot is working?
I have unfortunately tried to install blocky (Adblocker) before testing if hotspot is working.
After that I read, that there is a problem with hotspot, when you install blocky. And indeed hotspot didn’t work. So i uninstalled blocky again, just to recognize, that ads were still blocked. So I installed it again, stopped the service, disabled the service and uninstalled blocky again. now ads are here again and I’m able to connect to the phone again. But unfortunately without getting acces to the internet (restricted connection).
So now I’m unsure if I broke something or if that is an issue of this port.

when I try to start Waydroid I get this message

$ waydroid log
(005115) [00:02:42] Failed to get service waydroidplatform, trying again...

Has anyone else had this error message?
Waydroid was installed with chum and the correct settings made in waydroid-gbinder-config-hybris.

Have you done this?:

I don’t remember. I’ll try tonight, back home and report.

1 Like

Yes, I did it, like GitHub - sailfishos-open/waydroid: Waydroid packaging for Sailfish OS
Now, I reflashed my GS5 (as Volla Phone 22) again and tried with fresh Installed only chum and waydroid, but the log is the same.