The Volla 22 (Gigaset GS5) Thread

I also thought i could return it and claim DOA.
Question is: Do i ask for a replacement GS5 Lite or go for the Xperia X III, the Sony is more expensive but i guess the chance for success is higher.

What do you mean by “Both types of reboot”? The phone is unresponsive to any kind of input.

I have two functional GS5s with SFOS which have only the irritation with the SIM card not being recognized from reboot. My son has a GS5 which did some automagic update while he was playing a game and self-bricked. Resting that (from the firmware) worked. It’s a reliable phone.

Sadly, I always forget how to get to the ‘recovery menu’ on these phones:

I always forget the boot sequences, but there is power + up and power + down … I always forget since I don’t have to do it often. In any case, by a combination of the two, you get to the recovery menu where you can do stuff like wipe cache/user partition, factory reset, etc. It’s something like:

  1. power + up till it begins booting
  2. power + down
  3. recovery menu

But it might be restart with power + down. You could also try to use fastboot in this manner:

  1. plugin phone to usb (powered down)
  2. enter boot with volume + up
  3. type fastboot reboot-bootloader on the pc

Finally, did you try:

  1. power down phone, disconnect usb
  2. start ubuntu installer
  3. connect usb
  4. start phone with briefly held power + up

To see if the ubuntu installer sees is?

I’m guessing that what happened is that on flashing volla over the native android the user partition wasn’t erased properly and when it tries to boot it get’s a wrong layout or some such.

It’s very probable that you can recover it’s just impossible to find reliable information as I’m demonstrating right here ;-(

Also, what happens if you do:


when the phone is plugged in and you power it up?

There is no response from the phone when i press up+power or down+power (i even tried up+down+power). Just to be sure: Phone seems to be off (notification led is off, display is off), I’m pressing the key combination keeping them pressed and expect a response within 20 seconds.
I found this website:
Since the menu isn’t displayed i can’t select recovery.

Since the phone doesn’t do anything at all, there is no route to fastboot. Except for charging there is no activity on the USB bus.

1 Like

Ok, it’s probably just lame. I’d send it back. If you could start on that, say contacting the seller about returns, I should have a test run at the process in the next day or two and can document that more carefully here.

EDIT: of course there’s nothing to keep you from going with sony. In my experience that install is more complicated (from installing xperia 10ii with license and sony dance).

I bought my phone at a regular shop, not a webshop, and i’m planning to go there next weekend. They don’t have the GS5 on stock so if they are willing to give me a new one it’ll probably take a few days from then.

I’m a bit surprised by your remark about the official install, i’d expect supported=easier :slight_smile: . I think i’ll try a GS5 again, the GS5 fits my needs better than the Xperia.

So, just for info, using the ubports installer bricked my spare GS5, too. Same symptoms. Presumably, volla has made some changes. So, BIG FAT WARNING do not use the ubports installer.

1 Like

It’s just more involved since you have to go and get a code from the sony opendev program and subsequently the install has more steps. Went fine for me with my xperia 10ii.

The ub port installer work without problems…!
only volla os detect no simcard!!!
ubuntu touch without problems

Hmmm. I just tried it and it completed all the flashing, but the device did not come back up. Pulling the battery, letting it sit, restarting with all combinations of keys. Nothing started it to the boot menu. No idea if something has changed, but it didn’t work twice in a row, so I’d be cautious?

I’m sorry to read you have the same result. I also have to admit it’s good to know the problem isn’t specific to what i did.

Your result does bring me back to the question of GS5 vs. X10iii, if it’s not possible to install SailfishOS on the GS5 there’s no reason for me to have a GS5.

Do these steps also apply to the free version of SailfishOS? I don’t care for the extra features the licensed version provides. Or are these steps necessary to unlock the bootloader?

To unlock the bootloader.

Ah, but it is possible. I have a device that I flashed successfully. Only, I neglected to make notes. It’s not really helpful for you to know this since it’ll take time before I figure it out. I’ll get back to the GS5 next week.

Someone in the 10 iii battery thread mentioned that they disabled the ‘battery’ saving 90% setting and are seeing more normla battery behaviour (ie. minimal drain on minimal use). But, yet another anecdote. I just saw returned 10 iii phoneson ebay (germany) for 179-199 … at those prices I might buy one just to have a more up-to-date ‘official’ device.

Hallo Mr. Poetaster

can i update my GS5 to via ssu re…

that’s a question for @piggz … but you can always check what’s avail here:


Is this only for the Volla 22 or also for the Volla (GS290)?

A short update on my story: Last sunday i went back to the shop where i bought my GS5 and asked them to swap for a X10iii. They took the phone and wanted to verify it’s not dead because of something i did (which is their standard procedure). Yesterday they confirmed to me they cancelled my order for the GS5 and will give me a full refund.
As a happy coincidence they have an 80 euro discount on the X10iii now so that makes it even more attractive. I’ll post about that in the appropriate thread, I just wanted to say thanks for the help here.

Thanks for the note! I’ll report what I find on the next GS5 flashing round. I also found an xperia 10iii for 160 euro new (!) so picked up one for debugging …

What might be more relevant than the nice discount is my impression that this discount means the X10iii is going away. Given the low availability of the black version and that the white version is already gone, this might be a last chance.

I just found one on ebay (germany) by chance. Since I always ‘need’ an official device to test if something I’ve built is ‘just broken on my port’. The xperia 10ii was a bit suck (it can’t render opengl scenes that, for instance, the volla / GS290 can) so I’m happy to have found one new under 200. Now I can sell the 10ii.

So, I managed to rescue the GS5 (a long ugly story in itself). I got it stock up to version 12 (with the Gigaset updates). So, hardware looked ok. Then I did the flashing, again. It’s weird. This time, after making sure the boot loader was unlocked and booting into the ‘normal’ Anroid, I said, what the hell, and tried the VollaOS install via ubports again. This time, it succeeded, did a reboot and the Volla logo appeared. Yeah! I thought, nope. It stuck there in a fastboot loop. So, I did a bootloader reboot into fastboot to try again. Same thing. Said, the hell, and since I’m in fastboot, tried flashing sfos (the image from nov. last year). And I have a dead phone again.

I’m not sure what has changed. I’ve flashed my main GS5 3 times without ever having an issue. I even tested the cables first. I’m stumped.

Te sony arrived in the middle of the process and it’s now runing sfos. Ah, well.