The screen goes black and that's it

REPRODUCIBILITY (% or how often): 100%
BUILD ID: 3.4.0.22
HARDWARE (Jolla1, Tablet, XA2,…): Xperia X
UI LANGUAGE:
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

After boot in about 10 seconds the screen goes black (it could happen even before entering the PIN) and I haven’t found a way to bring it back without a new reboot but only for 10 seconds again. While ringing I was able to silence the phone and with power button I can restart it but that’s it.

PRECONDITIONS:

Phonehook

STEPS TO REPRODUCE:

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

2 Likes

I think I have the same issue. It seems like lipstick is crashing and I do not understand why. Here’s a journalctl -xe log https://pastebin.com/F1S319AV
I can still connect via SSH, but can’t update the repos and redo the update.

Required one missed call and reboot after that to get it working.

1 Like

More or less same with me: But I can enter the homedir decrypt code before.
I now just did a factory reset and upgrade from scratch. For me it was a too full system partition.

How full was full? Because the system partition is only 1.5Gb and I wonder how one can increase that on sailfishos

System told: Need 620M have 606M. And this is very much for the partition. It told it need 790M for upgrade. .
And now I am just upgrading from a clean system (from scratch) and then recover (thanks to restic and an s3 store this will not need too much time…

Some additional information: I did a version --dup after the memory message and it told libc does not fit (there was only the old image available). So if you get the error message with the missing memory it is IMHO too late.

Do you have installed phonehook? I have the same issue and I solved it uninstalling phonehook via ssh

5 Likes

thank you, this worked for me

It was phonehook. I was fast and could remove the phonehook in the first 10 seconds after restart and in brought the screen and phone back.

2 Likes

Thanks for tip. Solved my problem too. :relieved: First time ever phonehook caused problems :sweat_smile:

1 Like

I may have the same problem with X10+:

  • I first got the info that I needed more space to complete the upgrade to 3.4.
  • I deleted an app and could lauch the update process
  • the update run for some time until an error message (something like ‘could not be finished’) and the option only to reboot
  • but lipstick seems to crash as it passes the first unlock but then the screen flashes. The same occurs after many reboot
  • I can access the phone via ssh but the phone screen remains empty
  • I noted that ssu release was still on 3.3 but the terminal shows that the phone is under 3.4. This points at an unfinished update
  • when I run version --dup from cli, I have an error message

Error: Medium not attached: plugin:/ssu?repo=adaptation0
Finished transaction (status=2, runtime=3609ms)
UPGRADE NOT COMPLETE - Retry 1 of 9

There is the same message when I run the version–dup on release 3.3 or 3.4.

found it by myself :wink:
devel-su pkcon remove phonehook

2 Likes

I have the extract same issue on an XA2. Also appearing when release set to 3.3 and 3.4.

I’m able to curl the repo so it’s not a network connection issue.

EDIT: Also checked if my Jolla account was enabled which it was.

Link: https://jolla.zendesk.com/hc/en-us/articles/360001643933-Checking-accounts-from-command-line-ag-tool-

EDIT 2: Sadly it’s not possible to skip repo check just install with cache using "version --dup.
it might be possible to update using “pkcon update” but also risky.

For me it was patchmanager. rpm -e --noscripts patchmanager

1 Like

Had the same problem, update broke. and asked for help in the telegram channel

cp /usr/lib/zypp/plugins/urlresolver/ssu /usr/libexec/zypp/plugins/urlresolver/
and rerun version --dup after doing that

The reason my installation broke was aliendalvik-control so i had to remove that before the update would work rpm -e --noscripts aliendalvik-control

2 Likes

I tried to follow your suggestion but “version --dup” is stuck at “Refreshing: 0%”. I tried waking the device by tapping at it to it doesn’t not help.

EDIT:

“zypper refresh” is a bit more informative.

Retrieving repository 'adaptation0' metadata ..................................................................................................................[error]
Repository 'adaptation0' is invalid.
[adaptation0|plugin:/ssu?repo=adaptation0] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'adaptation0' because of the above error.
Retrieving repository 'adaptation1' metadata ----------------------------------------------------------------------------------------------------------------------[|]
Retrieving repository 'adaptation1' metadata ..................................................................................................................[error]
Repository 'adaptation1' is invalid.
[adaptation1|plugin:/ssu?repo=adaptation1] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'adaptation1' because of the above error.

So it seems like the issue persists despite copying the file as suggested.

exactly the same here, stuck at 0% :confused:

i was to, for about 20 minutes. but then it started ticking up slowly

I have similar. Upgraded to 3.4 and while I can enter the pass code to decrypt my device I get blank screen as soon as Battery Overlay then starts.

My USB us set to “choose” so can’t select connect via developer mode on the phone so would welcome advice on how to access via putty etc. and how to delete disable battery overlay which I suspect is causing the problem please?

Thanks in advance.

If your phone is not connected to wifi and therefore you can’t reach it that that try this:

You should get into recovery mode: https://jolla.zendesk.com/hc/en-us/articles/360002996893-Xperia-X-devices-How-to-use-the-Recovery-Mode

After recovery mode has started, telnet to the device and press the number to start a shell.

After starting a shell you can type this to mount the home partition:
mount /dev/sailfish/home /rootfs/home

As the root partition is already mounted and ready for chroot type this:
chroot /rootfs

You’re now in chroot and should be able to manipulate the system and uninstall packages.

When ready to reboot, just exit the shell by running “exit” to times and press the correct number to reboot the device from the recovery shell.

2 Likes