The screen goes black and that's it

@Louis thanks for the very quick response and for the link to using recovery mode. I’ll try to access via wifi first as I don’t fully understand all that you’re saying about telnet and chroot.

maybe you can add phonehook as a precondition to your bugreport :slight_smile:
if your topic is still editable for you.

That did it for me. After a bit of time it started installing packages and then some time after the display was back.

1 Like

I had same problem, but managed to select mode by plugging usb right after entering pin-code just before blanking happened.

1 Like

same here. I was stupid enough to trigger the update without uninstalling phonehook or patches. Upgrade told me Backup did’t work, then Upgrade downloaded, then Upgrade installed, then splashscreen informed update did not install, I should restart for prevous state. That last part did not work either, my X10 has a black (dark blue actually) screen since. coupe of times it arrived to sony’s unlocked warning, though.

@ninepineIf you can’t connect via wifif and you need further clarification please me know.

I finally managed to update my device. Just have to wait on “version --dup” to finish refreshing.

1 Like

Thanks for the suggestion, added phonehook as precondition :slight_smile:

1 Like

I can report back that I managed to finish the upgrade. I will report what I did but not sure exactly what solved it:

  • I changed ssu release to 3.4 as it remained stuck in 3.3 despite some packages updated to 3.4
  • as suggested here, cp /usr/lib/zypp/plugins/urlresolver/ssu /usr/libexec/zypp/plugins/urlresolver/ may have opened the possibility to rerun version–dup
  • I also did ‘pkcon download . ssu’ to manually update ssu package (following suggestion from @mal)
  • I removed (not sure it helped) using pkcon: aliendalvik-control (even though I had updated to the version coderus said was compatible with 3.4) and storeman (the dev said it was not working until a fix)
  • you have to wait for some time before version–dup completes. The first try ended up with an error message but an automatic retry worked.
  • I could reboot. To make it safe, I rerun version–dup and indeed it found further packages to update
  • another reboot and version–dup finally says no available updates

voilà I can enjoy 3.4 now :slight_smile:

1 Like

@Louis Many thanks for the help.

I managed to login via putty and wifi.

A username of defaultuser would not work however giving “Access denied” when I entered my password.

But I could login using username nemo and my password (which is different to the advice on Zendesk) (I’m going to set my USB to developer mode from now on)

Then using

pkcon remove phonehook


pkcon remove harbour-batteryoverlay2

I removed both Phonehook and Battery Overlay.

Rebooting my Xperia 10 Plus now works fine and it’s back to normal running!


Thanks again.

NB Now I’ve got 3.4 Google Calendar Sync seems to be fixed too.

1 Like

Glad it worked out.

Just make sure your device is correctly upgraded please run these comnands:

ssu re
version --dup

If anything gets installed please to a reboot afterwards - eg. by running “reboot” in the terminal.

The default username will continue to be “nemo” on existing installations. Only new devices installed with 3.4.x or later will use “defaultuser” as default username.

Thanks, Have done that.

Got an error about Alien-dalvik

Failed to stop aliendalvik-sd-mount.service: Unit aliendalvik-sd-mount.service not loaded.
/var/tmp/rpm-tmp.ZMAjXS: line 32: syntax error near unexpected token fi' /var/tmp/rpm-tmp.ZMAjXS: line 32: fi’
error: %preun(aliendalvik-control-9.3.0-1.armv7hl) scriptlet failed, exit status 2
error: aliendalvik-control-9.3.0-1.armv7hl: erase failed

And finished with

Waiting 1 seconds before retry.
Refreshing: 6%^C


Try to stop Android Support under Settings and then rerun “version --dup” as root. Should work now.

No issues now. “NO UPDATES FOUND” so looks like all good.

Many thanks again.


If you manage to begin uninstall before the screen turns black (which is possible), and the screens turns black after you clicked the cross, then you get back the screen after it uninstalls (it continues uninstalling while the screen is black).

Had same problem with Phonehook!
Your solution really helped, 10s for unlock, the phone, and uninstall Phonehook, to get out of the black screen problem. As soon, as Phonehook get uninstalled, the Screen goes back to operational state, and it was the only problem with the Upgrade!

On the OP:

There seems to some issue with patches which causes the screen to blank after activation.

Specifically, Jolla has apparently broken all “overlay apps” in this release.

On a freshly flashed system:

I installed Patch Manager but no patches.
Installed “Battery Overlay”

On activation of Battery Overlay, the screen blanked.
On reboot, Patch Manager autostarted Battery Overlay and blanked screen


Can confirm that, same issue here with phonehook and battery overlay.

I can confirm. Same problem, same solution. Quick uninstall of Phonehook did the trick, and the uninstallation continued even if the screen did go black (before getting back to normal when the uninstallation was complete).

I am having trouble uninstalling phonehook. I have managed to connect to the device in recovery mode via telnet. /dev/sailfish/home does not exist so I mounted /dev/mmcblk0p28 and chroot into it.
However, when I try running pkcon remove phonehook I get:
“Failed to contact PackageKit: Could not connect: connection refused”
Also, devel-su requires password which I don’t know(developer mode is disabled on device).

Any suggestions on how to repair the device?

You can disable phonehook by simply renaming the two directories associated with the program:

cd /usr/share/
mv phonehook phonehook.old
mv phonehook-daemon phonehook-daemon.old

After that, type ‘exit’ twice and then ‘2’ to reboot. You should be fine from there.