Situations-Sonar can not intalled on Xperia 10 ii

I noticed that unfortunately the app situations not abel on a Xperia 10 ii aarch64 4.3.0.12 to switch off the mobile data at night and WLAN can no longer be controlled either. Every time I want to open the app situations reinstall the situation sonar daemon. But when I check the page “about” after it is not installed.

My question how can I install the deamon separately?
Anyone else have this problem?

Oh yeah, I have the similar question too:
IIRC, the ability to install sonar was proposed on first Situations launch.
I restored my /home partially on a new reslashed SFOS and then reinstalled Situation.
I believe Situations thought it was already installed and didn’t propose to install Sonar.

I export the settings, delete the .local files and reinstall situations. But every time if I open situations I get a task to istall sonar. If I make this I get a positiv notification but in the page about I can see, that situatins this deamon not can see. I think it is a problem with sailjail.

Try through devel-su zypper

ould you exlplain more details please?

zypper sonar

not work

It would be (as root)

zypper search sonar

and

zypper install [the package name you found with prev. command]

But sonar is not found that way.
Now I remember, sonar can also be installed separately.
Infos here:

2 Likes

Delete situations-sonar. Download from: Releases · pastillilabs/sonar · GitHub. And install:

devel-su zypper in /home/defaultuser/Downloads/situations-sonar-0.0.9-9.aarch64.rpm

pherjung thanks for noticing!

1 Like

I try this but got only erros :frowning:

File is on the wrong path, because command has been executed as root (where’s main path is /root). So once you’re logged as root with devel-su, you should execute following command :

zypper in /home/defaultuser/Downloads/situations-sonar-0.0.9-9.aarch64.rpm
2 Likes

Thanks verry much for your help. This works but I have to uninstall sonar before. how can I make this?

I fond the way without uinstall harbour-situations. Only uinstall sonar and intsall sonar with zypper (root).

devel -su
pkcon remove situations-sonar
zypper in /home/defaultuser/Downloads/situations-sonar-0.0.9-9.aarch64.rpm

vola situation can use sonar - Thank you very much!!!

2 Likes

I can install Sonar using the method outlined in rdomschk’s post above but I still get the message that Sonar needs to be installed when I try to set up a situation. Initially I see that Sonar is installed when I open the Situations information screen but then later when i go to that screen I see that Sonar is showing as not installed. Any ideas?

Hello - yes since the update to 4.4.0.68 the app Situations not found the sonar service :(. I reinstall it with my command but its not work. Maybe the sandboxing is the reason? I will test some workarrounds and send the resulds…

You need to modify /usr/share/applications/harbour-situations2application.desktop to get Sonar to install.

Basically, just add this at the end of the file to disable the sandboxing:

[X-Sailjail]
Sandboxing=Disabled

There is a mention of doing this in a comment for Situations within its Jolla Store listing.

I would recommend just restarting your phone after making the change, and then go ahead and install Sonar.

You’ll have to test out the functionality afterward to make sure everything you need Situations/Sonar to do still works as desired.

1 Like

Thank you this was what I wan’t to poste here, because I found it also as solution :slight_smile:
Here the steps as summery solution:

  1. download the sonar app from here
  2. uninstall sonar with: ‘pkon remove situations-sonar’
  3. install sonar with root: ‘devel-su zypper in /home/defaultuser/Downloads/situations-sonar-0.0.9-9.aarch64.rpm’
  4. If you uninstall Situations then install Situations app from jolla store
  5. open the file ‘’/usr/share/applications/harbour-situations2application.desktop" with a root editor like tIDE and add “[X-Sailjail]
    Sandboxing=Disabled” as new lines at the end and save this
  6. Open situation and you get no questions about sonar any more :slight_smile:
  7. import your exist profiles
3 Likes

I recommend creating a new file in /etc/sailjail/applications and adding the two lines there.

This has the same effect and will survive app updates.

5 Likes

Edit: It seems like my post was wrong, really sorry about that. Instead please follow Nephros’ advice
What I have been using for years and it has went around all the problems of sandboxing is Auto-start for Situations app | OpenRepos.net — Community Repository System
And that has been working great up until X10, but there is no build of it for aarch64. So I extracted the systemd file from it, /usr/lib/systemd/user/situations.service

[Unit]
Description=Situation auto-start
After=ofono.service lipstick.service

[Service]
Type=simple
ExecStart=/usr/bin/harbour-situations2application server
Restart=always
RestartSec=10

[Install]
WantedBy=user-session.target

So all you need to do:

  • install sonar and situations from the store
  • add this .service file (maybe enable it? with systemctl --user enable situations.service, but probably not necessary)
  • restart your phone

And now you don’t need to disable sandboxing or anything like that, because the server gets started from the command line, it is worked around. And you get automatic start too.

2 Likes

Nephros - Your workarround works perfekt - Thanks!

This file exist on my Sony Xperia 10 ii 4.40.68 but with out the two lines in the desktop file situations don’t can see this service… Thanks for your help - it is very helpful if many users answer whta they know!

1 Like

Yeah, I was wrong. It seems like the .service file that was installed by Auto-start for Situations does exactly the same as the .service file provided by Situations itself. So it is not needed and all you need to do is disable sandboxing and install sonar, as other said.
Sorry for posting a wrong solution

1 Like