Situations no longer turns sound on?

Really? Tapping the Silent/DnD options in Settings does not help?

Also, maybe it’s the problem with pulseaudio stopping to work which could be unrelated to Situations?

BTW, switching Dnd/Silent mode on and off seems to work for me with Situations…

If this continues to cause problems, you can alternatively use systemd to do it for you:

nemo@PGXperiiia10:~/.config/systemd/user $ cat dnd-activate.service
Description=Do-not-Disturb mode toggle

ExecStart=/usr/bin/dconf write '/lipstick/do_not_disturb' 'true'
nemo@PGXperiiia10:~/.config/systemd/user $ cat dnd-activate.timer
Description=Do-not-Disturb mode Activation

OnCalendar=Mon..Fri 23:59
OnCalendar=Sat,Sun 01:15

nemo@PGXperiiia10:~/.config/systemd/user $ cat dnd-deactivate.service
Description=Do-not-Disturb mode toggle

ExecStart=/usr/bin/dconf write '/lipstick/do_not_disturb' 'false'
nemo@PGXperiiia10:~/.config/systemd/user $ cat dnd-deactivate.timer
Description=Do-not-Disturb mode Deactivation

OnCalendar=Mon..Fri 06:30
OnCalendar=Sat,Sun 08:30

nemo@PGXperiiia10:~/.config/systemd/user $

A solution can also be open the teminal and type:

pulseaudio --check && pulseaudio -k && pulseaudio --start

Note, the latest command will be remembered in the terminal.

1 Like

I really don’t think I’m going to be starting stuff from the command line every time I reboot the phone.

Is there some SFOS equivalent of /etc/rc.d/rc.local one could edit to automatically run Situations at boot-time?

You should lookt at Need Help: HowTo start to programm a first app: “Pause” (break or “face down”) for Xperia 10 III

What I was doing with Situations was just switching ring volume between 0% and 100%, the settings were showing 100% volume even though it was somehow on silent.

Although a fan of rc.local, @nephros


is effectively a discrete, service specific, local rc. I’m not a systemd fan, but having user service activation in a user context I find quite nice.

I think it might be even easier to simply set the volumes via pluseaudio if that’s all you use situations for. Maybe just run

pactl set-sink-volume 0 -100% -100%

All this is getting a bit involved, and unfortunately I don’t have the time right now to get to know all these intricacies.

Is the conclusion that with the development of SFOS, Situations is mostly unusable as it is distributed?

Partially, that is true.

Certain things that used to work do not any more, or in a degraded way.

The developers (pastillilabs) are aware of these, but they are occupied with other changes of the app at the moment (it runs on onther OSes as well), and have told me it could be some time until they can revisit SFOS support.

It is NOT abandoned though.


Agreed on all points :wink:

Although actually, as an OpenRC user, I prefer /etc/local.d/*.start instead. And, to gain systemd-like service monitoring functionality, running monit from /etc/inittab. Which is an approach that predates systemd itself.

But that’s quite OT here. Sorry.

This is precisely how I learned to run gentoo, zentoo and co. Thumbs up!

Just to link @nephros note vis. developer contact here: Situations App on 4.4 - #7 by nephros

As a temporary workaround for this specific sounds/silent switching, you could create a new ambience with chosen sounds disabled, and then have Situations toggle ambience, instead of sounds, at given time.

1 Like

I’m afraid that due to this bug (causing that sound settings from one ambience replace sound settings of the second one) it won’t work for too long, either.

Well, that bug never affected me. I have my day/night ambiences working perfect as allways. So, @ExTechOp might be one of the lucky ones that don’t get affected. :wink:

That’s very strange considering that it is present on both my 10 III and XA2. And it doesn’t take any effort to trigger it - as videos posted in the error report show, a simple change between two ambiences having different sounds is enough for sounds from one ambience to overwrite the other one. I had to stop using ambiences because of that.

It would be really interesting to know what may be causing that it so badly affects both phones of mine but not others… Do you have different sounds in those two ambiences set for calls, SMS or email and are you sure that after switching between them the sound settings of the second ambience don’t get replaced by sounds from the first one as shown in these videos? Stunning.

Call sound is the same in all my ambiences, the rest is different. Everything but call and alarm is set to “No sound” in my night ambience and I change between the night ambience and a couple of others every morning and night with no problem.
The only thing I can think of is that my ambiences is installed from a custom rpm every new system setup.

@eson, did you ever reboot the phone when the night ambience was active, and switched to the day ambience only after reboot? If not, please could you test it? I mean:

  • enable the ambience which has SMS and email sounds set to “No sound”
  • reboot the phone
  • after reboot switch to your day ambience which has SMS and email sounds enabled
  • now please check in Settings / Sounds and alerts if all sounds were correctly changed.

In my case, ringtone, SMS, email and alarm clock sounds remain unchanged (i.e. still “No sound” of the former ambience). And if I go to that second ambience settings, I can see only sounds for chat and calendar listed, all the remaining options (SMS, email, ringtone, alarm clock) are gone. It is 100% reproducible, 10/10. On both XA2 Ultra and 10 III. And it looks that I am not the only one as there is a bug report describing the same issue with alarm sound setting disappearing from ambience setting: Make alarm sound setting in Ambience persistent

So you want to break my system. :wink:
Sorry, no game. Everything is still working fine.

Shouldn’t this conversation be moved to that bug thread?

Actually, not break it but realize that it’s already broken :wink:

I will quote Sir Bob (not Geldof): ‘Everything is broken.’ … an go about my way putting fingers in dykes.

1 Like