SFOS 4.5 feedback thread

Hi @Seven.of.nine! The 0.10 version for 32 bit is already released on openrepos :slight_smile:

1 Like

Thank you so much @carmenfdezb , installed on Xperia 10 and works like a charm! :smiling_face_with_three_hearts:

1 Like

i fixed my notifications bug, it was on my end.

the other five regressions previously reported (android-app-sdcard, media-scanner-cpu-100, element-crashes, cannot-send-mms, cannot-bluetooth) remain.

AND i have another regression to report. mcetool --set-exception-length-usb-connect=0 is no longer respected! (nor mcetool --set-exception-length-charger=0)
on sfos=, it works fine, and the screen stays off when i plug in the charger.
on sfos=, there seems to be an enforced minimum of 3000msec.

Had a look at the new Calendar right now. The new 3 viewing modes (month, week, day) are really beautiful! Thank you Jolla!


Just to make sure - For those who report problems with MMS:

I had problems with MMS not working properly. I then discovered that there is a setting regulating the maximum size of messages in the Settings - Apps - Messaging (or whatever it’s called in English). Although I just send pictures taken with the phone’s camera, (which, in previous versions, at least, is scaled down to a reduced resolution), increasing this setting solved my problems. So if you, like me at the outset, is not aware of this setting at all or have it set to a low value, test it out by increasing the accepted message size.

(MMS problems may be due to so many factors. The previous time I installed SF on a new phone and encountered MMS problems, it finally turned out to be caused by the phone’s SIM card being a twin card, and my carrier don’t forward MMS to those, only to main SIMs … )

  • for me, MMS send works 100% of the time with SFOS 4.4, and is 100% broken on SFOS 4.5 with identical settings
  • MMS size settings do not help (although its quite odd that making it larger fixes it for you. for me, only Large-600KB and smaller ever works, on any SFOS version)
  • MMS receive works fine for me on SFOS 4.5

what i get in mms-engine is:

2023-05-11 21:35:18 [mms-task-http] /tmp/mms-engine-PNAI41/msg/9091/m-send.req (222265 bytes) -> -> /tmp/mms-engine-PNAI41/msg/9091/m-send.conf
2023-05-11 21:35:18 [mms-transfer-list] Transfer /msg/9091/Send started
2023-05-11 21:35:18 [mms-task] Send[9091] NEED_CONNECTION -> TRANSMITTING
2023-05-11 21:35:18 [mms-transfer-list] Update flags => 0x11
2023-05-11 21:35:25 [mms-task-http] HTTP status 200 [application/vnd.wap.mms-message] 18 byte(s)
2023-05-11 21:35:25 [mms-task] Send[9091] TRANSMITTING -> DONE
2023-05-11 21:35:25 [mms-transfer-list] Transfer /msg/9091/Send finished
2023-05-11 21:35:25 [mms-task-send] ERROR: Missing Message-ID

i recompiled mms-engine and added some debug logging nearby. pdu->sc.msgid is NULL and pdu->sc.rsp_text is "OK".
also, the identical mms-engine rpm works correctly on SFOS 4.4, so the problem PROBABLY isnt in mms-engine (although i do have to symlink /usr/lib64/libgmime-3.0.so.0 => libgmime-2.6.so.0 to make one rpm target both platforms, so its not a perfect test. i get the same error with jolla’s RPM as with my custom built one, though, so it’s probably a good bet that the problem is not mms-engine)


is it safe to upgrade the phone by now?were the issues fixed?i really don’t feel like reading 400 posts.
i need the phone for work.
also should i even update if everything works just fine with my current OS version and i miss nothing?

I had the same thoughts before updating my Volla, because reinstalling the Volla is really hard work. But at the end curiosity was winning and luckily phone still works. No data loss at my side, no new problems. I’ve got the feeling, some problems were solved, but some other still persist.

edit: Sony X10 no problem.

1 Like




twenty characters

1 Like

According to the poll here

Out of 86 voters
93% had no issues during the upgrade process

You will be fine.

1 Like
  • that poll is about the update process. i had no issues with the upgrade process, either. also, it was just 87 folks, during a relatively short window.
  • i know of three serious regressions in 4.5, and four minor regressions, and zero of them have been fixed.
  • why update if the device is working well? i would never have updated if it wasnt for the OTHER serious MMS regression that results in data loss being fixed.

EDIT: you did catch this part, right?

1 Like

Yes, I did, I too need my phone for work.


It sure is. But if you asking for assistance in reading posts here, I can’t help. :wink:

1 Like

I also do.
That’s why I always reflash instead of upgrading. (Subjective opinion, more feeling than scientific conclusion)
Anyway, my XA2 reflashed works perfectly now. (almost no android use, few mms, but works)

edit: this said, I’m still “disadvantaged” compared to my colleagues who have whatsapp, waze, and all sorts of gadgets that sometimes make things a bit faster.


This was easily the most awkward upgrade for me so far (XA2).

There are several things I’d do before upgrading:
Normal backup
‘dd’ backup
App grid backup
Update FakeStore
Update Okboard

First and last are normal. ‘dd’ is a major hassle but worth it if in doubt. App grid seems to be a thing for this update and was needed for me (XA2). FakeStore needed if you use it.

If there are problems that can’t be resolved, try fresh installation. If that doesn’t work, you have the ‘dd’ backup (make sure it doesn’t max out your SD card, failing to finish properly).

PS. I still have minor new problems with Bluetooth, haven’t tried zypper/pkcon refresh yet. Worth it for improved security models (inc Android) regardless.

1 Like

i just need the Android support to function properly for Firefox and Whatsapp,
it would be nice to still be able to use my Bluetooth earbuds,
and obviously phone calls and sms.
that’s about it for me.

i don’t want to get into backups,
and re-flashing is a hassle, since i wasn’t successful doing it the first time on my home PC running Linux and had to go and find a Windows one.

couldnt take my phone dying every 4 hours anymore, so i switched back to SFOS 4.4 again.
…and immediately missed an incoming MMS that will now forever be ‘waiting’.
just cant win with sailfish these days. still, better than having a dead phone.

on an aside, i tried to install android10 aliendalvik on SFOS4.5 and it was mostly working, with just binder-utils, apkd, aliendalvik/settings/system, and lxc RPMs from SFOS4.4, but there were a bunch of missing pieces so i gave up.

THEN i tried to backport the SFOS4.5 MMS bugfix to SFOS4.4, but jolla-messages, mms-engine, commhistory, and dbus RPMs installed fine but did not fix the bug.

if anyone has any advice on how to get android10 aliendalvik or waydroid working on Xperia 10 III with SFOS 4.5, or any fix for the constant battery drain of media providers module, please let me know :slight_smile:


i ALREADY outlined, in detail, the various regressions of SFOS 4.5 that i and others are facing, here and in individual bug reports.

while direct solutions to those regressions are MORE THAN WELCOME, its been months and no one has any. (two biggest ones are: element/realm-db is not working for anybody, android.media.providers.module/sdcard uses enormous CPU forever for me)

so, yes, i am in fact exploring workarounds. do you have any suggestions?

1 Like

Did not bother to make a bug report but since the latest update (4.5.19) my Xperia 10ii doesn’t start the android app support automatically when starting the phone even though the option has been enabled in the settings. The same issue was also with the previous version but prior that this was never an issue.

Another issue is that when playing music via Tidal and starting to browse the Internet with Firefox simultaneously, Tidal crashes like every second time. After restart it usually stay up better but the 1st time is always just a matter of time before the crash. I have a gut feeling without any proof that browsing sites with lots of embedded videos, twitter posts etc. tend to make Tidal crash more often even if one does not open/play any of the embedded media links.

On the better side, the switcing between mobile data and wifi seem to be working much better now