SFOS 4.5 feedback thread

Same happens to me on a 10iii.

Upgraded last week - since then a reboot requires manually starting the Android App support.

I tried another approach and reinstalled the whole phone and after the reinstallation the android support finally starts with the device as intended.

Another nice feature after the reinstallation is to have my password manager app autofill feature finally working with all the android apps.

the autostart issue may be the storage+permission migrations. for me, when upgrading 4.4=>4.5 with ota/ssu, android wont start at boot until i create the android_storage migration-completed marker files. and like you also found, fresh install works fine.

when it doesnt work, i get ‘Unable to start’ status in journalctl on boot, but start works the second time. creating the migration completed files seems to fix it, and removing them seems to cause it, so i assume that one of the migrations is failing.

i think maybe it is somehow related to my permanent media providers CPU drain. who knows

updating regressions as of

  • media-providers-100%-cpu: BROKEN
    com.android.media.providers uses 100% of my cpu forever. media providers ALSO ignores .nomedia files, and indexes directories that start with a period e.g.: .pron
  • opencamera-video-crash: BROKEN
    opencamera also crashed in SFOS4.4, BUT restarting cameraserver fixed it, and it no longer does
  • android-file-access-sd: fixed as of
  • element: fixed as of
  • send-MMS: BROKEN
    receive works fine
  • bluetooth: mostly fixed
    have to restart bt services sometimes, didnt used to
  • notifications: fixed with small tweak
  • mcetool-usb-connect: BROKEN
    mcetool --set-exception-length-usb-connect=0 is no longer respected! (nor mcetool --set-exception-length-charger=0)
    USB plug in turns the screen on. this worked in 4.4
1 Like

Are you sure? There’s no hint in release notes / changelog about that, and on my Xperia 10 III Android apps still cannot create files on SD.

on, opencamera can save photos on the sdcard with SAF, and coolreader could open a book on the sdcard without doing anything or granting any special perms.
neither of which worked for me before on in May. i did not try again on today, though, so it may be coincidence and not a bugfix.

Good day all Sailfish OS users and creators!
Thanks for your great work!

So, bugs of last firmware on Xperia XA2 device.

  1. Can’t create RFCOMM TTY on
    rfcomm --auth connect (mac address) 1
    As i tested, on all was good and it worked, with same OBD adapter.

  2. Every time after reboot we need to do
    pactl set-source-volume 2 300%
    for normal microphone working. Please fix this! Critical bug!

  3. Any attempts to start File Browser with root rights failed. Even with special application links in Storeman. Please allow this.

  4. Bug/no feature
    Please add favorites photos section/page in Gallery.

  5. Design misbehave
    In E-mail app all background is black, but when open a mail - background is white! Please fix it.

  6. Bug
    Selecting text for copying in Browser is awful and haaaard, sometimes impossible to select. Please fix this.

  7. Bug/no feature
    No sorting of favorite contacts in Contacts app. They sort at alphabetical order now. Please allow manual sorting.

  8. And sure, most known bug - standard Weather app not working, please fix it finally.

Thanks, regards!


Which File Browser are we talking about? If it’s the latest File Browser from OpenRepos, then please try…
devel-su env XDG_RUNTIME_DIR=/run/user/100000 WAYLAND_DISPLAY=../../display/wayland-0 harbour-file-browser

4, 5 and 7 is by design, no bug.

1 Like

And 2 also )
9. Bug/misbehave
Please make the volume of notifications and volume of multimedia (video, audio) separately!

  1. Misbehave
    Please add/or option of smooth volume increasing of Alarm clock.

@eson Thanks, that’s work! So only way to start this way from Terminal, can’t from icon from main menu?

Well, you could use qCommand to generate a icon from that command line, or you could try Nanofiles, which has built in root mode.

1 Like

Definitely no bug.
Do other platforms really have separate audio and video volume? O.o
If you mean separate multimedia volume from ringtone volume, that’s already the case.

Pretty sure they already work like that by default. Or you mean you want to turn that off?

I mean separate volume of notifications and media!

You mean, developers know about this feature and working on it now? Better option, usually. Smooth (upscending) or normal.

Separate volume definitely exists.
Which one is adjusted when you press the volume rocker depends on if media is playing or not.
See also sound in settings; definitely two sliders.

I definitely experience increasing volume for alarms every day. And i don’t think it is the sound file that does that, though it is possible (I use the default Jolla Alert 1).

1 Like

I know, that there is 2 sliders… Should be 3 (three). 1 - Ringer, 2 - Media, 3 - Notifications.

There’s NO increasing volume of alarm sound now. Sound start from its initial value.

1 Like

That’s not what you said. Notifications (i.e. ringtone) is separate from media. Why you would want ringtone separate from other notifications i don’t understand.

I let my alarm keep running just now. It increased in volume. Perhaps it doesn’t start soft enough for you, but it does ramp up.

Don’t know if this “Alerts” from OpenRepos is relevant or if it still works, but you might want to try.

1 Like

Wow, thank you! I saw this app in Storeman, read it’s description, but no words about smooth increasing volume there, and no option of it. But it works, now Alarm is increasing, only 3 steps from 0% to current value, but it’s better then without of them!

@attah, should be no question “why we need it”, all people on android devices have this option more then 5 years, then it’s really need.

Well, then maybe some developer with better knowledge than me should take a look at it. The “Alerts” app obviously change something relevant for the better.
I remember I had problems like this, some year(s) ago and Alerts made a different also at that time. I don’t have that problem for now though.

Blindly copying others isn’t a good idea either.


…and Sailfish is not, and should never be android.