Setting up General Email (IMAP, SMTP) fails

REPRODUCIBILITY (% or how often): difficult, more often on a “fresh” phone
BUILD ID: definitely since SFOS, most likely even longer
HARDWARE (Jolla1, Tablet, XA2,…): JP1301 (J1)
REGRESSION: probably


When creating a General email account, after filling out the forms for incoming and outgoing servers and Accepting the settings, the Settings app fails with “Checking account credentials …”, delivering a timeout message.
If you are ever hit by this, the problem does not vanish if you modify any connection details (e.g. trying a different working combination of remote port and protocol). In fact, no network communication ever leaves the phone in this situation (checked MITM and on the remote mail servers).


It is completely unknown what condition actually triggers this bug. It seems more likely to show on a “clean” phone, e.g. after a factory reset.


  1. Within the Settings app, create a General Email account (manual setup)
  2. Fill out incoming and outgoing server fields
  3. Click Accept to start the account credential check


With proper login data, the account credential test should detect and verify the incoming and outgoing accounts.


The check fails with a timeout message. No network packet ever leaves the device, so no check has been attempted at all.


This is based on the related TJC thread. There are numerous similar mentions on TJC, some of them have been linked from the mentioned thread. If you reboot your phone just when the timeout message appears, the account will survive the reboot and may be fully usable then.
If you read other TJC threads thoroughly, you could get the impression some bug in the Settings app may be as old as SFOS. I had a similar experience with updating credentials only last month. I needed a couple of attempts to actually change the credentials on the phone (as opposed to re-creating the account).
Furthermore, restoring General Email accounts from backups does not work.

1 Like

So are we taking over bug reports now manually?
Could be a time consuming and/or irritating task if you search for a solution.

We can also mention:
general email accounts do not connect after having been restored from a backup… and so on…

1 Like

@peterleinchen Correct! The problem with restoring from backup is severe … It rendered my phone unusable. I manually removed General Email accounts from my backups once I had to restore the phone. And I also suspect this same bug to be a probable cause.


I can’t comment on the main bug, but for restoring from backup, my recollection is that the functionality was changed so that account passwords are no longer stored in the backup (as they possibly were at one point). So after restoring from a backup, it’s necessary to enter the passwords for the various accounts again in order for them to work correclty.

It may be you’re talking about something else in relation to backups, but I thought it worth mentioning just in case.


That may be so (the password thing) but the bug is that there is no chance to get your mail account to connect even when fiddling with settings and re-entering password.

I agree with both of you, @peterleinchen and @flypig: the trouble with restoring from backups is worth a bug report, but it’s probably not good to join it into this topic.

Absolutely right, and I asked how to proceed with these existing, open, not-solved bug reports.
As soon to take over may create a huge lap where cluttering and opening double posts will happen.

I just installed last Sailfish OS on a XA2 (Sailfish_OS-Jolla- and unfortunately I’m not able to set up any mail account.
Even with my GMail account, after getting the right credentials from GMail,
I could not get Email displaying anything else than a waiting screen.
Is there any means to make it work ?

Well. I reset the phone (reset to factory settings) and it worked.

Wow, after some years of struggling with this (Xperia X and X10), finally doing proper research and coming across this thread, as suggested above I tried the following:

  1. fill in credentials (add account -> general email)
  2. click accept
  3. wait 60 seconds and then reboot

I can even add a second (and presumably third) emailaddress in the same way without having to repeat the same process.

Thanks a lot!

You’re welcome, and I am glad it helped. Unfortunately, this is still not reproducible easily and thus not of relevance for Jolla.

Same issue here after updating to

Same here, as posted here: Can't creat many kinds of accounts

Which are the packages needed for e-mail accounts? Maybe a reinstallation might help.

[nemo@Sailfish ~]$ rpm -qa | grep mail

I’d suggest jolla-email-settings and jolla-settings-accounts-extensions-email, but I really doubt it’ll make any difference. This whole bug is obscure, it’s not reproducible easily or consistently at all but by us few. If I had to take a pick, I’d suspect libqmfmessageserver1-qt5 as the source of our problems. But again, it’s obscure.

Don’t know, if this might help

Oct 17 19:54:45 Xperia10 estart[14159]: [W] unknown:0 - writeProfileFile() called, forcing disk write: “/home/nemo/.
Oct 17 19:54:45 Xperia10 estart[14159]: [W] unknown:-1 - file:///usr/share/accounts/ui/EmailCryptoSection.qml: File
not found

Workaround to add and syncing of email accounts

  1. removed email related packages
  1. reboot and removed content in /home/nemo/.qmf/mail/*
  2. Reinstalled packages above
  3. Used method from @border to add first account
    4.1) fill in credentials
    4.2) click accept
    4.3) wait 60 seconds and reboot
  4. Email syncing is again possible (only manually, but that’s a gain)
  5. further email accounts can be added the "norma"l way

I’ve spotted some memory corruption inside messageserver5. I suspect that a lot of the mail-related problems could go away if Jolla devs ran the e-mail system via Valgrind.