Setting up General Email (IMAP, SMTP) fails

Yesterday, I test-drove SFOS on my Pinephone again (the initial setup with encryption of /home shreddered my Mobian installation on internal storage, but otherwise very impressive) and restored a backup from a J1 onto it. Lo and behold, I did not experience any problem whatsoever with accounts.
I am sure this bug still lingers somewhere but is extremely difficult to reproduce in a way that helps developers to find its roots.

Ah, thanks! Did you observe this on 4.2 also? I’ve never had this problem with 3.4 but with 4.2 it seems that this, and the PIN options, are being corrupted.

Just flashed back to Sailfish this morning with the hope that Volte shows up in 1Q2022.

However I seem to have run into this problem when I try and add an email account to the email app. However in my case, it seems to be an endless loop of “Checking account credentials” with no error message ever showing up.

Xperia 10 Plus, Build 4.3.0.12

Did you try to automatically create the account by entering address & password , or manual setup?

Did you follow the links to TJC found in “additional informatio”? It boils down too reboot…

I tried rebooting several times which didn’t work; I did a full reset and that fixed it.

On an XA2, freshly installed 4.3.0.12.
After a full device reset, we could create the mail account.
But then, it has been displaying: updating account forever.

(the mail account is configured so it doesn’t download attachments)

Strangely, the passwords entered in the account server settings are shown as “default” each time one comes back to them. The Mail application keeps showing “updating account”. We’ve tried several combinations of setting the password and then rebooting before reopening Mail. But still the same.

It turned out that the outgoing server needed to be named differently now as it used to. So the specific problem is solved.

=> What is indeed broken is that there are no error messages that help either advanced or new users to know what could be wrong or what could be done to change the situation.

But good that it works!

4 posts were split to a new topic: E-mail app should offer immediate deletion / erasure

And since two years, and version 3.3, 3.4, 4.0, 4.1, 4.2 and 4.3 it is not possible to power off the device! Some tricks may help sometimes, but not always. e.g. press and hold vol up button and then press power button… To have a phone I never ever am able to power off is a strange feeling…

edit: the delete feature is not the only reason of my current fret, it’s also the above mentioned power off misery, the censory + flagging misery, … These two are the main things I have to critisize. Some others are minor important.

But the main reason for my anger is, what SFOS COULD BE easily, but IS NOT.

1 Like

And now I already feel afraid in this forum to answer as I would like in a free speech world (which some do not like).

So calling @vige (or any @moderator which is not public and unknown to us!) to move this out -as it also may be interpreted as offtopic to the title and may become flagged / ‘censored’- into a new topic with title ‘Feature request - e-mail app should offer immediate deletion / erasure’ and maybe a second one with title ‘Anger - what SFOS could be but is not’.

2 Likes

Is this now a feature request thread for the email client ;-)? I also have a wish.
If I set the synchronization rhythm to OFF in the server settings, SFOS should not synchronize even when switching the folder. In this case, I would also like to initiate this manually.
At the moment it always starts to update the folder.
Maybe that’s a bug?

3 Likes

Good idea! so it would be possible to look into old mails without triggering a synchronisation or network traffic or an error message if network not available.

The solution seems to be as following; After flashing the device, install also following package: jolla-settings-accounts-extensions-email-crypto. After this the account setup does not hang forever anymore …

This is great news, and I seriously hope that it helps many. AFAIR, this package wasn’t even available when this bug surfaced the first time, so I’m not entirely sure it’ll help all of us. But I will test, once my phone survives displaying an email in the Mail application (which is a known bug on my device, supposedly solved in 4.4).

My XA2+ is in 4.2 and I also have trouble with General Email, not with setting up, but with the diappearance of the account every few weeks. I have to log in again and again.