Sailfish OS pinephone

As far as I know most other distros for PP do expand the partition but sfos does not yet…you have to do it manually. If you need help follow the instructions on the PP wiki (https://wiki.pine64.org/wiki/PinePhone_Installation_Instructions#Resize_partition_to_fit_disk_space).

1 Like

Wow, I swear some days it’s like I’m brain-dead or something. Idk why I didn’t think of this even though I’ve done this times before.

I feel stupid for not realizing that sooner. I think I got caught up in the script thing 'cause that’s what I kept finding online where people mention the self expansion thing but I’ve literally done the manual thing for different devices before.

Thank you for setting me straight there. I even looked at the wiki too! Wow!

Just recently installed this on my PineTablet and its honestly nothing short of amazing. I really love the ‘different’ feel of Sailfish and how things are done. Right now its booting off the SD card but it seems to be having some issues. I’m going to try and use the script again to build an image and see if I can install directly to the eMMC.

Issues currently
Email: Added an IMAP account. Pulls down all the messages, but crashes every time I try to open and read the actual message
Power/Sleep: If I leave the tablet alone for an hour or two, hitting the power switch doesn’t seem to wake it back up.

I’m guessing this is because of the beta status of all this. But I’d just like to say overall how much I really like Sailfish and I’m hoping it continues to develop. Anything I can do to contribute I’d be happy to.

2 Likes

I have tried the latest Sailfish OS on Pinephone again, using the flashit.sh script, however, still can’t get any sound output, and of course calls don’t work. Anyone else having audio problems? There was a version a few releases ago that actually had working audio for me, just that used a lot of battery. Since then battery usage has improved, but sound has lost.
I have a Pinephone revision 1.2

Some pulseaudio files were missing and are reportedly working after doing a

devel-su
zypper ref && zypper dup

That won’t get you a working modem, though. As I wrote above, this port would need a lot of love to make it usable, as with all of mainline kernel ports. And as I also wrote above, what has already been achieved is impressive!
@PeperJohnny consider that ports based on Android environments have standardised interfaces, which can be used with hybris, to abstract hardware from Sailfish OS software. The Pinephone has no such interfaces and moreover, the (kernel) interfaces it has are rapidly changing, because they are being improved a lot with every new kernel release. Most of the hardware control examples in the Mer wiki just don’t work any more on a recent kernel, and on the Pinephone, you want a recent kernel to enjoy many improvements like a longer-lasting battery.

I haven’t looked in depth at SailfishOS at the lower level yet, however, I notice similarities to Suse, who do have a “working” Pinephone port. Just wondering if one could leverage some of the modem manager bits and more from there?

Well, 52% should be enough for everyone. :slight_smile:
I tried Sailfish OS on the Pinephone but it lacked a lot of polish. Right now my Pinephone is sitting in my locker and will be transformed to a miniPC/Nas Server someday. I don’t see it as a replacement for my Sailifsh Xperia X compact anytime soon.

The Pinebook is the homeschooling laptop my daughter uses and it works great for that. The Manjaro install is pretty solid and even Jitsi meetings are possible with it.

1 Like

You should check out LINMOB’s video. It mentions how you can upgrade to version 4.
You have to set a password in the developer tools and then:

devel-su
ssu re 4.0.1.48
ssu ur
zypper ref
zypper dup

I’ve done that yesterday and it takes some time (+/- 800 package-updates). v4. defenitly works better, but I still have issues.

If Modem manager can have bits integrated into ofono, I wonder if VoLTE support could work on any SailfishOS device…

Is this still the latest update information to run after a new install from flash-it, please?

I just did this and had one package update, not the hundreds from the last time I did it a week ago.

My phone won’t ring now, and placing a call takes more than ten seconds, so I can’t use it at present.

1 Like

Did it make a 3G call?

It’s usually on 4G. Trying it just now it wouldn’t place a call, but the error I had earlier was not receiving them. The phone stayed in sleep rather than ringing or taking SMS’s.

I’ve just had the problem that kills it for me where pressing the power button won’t wake the screen, which is something I had last time I tried Sailfish.

1 Like

Anyone Upgrade to last release (4.1.0)? Are there any improvement?

for me work now Email.
GPS & Camera do not start. i dont now why.
Modem (SMS, Call) unstable, works after reboot.
Bluetooth (pebble) und Wifi are stable
SC Card no working (16Gb) ext4
version 4.1.0.24

1 Like

This OS (latest from gitlab job) on PinePhone 1.2 is simply amazing! The nuances of the OS alone are reason to have this on my PP1.2, I have never “had” an experience like this on a phone! Been around since WindowsCE and Android Doughnut times too. I hope devs can make this a daily driver, seriously almost there though!

2 Likes

I have been searching quite a bit to get the GSM to work, I can get incoming phone calls to register but never a connection - GPRS/3G/4G no data and no SMS sent/receive. Am I correct in assuming that the GSM (EC25) is not working for now or am I missing something here? If I am could someone kindly enlighten me on how to arrange the modem so that it is functional on the PinePhone?

I had to enter the APN manually. After that, the mobile internet worked.
Unfortunately, it only works until the next standby. After that, I always have to reboot.
The same applies to SMS.
Since I don’t know exactly how this works with the updates, it is of course possible that I broke specific Pinephone things during the update to 4.1.0.24.
I will flash it again soon and stay on the version that is delivered with the script “Flash-IT”.
Unfortunately, the app for the Pebble does not work in version 4.0.1.48, as it is already written for 4.1.xx.