Sailfish OS pinephone

While I expect that phone, calendar, email would work on SFOS Pinephone, many apps are hindered by old QtWayland and Qt in general. As Lipstick is clueless regarding newer Wayland protocols (XdgShell), it is impossible to run host of software on SFOS. Nor develop it together with other Linux mobile platforms - we are always faaaaaaaaaar behind with Qt.


Just a heads-up mail doesn’t work because of webview being from the browser now and that uses some libhybris magic if I understood correctly.
Interestingly enough a lot of apps work quite well. I’ve tested Piepmatz, Fernschreiber and Quickddit a bit on the Pinetab and it worked well enough.

1 Like

You nailed it. While SFOS is a beautiful and very functional OS, many crucial foundation pillars aren’t capable of offering features taken for granted on other platforms. (And as said above, Ubuntu Touch is essentially in the same boat, here, to use a maritime metaphor). And given the complicated situation (kernel limitations of current devices, Qt licensing issues, application compatibility/OS API issues, …) a bright future for SFOS is nowhere to be seen, at least I don’t see it. But then I have never been overly optimistic …


Pinetab on its way! I really hope in this…


Well yes that was me. I have got SFOS still on my Pinetab again and version 3.3

Much still to do and none of this is done by me but a few others here: Sailfish OS Dont Be Evil

The build is available here:

Second alpha - lots do not work but I can do the following:

Keyboard (attached)

So for me - I am sticking with it for now. Keep an eye out for more builds by the people driving this (not me)


Try out Manjaro Phosh Beta2.

The development is proceeding rapidly and many problems have already been solved. Updates and fixes arrive almost every day. The big Manjaro community is an advantage that Jolla does not have and, last but not least, Jolla’s user interface and architecture hinder the porting of many existing Linux programs. The day for a change is getting closer for me. I will certainly no longer install a Sailfish on the Pinephone.

Jolla is a loyal companion without enthusiasm and the will to progress can no longer be seen.


Well, that is your opinion.
Mine is, Phosh is ugly as Android and user comfort is awful.


Maybe Manjaro Phosh may not be beautiful in some eyes. Most importantly, it develops quickly and design shouldn’t be a criterion. It is based on current libraries and does not require any proprietary Android blobs. That is more important to me.

I fully support any way of Linux on phones. Not that I am childish like "SF s better han blahblah, I do not care about that and really appreciate every move away from ios and android.
BUT: M. Phosh does use android blobs, too! Why do you think it does not? It has to, for all the gsm stuff. Just have a look at all the hybris libs on the Pines. I am not sure if Manjaro works without them, maybe, but: In facts it uses blobs, too. There are hardware jumpers to disconnect them and that leaves you with a phone without a phone, bt, wlan…
And the worst thing: The allwinner soc with built in malware: look what already happened (f.ex. GreTel phone). The A23 soc had backdoors included, not just one time.
Please feel free to proove me wrong, I’d be so happy having a blob free phone. In fact I am searching for something phonelike in size without gsm since PocketPCs 2002.

1 Like


The PinePhone aims to be fully open source in its drivers and bootloader. Despite this, due to the scarcity of open source components for cellular and wireless connectivity, the firmware for the Realtek RTL8723CS WiFi/Bluetooth, as well as the optional auto-focus firmware for the OmniVision OV6540 back camera, remain proprietary software. In order to mitigate potential threats to privacy, these components are communicating with the rest of the system only over serial protocols, such as USB 2.0, I2S and SDIO, which do not allow direct memory access (DMA). Integration via these protocols is also what allows them to be physically disconnected via kill switches.


thx 4carlos for clarification and letting me know I was writing BS. Wow, no DMA! Now I need one, too. Sadly I backed the wrong horses with Librem5 and Cosmo Communicator.


I guess it’s not really meant that way, so please don’t consider this an attack but rather a “heads up” on how it may be perceived: It leaves a bit of a “your priorities don’t matter” aftertaste. Because – even if it isn’t important for you – why shouldn’t it be for other people?

I will describe it in more detail. If I have the choice between 2 phones, one with a well design or with a standard surface on the other, I still choose between the two options according to my priorities and choose the standard. Function is more important to me than a great design. This is my personal decision that doesn’t have to fit to everyone.

BTW, who says Phosh won’t be more personalizable in the future? It’s a window manager like any other on Linux, and that’s what Phosh looks like at the moment.

Yes, I read it like that (and it at least partly matches my view, as well), just wanted to make sure no one misunderstood your wording above and got angry for no reason, which apparently happens sometimes. :slight_smile:


edit: that quote formatting didn’t work out

Manjaro supports Lomiri and Plasma Mobile as well. Maybe some day there will a nemo mobile version, too.

1 Like

Hi…Sailfish is one of the oses i’d prefer to test, but on the other hand it’s the just a single I can’t will boot appropriately.

The blaze it content revealed achievement, the gadget begins for sure, the sailfish logo shows up then it goes to a clear screen and the drove goes ahead. looks sort of pink. I’ve left it in this state for a few minutes yet no change.

All different pictures I’ve attempted have turned out great on the telephone, including utilizing a similar sd card. any hints? what am I missing?

XA2 with Sfos is my daily driver and my “just4fun” phone is a pinephone ce, manjaro branding, currently happy with arch arm. I tried a lot of OS variants but I would never flash the sfos port. Don’t bother me, full respect to the porters, but to be clear. Sfos isnt official build for this phone and there are to many hibris-libs build over years for the sony/android blob that makes no sense on the pinephone.
Instead of a port, only chance I see would be a “Sailfish Y” fork build on actual sunxi-u-boot with actual efforts of kernel-builds, qt and whatelse without the hibris-builds. But I can’t believe that jolla would make this possible, because their monetary system has other targets than this.


Yes, you can install it and it goes faster and smoother than other mobile systems for Pine. But in my case the only two web browsers available, none of them work. Neither the default one nor the Pirate one, it goes blank and does nothing, and that is why I am not currently using Sailfish.

So I flashed an image from last November for the PinePhone and it installed fine and I am able to connect to my account and everything.

Only problem is the OS does not see the entire space on the SD card on which it was flashed.

I followed the Pine64 guide to “flash” the image to the SD card via Etcher. My understanding is that the OS usually runs some task that expands the partition and file system upon initial boot.

How do I do this with my setup? Is it impossible while the phone is on and or via ssh?

i have currently manjaro flashed on my elemenatoryos pinephone.
in airplane mode it lasted multiple days, with wifi on two plus, so i have tried to used it for 2 days as daily driver: but the connectivity is not stable enough yet.
it is a bit like sfos a few years back, when phone-calls would not work and you would only recognize that after trying to call somebody and failed.
so i did stop and do wait for next update.

posh and the app are so ugly you dont need to monitor your screen on time, so an implicit detox :smiley:

rest did work for me.

sfos is the nicest and smoothest os still on the pine phone.
it wont boot without sim by the way and i do not have a second sim at the moment.
waiting also here for the update (last try was the january update)

keep finger crossed, my x10 is dying after 2 years only:

  • display issue
  • camera cant zoom
  • hull is broken too, when i did bend it once too hard