Sailfish on VollaOS

Since a few days both camera apps (Stock Camera + Advanced Camera) both crash (go to minimized view) and don’t save pictures after taking a photo or start video recording. SFOS @ Volla phone (GS290). All other apps working fine as always.

Advanced Camera - both photo and video: App minimizes and doesn’t save a photo or record anything. Minimized view shows app name (‘Erweiterte Kamera’). Restarting the app by tapping the minimized app icon is possible, app starts again but operating fails same way as written above.

Stock Camera - both photo and video: Same as above. Minimized view shows the last successful made photo. Restarting the app by tapping the minimized app icon is possible, app starts again but operating fails same way as written above.

Both apps did work for a time and bug occurs since a few days.
Does anyone know what can be the reason and / or how to fix it?

I’m looking at other bugs (webview / opengl ) but haven’t had any camera issues yet. We need a better way to report bugs for volla. @piggz should be use the forum bugs?

@Seven.of.nine do you have issues webviews? maybe in tidings?

1 Like

What is ‘webviews’, ‘opengl’ and ‘tidings’? Browser works fine.

Some of my apps use an embedded webview to show web stuff. DWD app for a rain map. Tidings for a webview of a feed item. Mah Solitaire is a local html app in a webview wrapper. Most of these are currently broken whole or in part.

camera’s still do work for me on gs290.

i have issues with connection, like every morning i have to disable / enable mobile network to have connection

but cameras are fine. i am on still

don’t you mean .68? The camera fixes came with EDIT .72 or is your video recording still borked?

On network is fine!

no, since the fresh update i did remain on .58
camera works, video is broken

You can safely to to .64. After that WebViews are broken. But WebViews are also broken on Sony phones from .64 (partially broken worse in volla land.)

i am cautious in regards of waydroid
but i guess waydroid was brooken due to waydroid images and not sfos version

ah, of course. I haven’t even tried waydroid! too much to do!

during update to .68 i get an conflict in fingerprint.conf between jolla and community
which one to keep ?
i think yes is: replace by jolla, no: keep community ?

NOPE: no results in cancel. so all i can do is say yes

just updated to .64 and camera is dead :slight_smile:

but on .72 it started to work again.
patchmanager seems to have issues now. install it , re applied setting and patches … works now

The same on my Volla, but since abt. a week or two, both cams crash in the moment of taking a photo or start to record video. Both means triple both: Front and rear cam, steady cam and video, Stock Camera and Advanced Camera.

As said, everything was working fine on .72 for a while, but since one or two weeks…

Went for .72 and now my outgoing calls are broken

18:31:46.419 slot1 > [00000649] 141 getSignalStrengthResponse_1_2 INVALID_RESPONSE

Heh. Ok, I did the updates from .64 → .68 → .72 and I’ve got broken outgoing calls as well. @piggz?

How inconvenient would it bo for you to repeat the upgrades, and get me the logs for each?
I assume you are using the upgrade process:
ssu re
ssu ur
zypper ref
zypper dup


Question: Does OAuth2 (e.g. for MS365-Accounts) work within the standard email client in SFOS on VollaPhone or is the functionality restricted to full licence?

I’m not 100% sure, but I don’t think even the licensed versions have oauth support for IMAP/SMTP, etc.

@flypig is OAuth2 supported for email ?

It’s not supported for “plain” IMAP/SMTP accounts, no, but it is supported for Exchange (MS365) and Google accounts, including email in both cases. The MS365 support (both OAuth2 and username/password) is part of the paid Sailfish X licence.