Sailfish on VollaOS

You even liked that post! :wink:
Follow the link and see for yourself.

1 Like

For my part I don’t need the recent changes, but…

  1. Exchange Auth
  2. Browser updates
    might be worth tracking? @piggz

I’m just worried to see the droid media bugs with video recording creeping out to other devices!

1 Like

As .72 is a stop release I will have to make it available

1 Like

I also fixed video recording today, so that will be included in a .72 update


Wow fine! Thank you so much @piggz !

edit: can i update with zypper ref + zypper dup if it’s ready?

edit: did it, worked fine, browser better, touchscreen much much better!! Thank you very much!!

But video recording still buggy. Advanced Camera hangs, video recording counter doesn’t count on recording, app crashes on stopping the recording. No file present in Gallery.

edit: i’m still on release, can/shall i switch to ssu release and update again?

I’m helping debug on the devel (not testing which is usual) channel. I don’t think the camera fixes are in testing. It’s not quite ready yet. Although I ‘only’ had issues with SIM /ofono stuff.

1 Like

I have pushed the changes to testing; @poetaster reported possible fault with sim/calls but it worked for me.

ssu re
ssu ur
zypper ref
zypper dup

Please report any issues

1 Like

Volla-X will follow later

after first command i got this. (see screenshot). Error msg ‘no carrier’

So i’m unsure and better ask what to do before proceeding.

edit: what shall I do now?

I re-flashed that device ( build). Did most basic setup and did the upgrade. All works! I tested bluetooth, nfc, mtp camera record playback, audio, network, browser, gps …


Updated from .64

phone starts
calls works
mobile and wifi works …

had the same line regarding no carrier, ignored and continued

Updated right now (edit: from 64), no error messages today, everything seems to be fine. Phone didn’t reboot but shows now in Settings/ Product Informations. Will now reboot, test more details and then report again.

edit: everything works like a charm, including video camera recording! Perfect! Thank you so much @piggz !!!

Vollaphone update also ran fine. All intial tests a-ok! Thanks! Finally video recording is back.

EDIT: argh. Web browser is gone. Re-installing doesn’t work either. hmmm. Removed user.js and all cache data. dies. uninstall, re-install. no dice. hmmmm.


Very strange: /usr/bin/sailjail -p sailfish-browser.desktop /usr/bin/sailfish-browser %U starts the browser.

My browser is still here

On the one GS290, it’s also fine. On the volla something is odd. But I get the same errors on starting from the cli on both phones. And, as I say, I can launch the browser, with the cli.

My browser works normal as always. Tapping and scrolling feels better now!

Updated today, everything seems to be fine. Video recording and browser works.

1 Like

And now available for the Volla-X


Found it. pkg: patterns-sailfish-device-configuration-common was missing and busybox-symlinks-procps hadn’t been upgraded properly.