Sailfish is becoming a mess...multiple bugs after lastest patch

I’m really starting to feel tired, after all these years Sailfish is still dragging behind on the most basic things, old bugs, and after the lastest patch things have got seriously bad, for me at least, making it close to useless as a cellphone.

First most important bug: Backup always crashes while doing it, sometimes it stops at notes, sometimes at playlists and gives an error, this is going on from 2 years now and I was still unable to make a backup after 2 years of upgrade patches, tried to delete the now old backup, format the microsd card, always the same problem…is it possible that Jolla can’t do anything about it ? I have seen this is a common problem for many…

Another bug recently discovered, there’s no way to update android apps anymore with one of the commonly used alternative stores like Aptoide or Apkpure, the apps give “App not installed” message, either from the store’s app itself or from web browser, and trying to open it via file browser gives “xpg-open” not found message.

Still haven’t found a viable solution for me, any help appreciated, thanks.

Phone Sony XA2 Ultra , Sailfish Vanha Rauma , language set to Italian, micro sdcard 32Gb installed (fat32 formatted).


Sorry to hear that you have troubles with SFOS - I do not have these problems neither on my XA 2 dual nor on my Xperia 10 ii, both runnung SFOS

Your are specifically mentioning two problems, a) the backup and b) the update of Andoid apps.

For a) I have no solution because I did not yet encounter the backup-problem.

Regarding updating Android apps you may try installing the Aurora Store. You will find the Aurora store in the F-Droid repositories. So first you should install F-Drod from and search for Aurora and install the Aurora store from f-droid. Since the Auroira-Store basically is an anonymous access to the original Playstore, you may easily update everything to the latest official version (much better than Aptoide or APKpure).

1 Like

Thanks for the F-Droid info, but this is not a app related problem, but a bug related to how sailfish manages .apk android archives for decompressing. :wink:

It will be useful though, I didn’t knew about Aurora store.

From a practical point of view, I suggest to reflash your device and then install all apps new. Please save your data on external media or SD card before and don’t rely on backups. After 2 years of updates some bugs or errors may accumulate.


Btw, backup’s bug report is here.
I could reproduce the bug. (XA2 Dual 4.4 with license)

I’d also recommend to reslash after manually copying your data.


I found the big culprit with backups was the number of media files. I got in the habit of moving most photos and videos off the device before a backup. I think that is, sadly, counter intuitive for many.


This would explain why I didn’t encounter this bug yet (keep fingers crossed) - I store all my media files on the SD card and camera is set to save everything on the SD card as well

I had the backup bug two updates ago and i couldn’t backup before upgrading sailfish.
After i upgraded it started to work again on mu XA2 plus.

Yes indeed sorry to hear u are facing so much troubles and bugs, hopefully a solution comes along from the more experienced, for myself i can only say my XA2 Ultra dualsim is working fine with the latest build, but please dont give up!

I haven’t had a problem doing backup or updating Android apps. XA2 dual sim running

I’d recommend doing a reflash

I did have other issues caused by either an updated that didn’t proceed correctly or accumulated little niggles with various updates. I did a re-flash and these issues have gone away. The one problem I ran up against was that before the re-flash the file system used Nemo now it’s DefaultUser and this caused some issues with the importing of the backed up data. This thread was a big help. [3.4.0 onwards?] Restore backup fails when restoring notes (here: from Xperia X to Xperia 10 II )

Thanks everyone for the support and suggestions ! Luckily I solved BOTH problems , the backup thing was solved by moving all the pictures and media files to the Pc , freeing up space , then backup saved and compressed till the end of it.

The unability to decompress android .apk .xapk packets was unexpectedly solved by Jolla’s last update patch that I received today, it seems that Jolla slightly modified the way android packets and archives are managed and uncompressed, in fact also updating the file manager to the last version now shows a “install” instead of just “open” if you look a packet file on the device, not sure what has been changed but now all the alternative android stores work and install/update android apps again…

Only a slight annoying thing happens now, opening “Sailfish updates” in device Settings sometimes takes a long time to respond, and the popup message with “wait for response” and “close” window appears for a number of times, but in the end sticking to “wait” opens it.

Now that I must restore all the pictures and media files, my question is: will the media gallery will find these if I restore all files on a bigger Sdcard instead of the device internal memory where these had been before ? And how must I put these in folders to make Sailfish recognize them correctly ?

1 Like

If you create Directories Pictures Videos Documents in the root of the sdcard, they should be picked up by, for instance, gallery.

I do backup differently. No tools required. Just copy everything once a week. Don’t wonna change that as it works for me.

About the updates. My system is basicly stock with only minor modifications. I’ve never had problems after any update. Everything works as it supposed to. Except the browser which became sluggish lately.

as a very good android-appstore solution you can install fdroid and get the aurora appstore from there.