Manual backup to SD: failure to load playlists or notes

REPRODUCIBILITY: 100% (on my phone, that is)
BUILD ID: 4.0.1.48 (Koli)
HARDWARE: Xperia XA2
UI LANGUAGE: Dutch
REGRESSION: Yes

DESCRIPTION:

Early july, prior to upgrading to 4.0.1, I successfully managed to perform a manual backup to SD. When I now tried to perform the exact same operation, preparing for the 4.1 (Kvarken) update, the backup fails at the level of the playlists or notes (~ “Error: can’t load notes” or “Error: can’t load playlists”).

STEPS TO REPRODUCE:

  1. Assure SD card is present and has sufficient space.
  2. Settings>System>Backup-up>Manual backup>“Backup up now” button (best guess translations based on Dutch UI)

EXPECTED RESULT:

Progression and completion of backup progress bar, and creation of backup file in root of SD card (at least, this is where I found the file of the last successful manual backup to be residing)

ACTUAL RESULT:

  • Backup progress bar progresses and messages “back-up: accounts” and “back-up: gallery” (best guess translations) appear below bar.
  • Then error message “Error: can’t load notes” or “Error: can’t load playlists” (best guess translations) appears below the progress bar, along with a ‘check’ (~ “V”) sign to the right of the progress bar.
  • Despite the ‘check’ sign, no backup file was created in the root folder of the SD card.

ADDITIONAL INFORMATION:


(no idea how to read the log files and/or where to find the relevant ones, journalctl seemed to require root, please advise)

I had the same problem. It’s some problem with too little storage on the device itself. Backup process seems to need quite a lot temporary storage for compression. For me it helped to manually copy all pictures to SD card and then delete them from device storage. After update I copied them back.

2 Likes

Thanks. This workaround works!

I guess it would be more appropriate if the backup process performs a prior check of required and available space and give a proper and more to the point error/warning in case no sufficient space is found available. Could I somehow notify developers of this suggestion or is this forum bug report sufficient?

Thank you - this helped me make my backup with the same problem! I ran into the inverse problem when I tried to restore from that backup on a fresh Xperia 10ii. It kept faulting at Notes and leaving my contacts (!!!) and calls behind. (Note to developers: alphabetical order isn’t the correct priority sequence for backups, as People and Phone are dead last). The new phone and the SD card were both otherwise empty so there was nothing left to delete.

In case others run into this problem I unzipped the backup .tar locally on my computer and located the all.vcf file, which contained all my contacts – it is under /People/Data. I transferred that back to the phone and then used the following from the Guide:

Install vcardconverter if not already installed.

pkcon install nemo-qml-plugin-contacts-qt5-tools

Import contacts from vCard

devel-su -p vcardconverter all.vcf

I can confirm that this is still persistent in 4.4.
Freeing more space on the phone did work. It doesn’t matter how many GB are available on your sd card

Yes, tested and got the “cannot load playlists”. (XA2 Dual 4.4 with license)

Not sure if this worth anything but the SF Cheat Sheet talks about diagnosing backup problems.

Backup Diagnostics

On the target device go to the command line. Download there Backup status reporting script and make it executable.

curl -o the-vault-storage-report.sh https://github.com/sailfishos/the-vault/blob/master/tools/the-vault-storage-report.sh && chmod a+x the-vault-storage-report.sh

Execute the command in privileged mode.

devel-su -p ./the-vault-storage-report.sh > /home/<user>/backup-status-report.txt

Attach resulting /home/<user>/backup-status-report.txt file to your bug report.

1 Like

Same here (4.4.0.68), error with Playlists or Notes. Jolla is it really that hard to make working backup? Or at least be able to exclude Gallery. Thats a bit sad that in 2022 a device cant make a backup to an empty SD card.

Thanks for your report @dad_and_alive. I’ve created an internal bug report about this and tagged it as “tracked”.

To make it easier to diagnose, it would be useful if you could please confirm that the underlying reason in your case was a lack of free space on your device (but not on the SD card you were backing up to).

How to get some usefull log out of failed backup?

Unfortunately the problem still exists in 4.4.0.72.
I used the backup (and restore) to switch from my slightly broken XA2 to the new 10 III.
Backup at the XA2 works fine. But restoring the backup at the 10 III always stops after the gallery with the error-message: Cannot load notes (translated from German). So neither the notes, nor all the hereafter coming data (primary the “contacts” are important) are restored.

The suggested workaround with freeing-up space on the phone unfortunately does not work: I cleaned all the images, there is 95 GB free user space + 2,3 GB free System Space.

Any other suggestions for a proper backup? (yes I know, I could copy the contacts etc. handish-ly, but this is not satifying).

Thx a lot in advance.