Sailfish Default Web Browser Can't Handle Some Pop-Up Dialogs

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): XA2
UI LANGUAGE: ENGLISH
REGRESSION: (compared to previous public release: Yes, No, ?): YES

DESCRIPTION:

A legal requirement under GDPR legislation is for websites to provide a positive opt-in method of agreeing to cookies. This is usually done by displaying a pop-up dialog asking the user to accept cookies by pressing a button on that dialog.

In a lot of cases where this type of popup occurs focus remains with the main website window underneath making it impossible to click on the ‘Accept’ or other button on the pop-up dialog and continue on that site.

Since most sites will not allow you to continue until you have dismissed the dialog - either by accepting or otherwise dismissing the dialog box - it is impossible to use the default Sailfish browser on these sites.

An example sites where this occurs is www.toodledo.com, but there are many others I’ve experienced.
the only way around this problem is to use another, Android, browser, to access the site.

PRECONDITIONS:

Website with a pop-up dialog box

STEPS TO REPRODUCE:

  1. Type in the URL for the offending web site; wait for it to load and display the pop-up
  2. Try to dismiss the pop-up
  3. Focus remains with the underlying window, so you are unable to continue

EXPECTED RESULT:

Pop-up dismissed when relevant action done (e.g. ‘Accept Cookies’

ACTUAL RESULT:

Impossible to dismiss pop-up dialog

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

2 Likes

Just tried on privacy mode, dismissing or accepting the cookies message works. I’m not sure that this is a bug with Browser.

Well, the same site works without issue on my iPhone, my Linux desktop and my Android phone … and surely you shouldn’t have to into private web browsing just to get certain websites to work? If it walks like a duck, quacks like a duck and looks like a duck … then it probably is a duck (or bug in this case!). I appreciate that some web sites don’t abide by the latest HTML5 standards or whatever and take shortcuts in their coding - and that may cause some issues, but surely not working with a load of web sites that display cookies messages is a bit of a disadvantage? I suppose Jolla, rather than fix the issue, could put a warning message up as the browser opens “WARNING - this browser only implements pure HTML5 according to standard XXX. This may mean that a load of your web sites won’t work” instead :wink:

You don’t, but it’s safer to be in private mode to attempt to reproduce the bug, so that I don’t have cookies/cache/etc. in the way.
Sorry, I think this is a problem with your device, you should delete all data in the browser and try again, or reflash the device.

My first attempt was to clear the browsing data but it didn’t make any difference. Strangely it does work OK in private Browsing mode. I’m not going to reflash my phone yet again … if I had a £1 for every time somebody told me to solve a Sailfish problem by reflashing the OS (a) I’d have a whole lot more money than I do now, and (b) I’d have wasted a good few days of my life on trying to get something as pedestrian and everyday as a mobile phone working properly. Life is too short. I’ve reported the bug - if Jolla want to look into the issue and do something about it then fine; if not then also fine by me. My Sailfish phone is only a hobby phone - I don’t and can’t rely on it as daily driver.

2 Likes

So, I tried it in non private mode, just to confirm whether this is a bug or not, and works perfectly on my side - this could easily be related to how you have used your browser since you first started using your phone. I know it’s annoying, but this happens everywhere - I can tell that you’re frustrated, but this doesn’t look like a Browser problem. Even desktop systems have similar issues whereby you need to nuke the browser’s profile for it to work OK.
You could try to remove all browser data stores manually and try again, which is what a reflash would do.
Sorry this happened to you, but it doesn’t look like a bug to me. Maybe somebody else with a similar experience and a workaround could contribute.


and try to continue with ‘personalized settings’ and not with accept all!

There are others on this forum who have experienced the same problem with other websites on the latest Gecko 60 version of the native browser and, whilst no doubt you are right that other platforms also suffer other web page rendering issues with their browsers, I can’t really see why “well similar things happen on other platforms so its ok that it happens on Sailfish” is a very good justification for doing nothing. You are of course entitled to your opinion that it is not a bug, but does that mean that I am not entitled to my opinion that it is? That is a rhetorical question on my part and does not need a reply.

1 Like

Agreed, this does not work either …

www.toodledo.com is working for me.

But, I have the same problem by visiting site https://www.speedtest.net/ . It is impossible to clik Accept and to proceed.

BTW: how to start private mode in the recent version?

Good question: where to find private mode. I looked in browser setting and noticed that Permissions - Pop-up setting was Block. When I set it to Allow I was able to accept a cookie pop-up that I couldn’t this morning…

Its very tortuous to access. Open the browser and then open any website in normal mode you like. You have to open a normal website before you can access private browsing (this seems to be a UI ‘bug’). Once a website is open tap on the tab icon on the bottom bar (the square icon with the number inside) to get the list of open tabs. Then use the pulley menu at the top. Pull it down until you see ‘Private browsing’ select this and you will get a new private browsing tab.

1 Like

Interesting that toodledo works for you but speedtest does not. I needed to access an article from the Washington Post this morning for work, so I loaded the website washingtonpost.com and clicked on ‘Browse’ which allows you to access a limited number of free articles before you have to subscribe. You then get presented with the cookie dialog box where you have to check a tickbox ‘Accept’ and then press a button to continue. I found it was not possible to check the tickbox no matter how many times I tried. I also tried tapping the background window and then tapping the tickbox to see if the change in focus registered, but it didn’t. I gave up and used my iPhone instead. However, to make sure I’d got the sequence right to write up in this post I went through the whole thing again … and about the fourth or fifth tap on the tickbox it actually worked this time … but toodledo still doesn’t work for me, nor does the weather channel site posted by @peterleinchen above. No consistency here!

Before anyone asks …yes I do have pop-ups allowed in the browser settings :slight_smile:

No the issue has always been present and affects many websites. Ok actually it works for the given website, but fails on many others. Often the “Accept” button ends up working when you click all around, but the “Customize” subpages are often impossible to validate.


1 Like

I really think this bug report has to be altered so that the focus of it is not a site that actually works, except to the person who reported it.
It would be beneficial to collect the sites that don’t work, as we used to do in TJC, but it doesn’t contribute when the bug report itself is misleading.
I don’t think this is a “GDPR bug”, as many sites will implement it differently - it’s just the way Javascript is processed alongside the DOM and whatnot.
@Steve_Everett, I know you’re frustrated, but all I told you is that the report that you opened is not 100% reproducible. Please consider re-doing it in such a way that others can contribute other sites, and accept the fact that your example works for others, and it’s your device that is at fault (or you didn’t mention certain preconditions to reproduce it).

My interest in helping here is depleted, so best of luck.

Maybe, the picture shows more than just words. This was taken in private mode (thank Steve for the explanation) andwith pop-ups allowed.

Oh good heavens :expressionless: - OK, just for you … I am definitely seeing this behaviour because my device is at fault, my bug report is therefore incorrect. You are right and I am wrong. I will of course reflash my phone to correct my error as you direct. Happy now?

When it walks like a duck, talks like a duck and looks like a duck … then there is absolutely no way it can actually be a duck …

I assume the issue here is that you cannot scroll the dialog box to actually get to the button in order to press it (even if you could) because the focus has not been raised to the dialog box?

Yes! That’s the point!