[Release notes] Vanha Rauma

I trie to install the update.
All went well at first, but after aprx. it said ‘update failed’. Now, the update is not available any longer and the phone already displaya the currebt release version. I just invoked ‘zypper dup’ and I hope this will finish the process.

I can confirm exactly that. More precise: It’s about sending SMS. Receiving is possible even with 4G registered.
Question to jolla: Why aren’t such basic features not tested before rollout? I’d be happy to wait longer for an update, knowing that basic operations won’t be compromised. I can only ask again: Please improve your QA.

It looks like is because VoLTE is enabled. But you have to remember that VoLTE is still in Beta.

Yes also by me on my Sony Xperia 10ii - I lost all cntact pictures and 2. the 4G network on sim1. I solved both with:

  1. open my backup and search in folder “People/data” the file “all.vcf” and open it with the app contacts - after the import and restart the contact apps the pictures are back
  2. delete the sim1 pin in settings and reboot with volume+ and activate the pin for sim1 and wait a long time (60min)
    Now no trouble.
    The new function with microsoft365 work untill to the point, when the administrator is informed. Now I will see what microsoft will answering.
1 Like

Call waiting switch in Phone settings still doesn’t work :disappointed: “Problem with changing Call Waiting status”…

I’m not brave enough to test if Call Barring options now work correctly.

To ask this here, too … ist zstd REQUIRED or an option as of 4.5. See: Q: 4.5 will switch RPM compression. What does that mean for existing RPMs?

Thank you for precise and well elaborated bug report.


[I have consulted one of our experts]
RPMs compressed with xz will still work after switching over to using zstd in SailfishOS.
Currently, both compression formats are supported.


Xperia 10 III update went fine. With Gemini PDA it stuck on update, but a forced restart solved the issue.

Update went on XA2 with no issues @all.

:warning: RECOVERY MODE NOT ACCESSIBLE via “telnet” :warning:

SFOS release flashed on SONY XQAU52 : ( Vanha Rauma )

Also this release does not provide any access to “recovery mode”.
Last known release providing access : ( Kvarken )

IMHO, a critical issue which should be solved. Thanks !

Further reading: [Xperia 10 II] Unable to reach Recovery Mode - #11 by launchpad

No problem, i can give precise report. Jolla recommendation is to provide clean install rather OTA update. So, i use backup toll and then flash the phone. After restore from backup my all apps are deleted. Android storage folders are empty. Documents and downloads on system partition empty. Calendar accounts not working, mail also. I’m asking: what’s going on? It’s so difficult, to add few folders to backup?


OTA-Updates are perfectly fine and flashing your phone surely deletes all data. It is meant that way.
Where did you find a recommendation to do a clean install in order to do a minor OS update?

In the backup control, right above the backup button, there is a note telling you precisely what will be saved in that backup. Hint: It is meant that way.

1 Like

I am guessing he meant this line:

OR How do I reset the phone to factory settings or here: Total device reset

In the articles is is explained very well (I think) what the different options mean.

Just because you can reflash with every new update does not mean you should.
and / or:
Just because you can upgrade from Windows 1.01 to Win 8, does not mean you should :slight_smile:

1 Like

It never came to my mind that one could understand this as a recommendation against the SF update function. Maybe it would be wise @jovirkku to give an extra hint here although the documentation looks good to me.
People tend not to use the normal update function for good reasons and also based on rumors and misunderstandings.
Emphasizing the normal update process a bit more might help.

Edit: @Seven.of.nine and @atlochowski just brought a similar issue up:


And we had a discussion on update methods in the German section


1 Like

Worked well on my XA2. Thx!

Yes i found it in relase notes as “stop relase”. Oh, sorry, it’s my fault, because i don’t read whole documentation. Are You serious? If I buy commercially available system, not beta-dev-geek relase, but normally available product for end user, can I expect normally functioning backup app or warning “hey, copy all data from Android layer because we can’t write a script”? We protect Your data - oh yes, so where i can found it in backup?

I asked @olf. Since 2022/10/02 - 17:22 there’s a updated version of sfos-upgrade. See https://openrepos.net/content/olf/sfos-upgrade
BTW: @nephros asked the same question earlier :slight_smile: On GitHub.

I feel very sorry for you that you lost data. What I wonder: how different would it be if, in the hypothetical case, you had dropped your phone in the ocean?

By this I mean: how do you view a backup of sensitive and important digital data stored on your oh so fragile cell phone?

1 Like

What is a ‘Stop release’ exactly? I always thought this is a necessary precondition for making later updates, isn’t it?