[Release notes] Suomenlinna 4.3.0

Well, I did an extra reboot after the upgrade, and zypper ref for good measure, and I am able to remove and install Battery Buddy.

I have to add that I upgraded using sfos-upgrade (because I was a hasty fool) (Protip: install screen and run the upgrade in it; the home screen restarts and kills the terminal…) which may have something to do with restoring the repos.

Replying to myself, it seems best way is to wait 'till official 4.3 image for Xperia X will be available and try to patch it with g7 script, then reflash.
Annoying as hell, but i’m afraid not much can be done.
Kinda I wish Jolla changed it stance and redo old Xperia ports to Xperia 10 II style.
Or 64bit AOSP10 port done by community with WayDroid working good enough for basic usage.


But they are working on esr78 which is big jump from esr60. I think it will be worth to wait for it.


Yes i know but the main issue is cant use my banking website for a few releases. Its not of urgent need since i have a pc available most of the time but it would be good to have.

I’ve always sshed into my device to do a terminal upgrade, obviously not always possible if you don’t have a PC nearby.

1 Like

I have a Xperia X as a test device. A month ago I did a factory reset and downloaded all versions from 2.0.x all the way (6-7 updates) to but did not install any applications so the system is as is after reset. Today I downloaded (Suomenlinna). Before installing the system tells me to delete or restore packages git-minimal and gittin. Where did these come and how should they be handled?

After 2 tries te update succeeded. Now the version is (Suomenlinna): I found an old discussion [changelog] 3.2.1 Nuuksio [closed] - together.jolla.com telling that these two packages were removed in version 3.2.1. Why do they re-appear after reset?

1 Like

I got these strange symptoms after upgrading to 4.2 on my Xperia 10 II. The Jolla Store asked me to update 4 Jolla apps, but failed. Just like in your case, the gallery, media player, documents, … empty.
Thanks to you, I now know that this is not just an isolated case caused by my own mistake. The cause seems to be out of our hands.

I got the advice from the community to reflash the whole phone, for which I didn’t find time yet.

And btw: I tried pkcon refresh as well (2 times) and 2-3 restarts. No avail.

I just upgrade my Xperia X Compact to 4.3 and everything looks ok to me. No restart so far.


Xperia 10 II. Vibrtion not working.
When the device is turned on, vibration is present, when unlocked, there is vibration. After unlocking, there is no vibration anywhere, even when testing.

1 Like

Since upgrading to 4.3.0, I can no longer send pictures over MMS. Instead of the message (no content is seen in the messages app) there is a retry button and the text “Problem with sending message”. Neither camera pictures nor screenshots can be sent. MMS Logger shows nothing when sending messages. Could it be the sandboxing that stops the messages app from getting access to the content?

I just tried this, and I was able to successfully send and receive an MMS with a pic from me to myself. I had opened Gallery and Messages beforehand, but neither asked for permissions.


I somehow can’t install storeman-installer on 4.3. Anyone has the some problem and even better already a solution at hand :wink:


Is there an error message if you try to install the rpm file using terminal? Download the file.and pkcon install-local filename.rpm


Do you have problems with installation of “storeman-installer” itself (as direc85 and me read) then follow his post and tell us more info.

If you mean that the “storemann-installer” does not install the app “storeman” then read:

Every SFOS release requires a configured OBS repository. Therefore Storeman installation may not be available for some time after a new SFOS release until maintainers configure a new repository. This is especially true for EA release


That seems to be the case here. RTFM :wink: Thanks for helping and sorry to bother you.

May it helps somebody stumbling over it as well.


Hmm, what SFOSX port is this? Official Sailfish X port for Xperia X patched with g7 tool ?
Do you have android support installed and finally did updater complained about packaages droid-compat-f532-* being problematic?

Xperia 10 II. The device feels faster overall which is nice. Unfortunately the majority of my installed Android apps crashes on startup. Cannot start Spotify and not a single Google app for example. Also my Bitwarden icon disappeared from the app drawer, but it is still installed att can be opened from Aurora Store. Hope this will be fixed in the stable build. :slight_smile:

after the update the austrian Covid certificate app «Grüner Pass» disappeared from the app grid. It was still installed and could be opened through the Aurora store.
A reinstall brought back the icon.

Probably it has something to do with the Umlaut ü?


I tried a reinstall which brought the icon back. But it disappeared again after reboot.