SFOS 4.5 feedback thread

Thank you for that valuable help. Disabling VoLTE made SMS work for me again as well.

X 10 III

Here is described how to apply the change: Beta VoLTE on the Xperia 10 III, disabled by default

Concerning problems with internet access from Andoid apps:

On my 10 III I disabled ip v6 for mobile connections because of problems roaming in Poland and Austria.

I kept that setting and just set it to ip v6 only for a test:

Fennec can access the internet with settings to dual or ip and fails with ip v6.

A broken ip v6 stack might explain a lot of problems with certain providers, roaming etc.


Xperia 10 II
Audio is not working on sverigesradio.se “Ljudfilen stöds inte av webbläsaren” (audio file is not supported by the browser), worked on 4.4.
Audio/video works on youtube.com

Hi jovirkku. I prepared the logs via Collect Persistent Logs | Sailfish OS Documentation. How can I send you my log file? Is there any upload functions in this forum? Or do you have an e-mail address where I can send my log file.
Later I uploaded the file via care@jolla.zendesk.com to jolla care support succesfully.

Apparently the upgrade to ffmpeg 5 broke some parts of the browser playback. This has been fixed, but did not make the release. Let’s hope for a hotfix.

Meanwhile… may i suggest the S’Play app?


Ok, found out how it works (@peterleinchen interested??).
Start app-support, ps auxw|grep lxc shows you –rcfile=/tmp/appsupport/aliendalvik/config, there in you have lxc.include = /tmp/appsupport/aliendalvik/10-bsp_config.
Hunting the source of this, since this is volatile. systemctl status aliendalvik gives you the script /usr/lib/systemd/system/aliendalvik.service, there in Requires=aliendalvik-prepare.service and there in …"$CONTAINER_CONFIG_PATH/10-bsp_config". Bingo!
Added thereafter:
echo “lxc.mount.entry = /etc/hosts system/etc/hosts none bind,create=file 0 0” >> “$CONTAINER_CONFIG_PATH/10-bsp_config” and restat app-support.
devel-su appsupport-attach cat /etc/hosts
(this changed in 4.5, see Testing Advice | Sailfish OS Documentation )
Warning: have no idea if this interferes with system updates!


So far, I’m pretty happy with the 4.5 update, a lot of things have been fixed. I’ve reinstalled from scratch on my 10 III, and updated on the last day of Early Access, I literally woke up to the news of public release.

Until today, where I noticed a seemingly familiar bug where audio stops working altogether (no notifications, calls seemingly dont ever start, no media playback) - In the fix was just a pulseaudio -k away (which starts a new pulseaudio instance, -killing any existing ones) and you can carry on like nothing happened. However, this happened twice today. I figured I’d try a pulseaudio -k again but sadly, it did not work. I had to reboot the device to have audio again.

After rebooting, I also noticed that there’s a delay in the AppSupport starting? I tried opening signal but it didn’t open, I had to open it a second time and see the notificaiton App Support is starting to open Signal or similar, and then Signal opened.

I think you can start (or search an existing thread) specific to /etc/hosts and post this there too:)

1 Like

Having a problem with WhatsApp not being able to find it’s storage.

I can send and receive messages, but not images/files.

Receiving an image gives this error:

Download failed
Can’t download because no internal storage is available. Please unmount it as a disk drive, and try again.

I also get an error trying to attach from gallery:

Internal storage required
Please turn off USB storage and try again.

And for images I sent previously:

Sorry, this media file doesn’t exist on your internal storage.

In the WhatsApp logs (/home/.android/data/data/com.whatsapp/files/Logs/whatsapp.log) it’s looking for /storage/emulated/0/WhatsApp/Media/…

2023-02-12 03:14:58.376 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/WhatsApp Video
2023-02-12 03:14:58.379 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/WhatsApp Images
2023-02-12 03:14:58.379 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/WhatsApp Documents
2023-02-12 03:14:58.380 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/WallPaper
2023-02-12 03:14:58.380 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/WhatsApp Profile Photos
2023-02-12 03:14:58.382 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/.Links
2023-02-12 03:14:58.382 LL_D W [313:WhatsApp Worker #4] fmessageio/prepareFolder/nomedia doesn't exist, creating in /storage/emulated/0/WhatsApp/Media/.Links
2023-02-12 03:14:58.383 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder /storage/emulated/0/WhatsApp/Media/.Links; exception=java.io.IOException: No such file or directory
2023-02-12 03:14:58.386 LL_E W [313:WhatsApp Worker #4] fmessageio/prepareFolder/mkdirs failed: /storage/emulated/0/WhatsApp/Media/.Statuses
*lots* more just like it

Weird thing is my chats are still all there and accessible, so I’m not sure where it’s picking those up from.

My old data still exists in

Because I’m not sure that the root dir looks like to Android apps I tried a few mappings:
/storage/emulated/0 → /home/defaultuser/android_storage
/home/defaultuser/android_storage/emulated/0 → /home/defaultuser/android_storage
/home/defaultuser/android_storage/storage/emulated/0 → /home/defaultuser/android_storage

I’m assuming this is to do with the new scoped storage in Android 11.

I’m also wondering if because I think I “cheated” a while ago to create space the easy way I mapped android_storage straight to the sdcard it messed things up in this migration:
/home/defaultuser/android_storage → sdcard

So does anyone know how Android 11 “scoped storage” works? It’s is different structure or just permissions?

Any suggestions on how to handle this?

I also can’t backup my chats because no internal storage was found.

Everything else with 4.5 so far seems to be working well for me.

Thanks, that will do until the fix. (I usually use the news clip flow, but SR does not seem to provide an API for it Hämta ut enskilda nyheter från API:t - Forum för teknisk support - Sveriges Radio)

It would help if separate bug reports are created for issues that are discussed here. Information is likely lost in such a long thread


Official update on XA2 Plus dual sim went smoothly.
After that Bluetooth won’t turn on at all.
Several reboots, normal (power->top menu) or power+volume_up bring no help.
Settings->Bluetooth Restart doesn’t help either.
Not possible to turn on Bluetooth at all! Any Ideas?

The empty bar at the bottom is there so you can actually get out of the folder. That being said, you were probably using launcher patches before, because nothing was changed about the way the launcher works - in fact I’m pretty sure nothing’s changed about the way it works since 2017 or so.


I use this opportunity the continue the list:

  1. Oona Konttinen, 22, voi valita joka päivä, haluaako tänään kuulla ääntäkään | Yle Uutiset

Yle (Finnish national broadcasting company) news site is somewhat broken. Usually the browser crashes instantly, when opening the given link. I was able to reach the fifth tab of that article, but I had to close Android App Support and all the apps I had running, but even then it took a ridiculous amount of attempts.

  1. Naton pääsihteeri Stoltenberg jättää tehtävänsä syksyllä - MTVuutiset.fi

MTV (the biggest Finnish commercial media company) news remain unreadable, since the page layout gets all wonky and the actual news content is not shown.

At least on XA2 bluetooth does not seem to work unless the bluetooth subsystem is restarted from Settings->Utilities. If search this thread you will find simiar posts. I hope there will be a hotfix release.

You’re welcome. After all you started it somehow when asking one year ago how hard it would be to create a week view. After some initial thoughts, I started it as a challenge : can we do the full layouting in QML ? And to answer your question, it took something like 2 weeks, not so hard after all. Then I started discussing with pvuorela and martin from Jolla for integration. My initial design was changed by martin and it took some more weeks to adjust. Finally after long reviews and discussion with pvuorela on technicalities the QML layouting was dropped in favour of reusing the CPP one of the day view.

Here are two screenshots of the initial design:


ok, i have restore the mobile from setting and upgrade other time from 4.1 all version to 4.5; all working fine now.
for keyboard i suppose the problem is come because i have installed this two app very useful

i hope will be included in the official repository

1 Like

I respond to myself.

The problem was not the phone. The Router had selected channel 13 as autochannel…

You’re right. I got mistaken by those 4 rows on the XA2 because I already got used to the 10 III’s much taller screen which fits 6 rows without scrolling. And yes, I’ve been using various launcher patches since ever, so I already forgot how the genuine launcher looks like. Sorry for the confusion.

Which is amazingly unproductive. No wonder that patches like “Launcher combined” allow exiting the folder view by swiping left or right or tapping anywhere where there are no icons, which works just as good and doesn’t waste any screen real estate. A bar consuming 20% of the screen only to be tapped when one wants to exit the view (and serving absolutely no other purpose) must have been the UI designer’s worst idea ever.

I don’t know what changes were introduced in 4.5’s launcher but the code does differ quite a bit making all patches which used to work on 4.3 and 4.4 incompatible with 4.5.

1 Like

It works like a charm! Thank you so much @amaretzek!