[Release notes] Sauna 4.6.0.13

hybris-recovery.img from 4.6.0.13 doesn’t work on the 10 III -bootloop. Don’t Jolla test such things?

What is the error, or what doesn’t work?

I have no problems with Pure Maps and OSM Scout Server under 4.6.0.13.
In fact, when I upgraded from 4.5 to 4.6, it caused osm scout server to be uninstalled. I don’t remember exactly how I did it, but from memory, using the Chum store, I was able to reinstall the latest version of osm scout server. And once reinstalled, you have to tell it where to put the cards (in this case on my µSd card).

No, on the other hand, the cards are getting a bit old and I’m wondering when the updated cards will be available.

As I wrote, it was a bootloop. I had to use recovery image from 4.5.0.25, which keeps working fine even with 4.6.0.13 on the device.

I had no problems with them either until I had to uninstall them :sweat_smile:
Did not want to try the update with them installed if they are marked as “could bring problems” :slight_smile:

Do you use OSM Scout server to download maps updates ? I had regular updates, around once a month and am surprised you say they are old

I just realize: there was a 4.6.11 I am in 4.5, the 4.6.13 was too quickly released before I could install 4.6.11, if they are still all stop releases, that may be the reason I have some troubles ?

:point_right: If yes, that would be a good thing for the OS to only display and download the next stop release.

Will the sfos-upgrade script solve that ? User issues on the app are not reassuring :sweat_smile:

4.6.13 is just 4.6.12 with few fixes to issues found in EA-period and 4.6.12 is just 4.6.11 with few fixes to issues found in EA-period.

When can we expect 4.6.0.13 SDK build targets to be released? Or are the 4.6.0.11 EA targets meant to remain the final ones?

1 Like

I’ve seen a couple of mentions of Android behaviour of the “back” button being fixed in this release, but in my case I’ve found that WhatsApp in particular sometimes has a strange new behaviour in this release. Occasionally, when reading a conversation, if I press the back button to return to the main list of conversations, WhatsApp is briefly minimised to a tile, then returns to full screen. It’s as if the app thinks I swiped to the side, then straight away realises its mistake and pops back up. It never happened before 4.6.0.13.

Anyone else notice this?

3 Likes

There’s the new bug which crashes some Android apps when you start them from app grid, which you can circumvent by starting them from the Android settings instead. But, when you start such and app from the Android settings, then the app does at its start-up what you describe there: the app kind of goes away but then immediately pops back up.

I would guess this is due to the same root cause, but it gets initiated the different way.

1 Like

When you connect a mouse the cursor apears. But does it work properly? I connected mouse but the cursor was stuck on the top left of the screen.

I had to reflash. I was unable to get appsupport to install properly after I uninstalled it (as instructed by the installer). But the weather-app is still not working. It says “illegal authenticationtoken” when attempting to add a location (or something to that effect. Translated from Norwegian). Are other users also still having issues with the weather app?

You can pretty much forget the weather app, the reason you’re seeing notice about authentication token is because there is no license for the data. Jolla, it seems, are not renewing the license. MeeCast from Openrepos seems to be a popular choice.

2 Likes

No, because there is no such thing as SaillfishOS 4.6.11 or 4.6.13. For SailfishOS 4.6.0 is not yet clear, if it will be a stop release, and it does not matter until SailfishOS 5.0.0 is released.

SailfishOS 4.5.0 is a stop release.

It never matters which point release of a stop release you install.
You just have to upgrade at most to the latest point release of the next stop release, and then (if you wish) the same cycle again (and again) until you installed the latest release.

:point_right: If yes, that would be a good thing for the OS to only display and download the next stop release.

That is what the GUI updater in the Settings app does.

Will the sfos-upgrade script solve that ?

As there is nothing to “solve”: No (or “yes”? :wink:). It does the same as the GUI updater: Install the latest point release of the next stop release, if not commanded to use a different release. Its advantage is that the user can determine the release to upgrade to.

2 Likes

I have also experienced this behaviour. I believe it happens everytime a conversation is entered via notification view or notification itself. Sometimes WhatsApp doesn’t even get back to fullscreen and crashes. No more messages can be recieved until the next startup of the app.

the 4.6 android networking issues, together with the full ofono crashes they apparently cause, are rendering my phone unusable. i lose 4g connectivity every few hours when off wifi, without fail, and i have to restart both aliendalvik and ofono to get it back.

downgrading to 4.5 will take me a little time, but sadly i absolutely need to. are other people less affected by this 4.6 issue?

1 Like

On Xperia 10 lll Pure Maps crash. When I try add address application goes small. It worked on 4.5.

1 Like

Ok, I understood, “minor-fix versions” are not part of the stop-release. Good thing :+1:
For the rest of your answers, it’s logic as there is no stop-release for a minor bug-fix version. But the script won’t solve the update asking to uninstall the whole phone then.

Could be linked to the .13 asking to uninstall it before update. Did you try uninstall and reinstall it (OSM Scout Server, Mapnik ?
I have to warn you, you may not be able to reinstall them. It’s my case on a X 10 II

Update went smoothly on my Xperia 10iii. I use Android App Support and MicroG

I had to un-install two apps first. Amazfish and OSM Server.

There were some other files that were listed as needing to be removed but I left them alone. I had removed them for the update on my XA2 and then had issues re-installing apps that relied on these files.

Very happy so far.