[release notes] Pallas-Yllästunturi 3.4.0

I give up, you can’t tell some people.

5 Likes

N9ish Icons has helped me a lot. I’m using UI Themer by Fravaccaro to apply it over the standard UI.
Unfortunately Fravaccaro has withdrawn all his work. Don’t know what has happened on his side.

After the update VPN doesn’t save username and password anymore, and the icon has diasppeared from the top right corner. I have to input username and password every time I connect to the internet. Also OneDrive password is not saved, therefore photos are not automatically uploaded to the cloud.

Anyone else having these problems on XA2 after the update? Is there anything I can do? Everything else seems to work so far…

I had problem with VPN and login, i had to type my credentials (user/password) all the time. But i tried “Network reboot Settings - Utilities - Network reboot” after that my VPN seems to work as usual but i have to do it again after reboot.

3 Likes

I can’t find “Network reboot Settings” from my XA2 settings. :woozy_face:

1 Like

Install ‘Sailfish utilities’ from Jolla store.

2 Likes

Thanks! After the “Network reboot” the VPN icon appeared and after returning from “Flight mode” VPN connection is still up. This means that problem solved! Thank you guys so much!

/etc/profile.d/lang.sh seems to be the culprit:

$ grep grep /etc/profile.d/lang.sh
if [ -n "${LANG}" ] && [ "${TERM}" = 'linux' ] && /usr/bin/tty | /usr/bin/grep --quiet -e '/dev/tty'; then
    if /usr/bin/grep --quiet -E -i -e '^.+\.utf-?8$' <<< "${LANG}"; then

1 Like

There is an internal bug about this issue but I do not have high hopes of getting this fixed soon unless some of the community guys do it. As far as I know, @rinigus has done something.

1 Like

Thank you to all devs for this beautifull 3.4 !! But now i’m waiting the 3.5 version :slight_smile:

  • the “android” applications do not systematically close when you close them and they often remain in the background. It’s also true for the Jolla Store app.

  • the kernel stack bug is not solved and its size increases over the days except by rebooting the smartphone :frowning:
    https://together.jolla.com/question/227579/bug-33-xa2-kernel-memory-leak/

  • Each time you reboot, you have to go to “Utilities” to reindex the database so that Gallery can find the images on the µSD card (which is encrypted).

I’am on a XA2- H3113 - monosim.

1 Like

@jovirkku and @elvarr: compass using Android rotation vectors has been merged about a month ago and later fixed by @mal for older devices. There is one more MR submitted to qtsensors which would allow to get compass working on devices without rotation vectors.

The patches were developed for Xperia Tama (XZ2, XZ2c, XZ3) and have been used for a while by those devices. I would expect that it will work on Xperia 10 as well. As far as I remember, @mal tested them on it. While mobile compass is not perfect, it does have its use. For example, Pure Maps allows to you to rotate the map according to the compass making it easier to orient. Just don’t expect perfect orientation, it is few degrees +/- even after taking into account magnetic declination.

I would think next release could get it enabled on the official devices. I expect that these devices support Android rotation vector (not sure about J1). In the end, it is just adding

orientationadaptor = hybrisgeorotationadaptor

in the plugins of sensorfw, as in https://github.com/sailfishos-sony-tama/droid-config-sony-tama-pie/blob/master/sparse/etc/sensorfw/primaryuse.conf#L7.

Edit: see @mal reply below - there is an issue with blobs with rotation vectors on Xperia 10, unfortunately. So, the other solution has to be applied.

7 Likes

The rotation vector adaptors won’t help on Xperia 10 because the problem appears to be in vendor blobs and many sensors seem to broken, those send a couple of initial values but then reporting just becomes constant. To fix compass on Xperia 10 a virtual compass sensor has to be added to either qtsensors or sensorfw.

5 Likes

@mal: thanks, forgot about it. Added a corresponding note to my post to avoid confusion in future.

2 Likes

the “android” applications do not systematically close when you close them and they often remain in the background.

That’s a (normal) Android thing. “open” and “closing” apps in Android is about opening and closing their windows (The “views” in MVC parlance) not the actual application.

I wrote a HOWTO on the previous Question-forum. Basically, you have to hunt down all the way which could automatically start an app in the background (autostart, cloud messaging, notifications).

It’s not 100% complete, there are still way to start an application.

Notably, the “share” function in Android: applications have to option to directly list destination. E.g.: chat applications list your most frequent contact so you can directly send them a picture from the share screen - instead of needing to , e.g.: select the contact in WhatsApp. AliExpress’ app is an example that gets started this way (whenever you share a picture, AliExpress also starts to suggest chat threads to share it into) and it manages to stay active even after.
A circumvention to avoid that is to install AlienDalvik Control and share photos from within Sailfish: ADC will add an extra “Share to Android” entry in Sailfish’s “Shareto” function, and that one only list accepting application, it does not start the applications themselves to obtain a list of most frequent contacts.

You still have to stop apps manually who refuse to exit when you close their windows (but again, that’s standard Android function, it’s the same on android tablets).

the kernel stack bug is not solved and its size increases over the days except by rebooting the smartphone

Also @elvarr:

Compass does not work on Sony Xperia 10 Plus.

This whole class of problem would completely go away if Jolla accept to sell Sailfish X (complete with AlienDalvik, etc.) on devices that support upstream vanilla kernel.
Most of it arise due to old kernel on whatever blob the manufacturer provided at the time Jolla ported the adaptation layer. Even if some companies - like Sony for Xperia X - do provide some firmware updates (unlike Qualcom for Jolla 1), it seems that the Jolla devs lack the time/ressources to port a new adaptation on top of it.

e.g.: The PinePhone from Pine64 is supported by a standard kernel. Any new update to kernel and driver done by the larger linux community can be used directly, without needing to have someone battle against some android firmware blob with libhybris.

Now specifically:

its size increases over the days

Not a solution, but a workaround: buy some “High Endurance” µSDHC or µSDXC(*) card, and make a 4GiB swap partition there.
Leaked unusude memory will get swaped out and won’t eat your RAM.

(*): Just make sure to reformat the main partition from exFAT to something supported in Sailfish. I personally go for BTRFS, but EXT4 would be a perfectly valid solution. Use FAT32 if you want to share easily with a Windows latpot.

4 Likes

Thank you very much for all your explanations. At the moment I always preferred not to install applications by openrepos. I will apply your recommendations and leave myself a few days to see if it improves the closure of androids apps. On the other hand, I do not control the command line enough to pass the swap on the µSD card. Maybe at Christmas, if my son can come and see us and if he agrees to do it. He is a computer developer who masters this particularly well. And sorry for my poor english so i used an automatic translator.

But that’s exactly the way how Android became what it is today. Totally overpacked with so many functions and possibilities accompanied with the desire to satisfy every customers needs resulting in confusing menues.
From my point of view the function should stand above the look. Comparing the old and new behavior how to pick up the phone, I really can’t see any advantage between them. It’s just a different way how pick it up.

1 Like

@mal This could explain why my Xperia 10’s proximity sensor tends to fail after a couple of days while I have no such problem with the XA2. Can you confirm this?

(The problem is there for a while and has nothing to do with 3.40.24 which did not provide any problems for me)

There is an issue in the Xperia 10 kernel and/or modem/adsp firmware which causes those subsystems to reset sometimes and it doesn’t always recover correctly, sometimes that causes also loss of audio.

1 Like

@mal - do you have any more information on this topic?
I have opened a bug-report Whole audio dead and sensors (proximity / light) stop working - but not answer/idea yet where it does come from