Whole audio dead and sensors (proximity / light) stop working

REPRODUCIBILITY happens “sometimes”, some minutes after reboot, sometimes the phone works for days
BUILD ID = Sailfish OS 3.4.0.24 (Pallas-Yllästunturi)
HARDWARE X10 dual sim
UI LANGUAGE: English
REGRESSION: also broken on 3.3

DESCRIPTION:

After some time of usage the X10 dual sim does not make any sound at all.
Not with media player, no timer, no csd tool or call can make any sound - volume is not muted!

When i receive a call, vibration is working, if I answer it i do not hear the remote person, and the other side does not hear me. In this situation the display behaves strange -> stays black, only pressing the power button gives me the possibility to end the call.
When i check the proximity sensor in csd-tool I do not get any readying - same for light sensor.

After reboot everything is working fine.

PRECONDITIONS:

Working Xperia X10 dual SIM with sim1 vodafone.de and sim2 congstar, both active.

STEPS TO REPRODUCE:

no idea :confused:

I think this happens more often if I am in a area with bad mobile network, e.g. shopping center, basement, but also happens at my desk at home with no movement and perfect network coverage.

EXPECTED RESULT:

Audio should always work!

ACTUAL RESULT:

No Audio on speaker/headset at all
proximity/light sensors don’t give a reading - not shure if connected?

ADDITIONAL INFORMATION:

When i try to “make a sound” e.g. ominous beeping app:

Oct 16 20:03:15 Xperia10-DualSIM kernel: glink_tx_common: 170 callbacks suppressed
Oct 16 20:03:15 Xperia10-DualSIM kernel: apr_audio_svc_lpass_smem: glink_tx_common: R[0]:68 Intent not present
Oct 16 20:03:15 Xperia10-DualSIM kernel: __apr_tal_write: glink_tx failed, rc[-11]
Oct 16 20:03:15 Xperia10-DualSIM kernel: apr_audio_svc_lpass_smem: glink_tx_common: R[0]:68 Intent not present
Oct 16 20:03:15 Xperia10-DualSIM kernel: __apr_tal_write: glink_tx failed, rc[-11]
Oct 16 20:03:15 Xperia10-DualSIM kernel: apr_audio_svc_lpass_smem: glink_tx_common: R[0]:68 Intent not present
Oct 16 20:03:15 Xperia10-DualSIM kernel: __apr_tal_write: glink_tx failed, rc[-11]
Oct 16 20:03:15 Xperia10-DualSIM kernel: apr_tal_write: Unable to send the packet, rc:-11
Oct 16 20:03:15 Xperia10-DualSIM kernel: apr_send_pkt: Write APR pkt failed with error -11
Oct 16 20:03:15 Xperia10-DualSIM kernel: afe_set_lpass_clk_cfg: AFE clk cfg failed with ret -11
Oct 16 20:03:15 Xperia10-DualSIM kernel: afe_set_lpass_clock_v2: afe_set_lpass_clk_cfg_v2 failed -22
Oct 16 20:03:15 Xperia10-DualSIM kernel: msm_sdw_codec 152c1000.msm-sdw-codec: __msm_sdw_reg_read:failed to enable the INT_MCLK1
Oct 16 20:03:15 Xperia10-DualSIM kernel: __msm_sdw_reg_read: 20 callbacks suppressed
Oct 16 20:03:15 Xperia10-DualSIM kernel: msm_sdw_codec 152c1000.msm-sdw-codec: __msm_sdw_reg_read: codec read failed for reg 0x218
Oct 16 20:03:15 Xperia10-DualSIM kernel: msm_sdw_codec 152c1000.msm-sdw-codec: regmap_bus_read: Codec read failed (-22), reg: 0x218, size:1

loudspeaker test in CSD Tool:
Oct 16 20:04:49 Xperia10-DualSIM kernel: glink_tx_common: 110 callbacks suppressed
Oct 16 20:04:49 Xperia10-DualSIM kernel: apr_audio_svc_lpass_smem: glink_tx_common: R[0]:68 Intent not present
Oct 16 20:04:49 Xperia10-DualSIM kernel: __apr_tal_write: glink_tx failed, rc[-11]
Oct 16 20:04:49 Xperia10-DualSIM kernel: apr_audio_svc_lpass_smem: glink_tx_common: R[0]:68 Intent not present
Oct 16 20:04:49 Xperia10-DualSIM kernel: __apr_tal_write: glink_tx failed, rc[-11]
Oct 16 20:04:49 Xperia10-DualSIM kernel: apr_audio_svc_lpass_smem: glink_tx_common: R[0]:68 Intent not present
Oct 16 20:04:49 Xperia10-DualSIM kernel: __apr_tal_write: glink_tx failed, rc[-11]
Oct 16 20:04:49 Xperia10-DualSIM kernel: apr_tal_write: Unable to send the packet, rc:-11
Oct 16 20:04:49 Xperia10-DualSIM kernel: apr_send_pkt: Write APR pkt failed with error -11
Oct 16 20:04:49 Xperia10-DualSIM kernel: afe_set_lpass_clk_cfg: AFE clk cfg failed with ret -11
Oct 16 20:04:49 Xperia10-DualSIM kernel: afe_set_lpass_clock_v2: afe_set_lpass_clk_cfg_v2 failed -22
Oct 16 20:04:49 Xperia10-DualSIM kernel: msm_sdw_codec 152c1000.msm-sdw-codec: __msm_sdw_reg_read:failed to enable the INT_MCLK1
Oct 16 20:04:49 Xperia10-DualSIM kernel: __msm_sdw_reg_read: 10 callbacks suppressed
Oct 16 20:04:49 Xperia10-DualSIM kernel: msm_sdw_codec 152c1000.msm-sdw-codec: __msm_sdw_reg_read: codec read failed for reg 0x218
Oct 16 20:04:49 Xperia10-DualSIM kernel: msm_sdw_codec 152c1000.msm-sdw-codec: regmap_bus_read: Codec read failed (-22), reg: 0x218, size:1

Even longer log done later: nopaste long log

Mentions before: [3.4.0.22] XA2 phone calls no audio and https://together.jolla.com/question/225772/xperia-10-plus-no-audiosound-with-new-log/

1 Like

I got this too, I have raised bug report here too, but still no any reply or answer…


1 Like