[release notes] Koli 4.0.1

Enable Do Not Disturb mode to turn off notification sounds and vibrator feedback


Address books support developed for contacts

Yess! :muscle:

  • Keyboard colours now follow the application theming (apps can override the ambience style)

Do we have control over this ? I really like the unified look given by ambiences.

I also have hard time dealing with some colors and the way ambiences works now have greatly improved my life by allowing me to remove them from the main interface.


Overall very positive upgrade experience (XA2 Dual Sim).

The update went through flawlessly. Had a few hiccups with contacts that were not showing up and calendar events. Easily resolved by making sure that I give permissions to the Contacts app and also go to all the Accounts and do a re-sync to bring all the calendar events and cloud contacts. Rebooted a couple of times in between and contacts appear normally. Also the call log got populated with the names instead of just showing numbers once the contacts loaded and I rebooted. Very happy, seems like a solid release and much better experience compared to the 3.4 update.

Another nice touch was the warning to uninstall some apps from OpenRepos (Contrac and System Monitor in my case) before starting the update - it’s good to see Jolla listening to the community requests :slight_smile:

Interesting UI changes, not sure if I like all of them but I am happy to see changes/experimenting/evolution.

Keep up the great work! Looking forward to new hardware support :wink:

PS: Seems that the battery life returned back to the previous levels, I am at 49% after 24hrs since last charge with the same use pattern as with 3.x versions. 3.4 introduced some horrible battery drain which I never tracked down, resulting in the phone barely lasting for a day with a full charge…


Issue with my XA2, single sim. After this screen:

After reboot I am stuck either on the Sony screen, or passing it, but then it stays black. Backlight turns on when pressing power, but that’s all. No SSH access.

Update failed on XA2. (Alien dalvik removed / storeman removed / all patches disabled)
Stuck while checking the device lock code.
Where and when to except v4 image to flash please ? :slight_smile:
EDIT: never used Defender app

About the warning note regarding to Defender:

Are there plans to bring back bash at some point? Busybox’s ash is an inadequate replacement for bash in my opinion, as simple things like shopt are not present, nor arrays. I’m sure there’s a ton more, but those are the first two issues I ran into when running a bash script on Koli.

Thank you.


Terminal does not seem to remember previous commands anymore.


Had the same. Since then I see only “waiting for connection”, wenn triggering the update. I guess this error you show is maybe due to an incomplete download.

gPodder has some UI bugs, hope to get to them soon.

Incidentally, this title is a little misleading. When I first read it, I thought “uh? Koli? Never heard of this app; what does it do?”.

1 Like

Hmm, that text has been inherited from the times of Jolla Phone where there was often a lack of storage space. Downloading and processing an OS update of hundreds of megabytes requires some free space. “Internal storage” referred to the storage inside the device, in contrast to external storage in a memory card. It is the time to reconsider that text.


Update went on my case fine yesterday on XA2 Dual-Sim. The phone was a bit sluggish first but it has settled down. Unfortunately Situations app doesn’t recognize the phone screen state (on/off) correctly anymore :frowning:

Great job though!

Update worked fine yet Android apps do not have internet connectivity with cellular network (3g/4g does not make any difference). When wlan is on Android apps work fine. Sony XA2 dual sim. I tried flight mode - does not help and reverting back to Android and then installing Sailfish seems a bit burdensome (and I’d need to find a Windows computer first :slight_smile: ) Solved: activated empty sim slot, deactivated the actual sim. Repeat the other way around and reboot = = > Android apps have connectivity in cellular network.


@oroesler thanks for the hint. That sounds very promising, however I didn’t find any further info on that here in this forum nor on https://together.jolla.com. system_a is not a useful search term.
Do you have any link available? Could you expand on that?

Anyone else have issues with the browser since the update? I have installed a pretty hefty /etc/hosts on my phone to block unwanted cruft when browsing, since I cannot manage to install Privacy Badger, and since the update the browser is ignoring these entries.

This seems to be related to the new firejail setup (which is a really great idea, btw!). I’ve looked into it a bit and it looks like it should work. Browser process runs like this (according to ps)

/usr/bin/firejail --quiet --profile=/etc/sailjail/permissions/Base.permission --profile=/etc/sailjail/permissions/Mozilla.permission --profile=/etc/sailjail/permissions/Audio.permission --profile=/etc/sailjail/permissions/Location.permission --profile=/etc/sailjail/permissions/Internet.permission --profile=/etc/sailjail/permissions/Downloads.permission --profile=/etc/sailjail/permissions/Documents.permission --profile=/etc/sailjail/permissions/Pictures.permission --profile=/etc/sailjail/permissions/Videos.permission --profile=/etc/sailjail/permissions/Music.permission --profile=/etc/sailjail/permissions/Sharing.permission --profile=/etc/sailjail/permissions/sailfish-browser.profile --whitelist=/usr/share/sailfish-browser --whitelist=/usr/share/applications/sailfish-browser.desktop --whitelist=/home/nemo/.local/share/sailfish-browser --mkdir=${HOME}/.cache/org.sailfishos/browser --whitelist=${HOME}/.cache/org.sailfishos/browser --mkdir=${HOME}/.local/share/org.sailfishos/browser --whitelist=${HOME}/.local/share/org.sailfishos/browser --mkdir=${HOME}/.config/org.sailfishos/browser --whitelist=${HOME}/.config/org.sailfishos/browser --dbus-user=filter --dbus-user.own=org.sailfishos.browser --private-bin=sailfish-browser -- /usr/bin/sailfish-browser

The Internet.permission profile contains this entry:

private-etc ssl,hosts,pki,crypto-policies

Which, AFAICT, should copy the hosts file into the private jail. However, all the blocked entries (that are hardcoded to go to in /etc/hosts) will now open in the browser. If I open the browser from the terminal without jailing it, this doesn’t happen.


Update went smoothly on my XA2 plus Dual Sim.
I don’t like at all the new notification UX: either on main screen and in the event view. I found managing notifications in event views more friendly before. Besides icons are ugly and again a step toward android.

1 Like

Thank you for this update. It works well so far. I only had one problem: the update failed the first time I attempted to perform it, but worked flawlessly the second time. I particularly enjoy the firejail sandboxing integration. Notification actions are a very useful feature as well.

Xperia 10 updated and everything went smoothly. But Android support does not work anymore. If I open Settings => Android -Support => cannot Start/stop press buttons because they are disable. (phone is rebooted couple of times)

When trying to start Android app it will try to load it for a while and then it fails.
When I look journalctl it shows following entries:
helmi 05 11:49:27 Sailfish kernel: binder: 4617:4617 transaction failed 29189/-22, size 0-0 line 3024
helmi 05 11:49:28 Sailfish kernel: binder: 4617:4617 transaction failed 29189/-22, size 0-0 line 3024

Tried to uninstall/reinstall Android support but id did not change anything.

Edit: journalctl -xe output:

  • Unit aliendalvik.service has failed.

    – The result is RESULT.
    helmi 05 11:56:12 Sailfish systemd[1]: selinux: Unknown class service
    helmi 05 11:56:13 Sailfish apkd[4617]: Alien Dalvik is activating (auto-restart)
    helmi 05 11:56:13 Sailfish kernel: binder: release 19897:20006 transaction 284151 in, still active
    helmi 05 11:56:13 Sailfish droid-hal-init: Received control message ‘interface_start’ for ‘android.hardware.radio.config@1.0::IRadioConfig/default_alien’ from pid: 2889 (/sy
    helmi 05 11:56:13 Sailfish droid-hal-init: Could not find service hosting interface android.hardware.radio.config@1.0::IRadioConfig/default_alien
    helmi 05 11:56:13 Sailfish kernel: binder: send failed reply for transaction 284151 to 20026:20110
    helmi 05 11:56:13 Sailfish logd: logdr: UID=1000 GID=1000 PID=935 n tail=127 logMask=19 pid=0 start=0ns timeout=0ns
    helmi 05 11:56:13 Sailfish kernel: ptrace attach of “system_server”[21196] was attempted by “crash_dump32 155 981 1”[21177]
    helmi 05 11:56:14 Sailfish init: Untracked pid 986 exited with status 0
    helmi 05 11:56:14 Sailfish init: Untracked pid 1005 exited with status 0

after that a lot of these:
helmi 05 11:56:15 Sailfish libprocessgroup: Error encountered killing process cgroup uid 1000 pid 41: No such file or directory
helmi 05 11:56:15 Sailfish init: Sending signal 9 to service ‘ril-daemon’ (pid 40) process group…
helmi 05 11:56:15 Sailfish libprocessgroup: Failed to open process cgroup uid 1001 pid 40: No such file or directory
helmi 05 11:56:15 Sailfish libprocessgroup: Error encountered killing process cgroup uid 1001 pid 40: No such file or directory

helmi 05 11:56:16 Sailfish systemd[1]: aliendalvik.service: Service hold-off time over, scheduling restart.
helmi 05 11:56:16 Sailfish systemd[1]: aliendalvik.service: Start request repeated too quickly.
helmi 05 11:56:16 Sailfish systemd[1]: aliendalvik.service: Failed with result ‘exit-code’.
helmi 05 11:56:16 Sailfish apkd[4617]: Alien Dalvik is failed (failed)

1 Like

Is that fix available as patch for users to try?