[release notes] Koli 4.0.1

Thank’s @Maus. I didn’t read carefully enough. :slight_smile:
I started the installation, but wasn’t successful.
“Sailfish OS could not be updated. Please try again later.” After reboot the phone works fine with version.

@jovirkku it fails at uploading… I’ve deleted and readded the onedrive account but it still fails :

@damoleon: Can you “share” pictures from Gallery with this OneDrive account, i.e. does uploading work from Gallery to OneDrive?

@jovirkku yes uploading from Gallery to onedrive works.

Okay, so far the update was mostly smooth, but for some reason typing in some flutter apps sometimes becomes super laggy and there seems to be no way to fix that but by waiting. FTR, that is an older version of FluffyChat, that still runs on the X (Compact). No idea, if that is related to keyboard, alien dalvik or other changes. Also some apps seem to use more CPU and sometimes it takes a while to switch between apps and their content becoming visible?

My experiences so far with 4.0.1 (on Xperia X F5121):

  • GUI tweaks are welcomed :slight_smile:
  • RAM consumption appears a bit lower than before
  • (as mentioned before) Browser bookmarks lost after update
  • (as mentioned before) Terminal history not saving, also issues copy-pasting if both the source app and Terminal are not running at the same time (paste button stayes grayed out)
  • Accounts: when enabled/disabled, the change does not reflect in email until restarted
  • If started immediately after reboot, the email app shows no accounts until restarted


  • Exchange account often shows error in email, still trying to figure out any pattern to it…
  • at least twice: after restart, phone acted very sluggishly, monitoring app Lighthouse showed CPU1 being at 100% while other cores stayed at 0%

My biggest issue is with Bluetooth: after having had the phone in airplane mode, bluetooth may appear working (icon on top, shown on in settings etc) but it cannot connect to devices. Running the Bluetooth test in CSD, shows “Turning Bluetooth on…” but it timeouts. After that the icon on the top bar disappears (leaving a blank spot between icons) and Bluetooth cannot be turned on from settings (blinks, but nothing happens) until the phone is restarted. (Are there any terminal commands to reset Bluetooth more with more force?) This has now happened to me daily! (In earlier versions, I did have the BT off, cannot turn on until reset -problem too, but very rarely).


I have the same problems as ^ with regards to bluetooth on the Xperia X.

Bluetooth icon sure is nonsensical most of the time (XA2 Ultra). I wish it was fixed in 4.0 but no luck I guess… Well, I’m reflashing my device for various reasons today, let’s see if that helps…

There are other terminal apps, ToeTerm (I try to maintain it) and others.

The packages are downloaded to /home/.pk-zypp-dist-upgrade-cache/ before the installation. That’s probably not dangerous if you run out of space there. How much it requires in rootfs I have no clue, I guess it’s better not to try at home…

Bluetooth works for me on EA with an XA2 h3113.

I enable Bluetooth, connect it to my Panasonic headphone. Set the phone to airplane mode. Turn that off 10 seconds later. Then it automatically connects again the the headphone and I can play music again.

I also have bluetooth problems with 4.0.1 (on Xperia X F5121).

When entering in the terminal:
[nemo@Sailfish ~]$ ssu lr
[W] unknown:0 - QConnmanEngine: Unable to translate the bearer type of the unknown connection type: “bluetooth”
[W] unknown:0 - QConnmanEngine: Unable to translate the bearer type of the unknown connection type: “bluetooth”

I could update one Jolla C and XperiaX without any problem (both with increased root size if this matters).
The positive thing is, my Jolla Account did survive this update, in the past i everytime had to put in the password again.
On the other hand i must say, more buttons for omp, no apps from omp.
The messages cover has still the unsightly and not adjustable white lines and the background of the webview in the mail-app ist still white and seems to be also not changeable :-(.
The mail-app says no accounts, when it for instance startet with “Apps after boot”.
The new notifications should be adjustable in their vertical position on the screen because they are often hide and disturb other items and actions.
Last but not least, the update leaved our beloved patchmanager unfunctional ;-).

The file is owned by group privileged. No idea whether it is important to preserve that.

Jolla Phone is not supported any more. OS release 3.4.0 was the last one for this device launched 7 years ago.

@jovirkku and team: Congratulations for keeping the device up-to-date for so long, and showing iOS and Android how it should be done.
I really appreciate the work you do, and am grateful that you do it.


Xperia X installation went flawlessly and everything works apart from a regression in the browser. My Salesforce internal website loads but does not render anymore which is a big problem for me at the moment and makes me consider installing Android support to install Firefox.
Xperia 10 installation also went flawlessly and the website opens so it’s only on the Xperia X (main device).
The browser tries to do something as it’s task is taking 80% of the processor as seen in lighthouse (top).
I tried leaving the device doing it’s work but even after 2 minutes nothing appears.
It does work in the private browsing though! Does the browser have a cache that could be deleted, might help.

It has something to do with my HOST file. I download it from https://winhelp2002.mvps.org/ to keep the web mostly AD free. I will restore the original HOST file and see if that helps. Clearing the cache did not help though.

Re Clock - if still not working have you tried the solution in Sailfish Core Apps do not work after Update to Sailfish (sandboxing problem?)

devel-su pkcon install --allow-reinstall jolla-clock

1 Like

The “computer” side of things seems to be working fine on my XperiaX 5122.

However, there is NO ANDROID whatsoever. Everything just crashes at startup. This is disappointing as there are a couple of apps that are supported on 4.x and which I still use :frowning:

And with the Jolla C Phone?
How long will this device be supported?

I’d think SFOS 4.* will be the last one. They should drop all those handicapped oldies.

Hello @ninepine,
thank you very much for this hint.
It is a little bit strange: This solution works (the clock-app starts after reinstalling) - but after a phone-restart the issue appears again.

For me, the circumstance is not too tragic, since I planned to reinstall the system anyway.
If I could have solved the problem, I would have postponed the reinstallation to a later time.
Now I wait until the official version is available and then do a “Sailfish restart”!
(There are some other little problems that I hope to solve this way).

Thanks for the feedback.

Edit: Now I have it! After I read the original post then but correctly. First “pkcon remove harbour-dynclock”, then again “devel-su pkcon install --allow-reinstall jolla-clock”! Now it works even after a reboot.

Thanks again!

1 Like