Problem taking calls on Xperia10iii

I haven’t activated or tried the VoLTE support yet but i do have problems with taking calls.
The problem differ some from time to time.
Sometimes the network goes down and a can’t call or take calls and to toogle flightmode doesn’t help so i need to restart the device.
Very often i can’t take calls at all and i only get an sms that someone tried to reach me and i need to restart the device to be able to take any call, if i’m waiting for an important call than i’m in big trouble since i don’t know if i will be able to take the call or not.

The most common problems is connected to a three signal tone that used to be used form when a number have no subscriber here in Sweden.
When i hear the tone while i hear the call signal for a incoming call i know that i won’t be able to answer and if i try it will disconnect when i try but for the caller it’s like i never tried to answer and they will stop ringing because i didn’t answer with time.
Sometimes i don’t hear any incoming call but i hear the “no subscriber tone” when the caller stops ringing.
Sometimes there is no “no subscriber tone” but i still can’t answer the call.
I had xperia10iii for some time but it more or less useless as a phone since i can’t take calls reliably and can’t be trusted and i use it every day but i still need my XA2 as a backup device.

Are any of these problems known?

It is very hard to follow what you are saying.

This specifically needs to be broken up into tiny parts and explained like if to a 5-year old. (At least if i am to be able to understand…)

So the phone does not ring, but still somehow it plays you $THE_TONE just when the caller gives up on calling you?

CS-fallback is notoriously fragile (as a concept even)… so consider trying VoLTE.

The last part, i.e. that the ‘no subscriber tone’ playing I can reproduce, or rather I see that issue as well.

  • receive call
  • do not answer in time
  • da-dit-diiit plays

And yes that also happens when the phone is ‘silent’, or connected to a car kit/headphone, or the ringtone is ‘no tone’.

Sound always comes out of phone speaker, not headset, and not phone earpiece.

Is this approximately a “I IV VI” rising tone pattern? On US phone networks in the olden days, it would be followed by a recording “The number you have dialed has been disconnected or is no longer in service. . .”

I think I’ve seen this – well, heard this – on my Xperia 10 II with Volte enabled. It’s really alarming when you attempt to answer a call just as it’s forwarded and you get the tones coming out at speakerphone volume right next to your ear! It is definitely not something I expect to hear when receiving a call.

1 Like

It could be since i’m not familiar with with “I IV VI” tone, here in sweden it’s for “numret har ingen abonnent” that translates to no subscriber.

Yes, it happens in a lot of different situations and i can’t seem to find any pattern.

It’s even harder to try to find any pattern to it.

More or less it can happen no matter what but when i hear the no subscriber tone then i can’t answer or it means that i missed a call that i may or may not have been aware of.

Sometimes yes.

It has worked fine on my other sailfish phones and should be the stable solution while to my understanding VoLTE is still beta.

Sometimes the phone connects only to 3G while it normally should be 4G and it’s an indication of problem that needs reboot, like 4G just crashed and doesn’t want to work anymore.
After a reboot everything i fine again it it connects to 4G network.
All my other devices connects to 4G at the same location (home) the 3G coverage is real bad here while the 4G coverage is excellent.

So, Audible tone after ignoring call also applies to Xperia 10 mark 3… I provided logs to @slava but no idea if he picked them up…

Thanks for the link and it’s the Special Information Tone (SIT) as linked in that thread.
Yes but the SIT is so random so it can happen no matter what but it seems to indicate that something is wrong.

1 Like

I could reproduce. The caller must not hang up but let the telco terminate the call. This is/was necessary but not suficient. I couldn’t find a strict 1:1 depency on the provider.

1 Like

I need to test some more but i don’t think i had this problem with Struven ketju 4.5.0 yet.

With 4.5.19 there are some problems again but this time the big problem is the lack of sound/audio.
Sometimes when i answer there is no sound/audio at all and i even had audio stopped working during a longer call and the only way to fix the audio is by rebooting

Are you aware of:

… and friends ( [] XA2 phone calls no audio - #81 by amaretzek (there is a tick missing!)) ?