[] XA2 phone calls no audio

Nice to see this made it in the newest image I just downloaded. :slightly_smiling_face:

I am also having this problem, on a freshly installed XA2 (build
A reboot fixes the problem, but this is not an acceptable solution !

I paid 50 bucks for this OS, I am expecting that this kind of functionnality works out of the box !

1 Like

Does killing adsprpcd bring back audio wo reboot?

1 Like

I can reproduce the bug fairly often after rebooting when I don’t activate the sim card right away.

I have this disappearing audio bug once in a while. Not often. I just reboot but will try to kill this daemon next time it happens, if I remember haha

I installed qCommand to execute a script as root (real bash is installed).


PIDtoKill=`ps axuw|grep adsprpcd|grep audiopd|grep -v grep|grep -v restart|awk '{print $1}'|grep '[0-9]'|grep '^[0-9]*$'`

if [ "x$PIDtoKill" != "x" ]
  #echo "PIDtoKill: $PIDtoKill"
  #kill -9 $PIDtoKill 2> /dev/null 1> /dev/null
  kill -15 $PIDtoKill

So, a normal user can just tap a few times on the screen and have call audio again.
This is faster than rebooting.

Got the bug now on three devices at a time. Killing adsprpcd worked. But why on three devices at the same time??

The TimeoutStartSec=120 line is in the newest 4.1 release, but it didn’t help.
BTW, couldn’t you just do systemctl --user restart pulseaudio instead of rebooting?


From what I figured in my tests, restarting PA doesn’t help. Even reboot is not a garanty for bringing call-audio back. But my script didn’t fail on my devices, so far…

1 Like

You’re right. I use it on my kubuntu box, where sound also is flaky.
I will try your script. Does it need you to install a “real” bash?

Didn’t test, won’t do it too soon. If so, I’ll report…

1 Like

Thanks. For now I have audio, but I have saved your script and added it to qCommand.

I can confirm that I’m also having this issue with on my XA2. This bug has persisted through several OS updates at this point - I would have thought failure of basic phone functionality would be quite a high priority for development of a phone OS, but it appears not…


Same here. Just updated to on XA2. And audio only re-appeared after two reboots. Made us miss out on a relatively important phone call though. So, indeed, I agree this would be useful to again look into.

Hi @amaretzek,

is something missing from your script?

A single ` then no other ` to close?
By the way, the preferred way should be $(some command).

On Xperia 10 Dual SIM, I am running SFOS since a few days. I have today for the first time no phone call audio. Everything else (sound-wise) works as before. Doesn’t seem to be a hardware issue.

What is there to try?

Yes, closing tick is missing…Thanks.

The command/script by @amaretzek did the trick for me too. Indeed, there is audio back.
This “bug” is annoying. Obviously.


Thanks a lot! Can confirm that after killing both adsprpcd processes, i.e., just running devel-su pkill adsprpcd, resolves the issue for me when this happens. The adsprpcd processes immediately respawn and the audio is back during the phone calls.

I’ve used this trick several times now and so far worked every time.

1 Like

Could someone discuss this topic at the next community meeting? Unfortunately I can’t attend during working hours.