No audio in a telephone call,, XA2

Not all versions but in SW_binaries_for_Xperia_Android_8.1.6.4_r1_v16_nile image. And Sailfish X won’t support Android 9 binairies on XA2. What version of android you had before flashing?

Oreo - Android 8

Android 8.0 and not 8.1? It still can be different version, as it’s overwriten durring flashing sailfish.

Didn’t ever check that closely; Its an XA2 from 2018, so it would have had what that model originally came with. I have refreshed it several times with SFOS and always used the earlier binaries (v16 I think) as the later one apparently doesn’t work to well with the 5GHz wireless. But I still can’t imagine this can make any difference as this problem seems to affect many phone models, not just the XA2.

I have used also v16 binaries only, maybe need to test v17b it has effect. But I have had always this problem on XA2 with all versions of Sailfish X from 3.2.1 → At least with my Jolla1 won’t have this problem.

Killed /odm/bin/adsprpcd (sig=15), no audio, killed /odm/bin/adsprpcd audiopd and audio was back.@jovirkku, does this help?


It does help indeed. Same experience here, killing adsprpcdonly didn’t help… but killing adsprpcd audiopdthen that respawned and the issue is fixed (for now I guess) without the need to reboot.

Is this an indication that the boot seq. is not fully correct? Are these deamons being initialized too soon? As in before the actual devices are available or the correct volume mixer settings are loaded?

So the full instruction set:
$ devel-su
# ps ax | grep adsprpcd
from the output there will be 2 entries with the same binary name: adsprpcd, use the PID for the entry with adsprpcd audiopd in next line.
# kill #here_number_pid#


I’ve got the same issue with my X10 and my old X
Intermittent no audio incoming calls

Just had that yesterday with my XA2 updated to 4.1. Reboot, issue fixed. Annoying.

For me on XA2 (H4113) killing /odm/bin/adsprpcd it does not give sound durring call, but next call has sound.
So it helps.

  1. didn’t try during a call…
  2. There are 2 processes with “adsprpcd”. The one with “audiopd” gave me audio back, the other one not.

Today three devices had this problem at a time. XA2 (dual and single SIM)

1 Like

Also happens on a brand new XA2 dual SIM (“H4113”) with a fresh SailfishOS 4.1 install.

The usual trick worked as expected:

devel-su killall adsprpcd

1 Like

I have only 1 entry there.

Tried also that - not working.

For me I have standard single sim xa 2
worked until yesterday, did a phonecall of round 1 hr in the moring and from the afternoon nothing worked. I got my sound back working with that killing stuff described above ut the other person can not hear anything.
also using a headset (wired and BT) does not work
csd tool sais all is working, i can record myself + playing it, both speakers.
Its only in the phonecall :[

This infamous bug is also present in 4.4. A reboot fixes it. But if you reboot later it will probably be back, so you never really know when you can hear the person at the other end.

I spoke to our developer investigating this issue, and he believes it may be a problem caused by the pulsaudio service transitioning from a system service to a user service when the user unlocks their phone (not at the decryption step, but the login step).

However, at this point, it’s not entirely clear that this is the issue, so it would be really helpful if anyone experiencing this could try a few things out.

First, after logging in to your device, running the following two commands (you’ll need developer access) will generate output that shows which of the services are running.

systemctl --system status pulseaudio
systemctl --user status pulseaudio

If things work correctly, the system service should be inactive and the user service should be active. If this isn’t the case, then it could be the source of the problem. If you find your phone in this state, it would be useful to also test out a phone call to establish whether you have audio working or not.

Subsequently, the following commands may get the user service up and running and potentially fix the issue.

devel-su systemctl --system stop pulseaudio
systemctl --user restart pulseaudio

However, note that since this may not be the cause, I can’t guarantee that this will work, but it would be useful to explore it. Basically, any further info you can give from running these various commands and testing out the audio on your phone afterwards, would be very helpful to know at this stage.

I’ve passed on the info about adsprpcd and hopefully that will also be useful.

If it does turn out to be this issue, then unfortunately it’s also likely to be challenging to fix, so I can’t give a timeline on when it might be. Nevertheless, figuring out whether this is the issue will certainly be a useful step in the right direction, so any more info would be appreciated.


I can confirm that this is the case. As soon as I encounter the problem again, I’ll retry the commands and let you know if there is a change.

1 Like

Are you aware of:

[quote="[] XA2 phone calls no audio, post:81, topic:2446"]
I installed qCommand to execute a script as root

Thanks, I’ll take a look at that.

I am using a XA2 Plus (dual SIM) and my wife has the same phone model. I am using the script and call it via qCommand and get along with this compromise (although I do not like it). But my wife not. Simply pressing a button would be acceptable, but entering root PW in qCommand is too much. Every release I hope the problem is fixed, to really have the phone ready for a “regular” user.