OTA Update to 4.5 crashes - What to do?

Trying to update Xperia 10 III from 4.4.72 to 4.5 EA and it crashed out and rebooted half way through installation.

It successfully booted back into 4.4.72, but trying the upgrade again it now complains there is not enough space in the root partition.

Presumably there are some temp files orphaned in there from the failed install using up the space now?

I tried to create more space by deleting apps as suggested in the release notes, but no apps will now delete - either from the app grid or through Storeman.

I tried to refresh the repositories thinking they may have got mucked up by the failed installation, but I get a fatal error.

What can I do to sort all this?

Remove that repo from storeman, you can add it again after. Then try update again.

How do I do that please?

Open Openrepos, tap Repositories, find the repo named Karry, hold down for menu and select either disable or remove.

You can always find that app again in Openrepos and pull down to add the repo back again.


EDIT: I did not read the screenshot slow enough :slight_smile:

Try to collect logs for sending to Jolla,
Collecting logs of the failed update

The second link for removing the cache is still useful:

Download starts but gets interrupted before complete

1 Like

Why do that?, the error message shows its a repo in openrepos, we’ve known for a long time now that we need to disable/remove repos in Openrepos before updating. Having said that, I did not disable/remove any repos and my update went quite well. It is mentioned in the release notes nearly every release, disable repos.


What to do?

Slap yourself on the wrist for installing an early release? I think the release notes basically say don’t use sfos-upgrade.

OTOH, thanks for highlighting a problem that may have bricked my phone instead. :sweat_smile:

We need a 4.5 feedback thread.

From the release note:

Start the update from “Settings > Sailfish OS updates”. Avoid running updates on the command line, please.

Voila, have created it just now.


Thanks, I did that and the repository in Storeman is gone, but when I try pkcon refresh I still get the same error message about that one repository as though its still there. If I try to refresh the repositories through Storeman it just hangs forever. :pensive:

Not sure I understand your point. I did attempt the update using the Sailfish UI at ‘Settings → Sailfish OS Updates’ Then top pulley menu for Check For Updates, then Download, then Install. Nowhere in my posts above did I say I used the command line, so not sure why you think I did?

1 Like

I didn’t use sfos-upgrade. See OTA Update to 4.5 crashes - What to do? - #12 by Steve_Everett above.

1 Like

Because I apparently have two separate issues:

  1. The upgrade to 4.5 crashed mid-install, leaving the root partition with not enough free space
  2. When I tried to delete some apps to get back some space on the root partition I found I couldn’t; hence why I tried to refresh the repositories as advised in another thread on this forum.

There’s plenty of advice here saying you can basically ignore the package removal errors before updating, and I have done through multiple SFOS upgrades from 3.xx and it has always been fine - no problems whatsoever. This is the first upgrade where it might have caused the upgrade to abort mid install - although there is no evidence the upgrade failure was due to this; it could have been something else.

Anyway, I have solved the root partition space problem by following @emva 's post above to clear the cache. However I still can’t delete any apps, nor refresh the app repositories for some reason?

I had the weirdest experience.

Update went fine and i can use nearly everything except:

  • keyboard is not working in any setting or app, cant create notes but on the shell it works
  • Jolla store does not load
  • Update Jolla page is in a loading loop

What i tried as devel-su on the shell is pkcon refresh and pkcon update.
It downloads a lot of packages with “refresh” but when i then try to “update” i get the notification: Fatal Error. The installation has been terminated as instructed.

OK, the phone just crashed in use now and all I get is the Sailfish OS logo screen when I reboot. Nothing makes any difference power+volup, power+volup+voldown.

It seems like the phone is completely bricked now.

The failed 4.5 installation must have screwed up the original 4.4.72 installation somehow. Its a shame that SFOS is still so fragile after all these years.

Oh well, I don’t have time to do yet another reflash for a while, so its back to the iPhone unless anyone has any ideas of how to get the thing to boot beyond the Sailfish OS logo?

Always download a flash image of the previous SFOS version early enough before it disappears from the SF homepage, so that you can reflash the phone with old version if new one doesn’t work.

Can you ssh into the device?

One try you could make is to use the recovery mode.
So power your device off and hold the volume up key and plug in your usb cable to connect the device to your computer. In the jolla shop there should still be the recovery image for 4.4.0 to boot into recovery mode. Make sure to get the one that matches your installed version.

From there start a shell and post the log from /rootfs/var/run/systemupdate.log