No song details displaying on car stereo when connected via Bluetooth Song Xperia 10 III



Unable to see the song details or skip back and forwards on songs. Using a Ford Stereo in Mondeo. It works fine on CalyxOS with Android 13 under the hood on my Google Pixel 6 Pro.

I have seen these issues before on Sony Xperia 10 Plus and back then I had to install BTtons via Storeman to get it working. But apparently since 4.2 the functionality provided by BTtons is included in SFOS from 4.2+

So not sure why it is working then.

I did install Storeman and tried to install BTtons but there was no install option so it must have been disabled to see if that could get it working.

On the Bluetooth connection I have tried switching to Multimedia as this seems to be the default when pairing via the terminal as pairing via the UI is not possible currently.

I also tried the CarKit and neither one displays the song details etc…


Tested on a Ford Mondeo
Using Sony Xperia 10 III
Flashed recently with the latest software and no further updates.
Paired with the car stereo via the terminal
Test with native media app and android music apps


  1. Turn on car stereo
  2. Turn on bluetooth on X10III
  3. Let it connect
  4. Test playing radio or music via various music apps


To be able to see all the song details (Artist, song, etc)
To be able to skip back and forwards via stereo buttons or via buttons on steering wheel.


Unable to see and do any of the above in Expected Result section.


No mods as unable to add BTtons manually via Storeman.


Happens to me as well, but not always.

There was a work-around for this via BTtons from Storeman but this is not needed in the latest versions of SF.

This could be: [4.4.0] mpris-proxy service crashing and not restarting

1 Like

Is there a way to check and restart it?

Yes, for checking if it is up or down.

systemctl status --user mpris-proxy

Should normally give you:

mpris-proxy.service - Bluez5-MPRIS Proxy
Loaded: loaded (/usr/lib/systemd/user/mpris-proxy.service; disabled; vendor preset: enabled)
Active: active (running) since Sat 2022-12-17 16:18:42 CET; 1 day 17h ago


systemctl restart --user mpris-proxy

for starting it back up.

1 Like

Thanks for the information really useful and will store away.

However even though after restarting because it was down the music information is still not going to the car stereo.

If I switch to my android device the music in similar apps is showing again.

I did notice that when I connected the sailfish device that it did momentarily flash with song details then disappeared again.

I have attached some screenshots of native music apps and the display on the car stereo and showing that the mpris-proxy.service… is active (running).

I also tried switching the car off and reboot the device and reconnecting and ensuring the mpris… was active which it was.

Previously on Sony Xperia 10 Plus to get all the music details I had to install BTtons and then it worked perfectly there after once I started the service which was available in the UI somewhere.

So with the above I also had the option to skip back and forwards via car stereo or via steering wheel buttons.

Now you have to do this via the terminal as you described further down which is fine as once it is up it looks like it retains that even after a reboot.

Currently no song details is shown whether in (native music (media, Sailwave, Netradio) apps or android apps (DI.FM, Replaio Radio, TuneIn Radio, VLC)).

However even though the skip back/forward buttons are not displayed they do now work via car stereo and steering wheel, however it did switch from the current music app to another app that was open in the background then I could skip through the tracks in that app.

Do I need to send in a bug report to get this diagnosed and fixed for everyone?

If so I am happy to do it but not sure what to do.


You already have (this thread). And i’m fairly sure you are not the first.
Temper your expectations.

As a workaround start the media player before connecting the phone to the car. It seems to me that it works this way. (most of the times at least)

I can never get that to work for me. Is that native sailfish music apps or both sf and Android?

I use the native media player.

You can run systemctl --user edit mpris-proxy and paste



This should restart mpris-proxy automatically and persist system updates.

Currently this it looks when i run that command, so its hard to know where i need to paste the.information in.

Paste it exactly there, it’s an empty file. After that run systemctl --user daemon-reload & systemctl --user restart mpris-proxy. Then systemctl --user cat mpris-proxy will show your additions to the service file.

Yes I have managed to paste this in.

But how do you get out of this.

I have tested on fedora to quit and its esc, q, q but cannot replicate in the terminal in sailfish.

If I just close the terminal after pasting in it is lost.

Ok so i opened a new window and finished off the process and this is the result.

Ive also restarted.the mobile and run.the restart nd check the status while connected to the car and.still from both native.and android.apps.

After you used the systemctl --user edit mpris-proxy command:
Type i for edit mode.
Paste the text you want.
Tap the Esc button (until the screen flashes white) to get out of edit mode.
Type :wq to write and save.