BTtons won't start after upgrading from previous early release build to latest one

On upgrading my Sony Xperia 10 Plus Dual SIM mobile from the last early release build to I am now unable to start the BTtons app when selecting start and when returning to the home screen the app is just continuously spinning with Mpris proxy isn’t running. In turn I am no longer getting music information on the ford car stereo again.

I had similar issues previously on version 3.4… when upgrading from one version of 3.4 to the latest version of

So a similar pattern. And then I found the only way to resolve it was to go back to Android 9 > Sailfish OS latest version which as you can imagine is a lengthy process each time there is an upgrade.

I did try uninstalling BTtons, removing the bluetooth car stereo from the mobile and re-pairing but that didn’t work.

Any other options would be very welcome or if anyone is having similar issues. If there is an easier solution I would love to hear.

as mentioned on the issue you created (thanks!), AFAIK BTtons shouldn’t be necessary anymore on 4.0.1, since mpris proxy is now built into the system.

If I’m mistaken there (just did preliminary testing as of yet), feel free to describe what isn’t working with the built-in feature that did work previously using BTtons.
Perhaps we can file a bug report here to get that fixed for everyone.


I can confirm that BTtons is no longer needed. My earbuds work without a hitch for pausing and playing in Spotify and Unplayer. I can’t confirm any extra controls as my earbuds are only set up with play/pause.


Yes BTtons worked very well on previous build.

But when testing in the ford car stereo after upgrading to or there is no feedback on the car stereo showing what music is playing etc or controlling the music skipping back and forwards.

So I also tried removing BTtons unpair and repair without BTtons and still no feedback on the stereo.

All is I get is the music playing on any music app.

But when trying to use BTtons is just keeps saying MRPIS proxy isn’t running and won’t start.

Many Thanks

One thing I tried is resetting Sony Xperia 10 Plus so it went back to then upgraded to to see if that would help.

So in the car and using bluetooth headphones I can pause, skip back and forwards. But the only issue when playing music from eg native built in music app or spotify I can hear the music but nothing is provided on the stereo to show the track, artist, radio station etc.

That is where BTtons came in previously but is not working now.

So not sure what is wrong - I did try going into the terminal to enter MRPIS-PROXY was running but not sure how to check that.

Hm, BTtons did nothing but starting mpris-proxy. Well, optionally doing that if a BT connection was detected.
So perhaps there’s a regression (if you can call it that in a feature that is just now enabled) somewhere else?

IIRC @abranson was somehow involved in that topic – perhaps he can chime in and propose how to proceed with this.

I haven’t seen the BTtons source, but could it be getting confused if the installed mpris-proxy service is different somehow from the one it’s trying to install itself? Might just need all the service installation stuff removing, and instead it can manage the bundled service.

I think that app is still useful for some, as the mpris proxy can get stuck under certain conditions so being able to restart it can come in handy.

My Sony headphones started responding to touches with Sailfish 4.0.1 without BTons. Earlier I just used my Android phone or Windows tablet. Fortunately that madness is bygone now.

It works much simpler than that, it doesn’t have a real service and just started the mpris-proxy from the original repo. Heck, it even uses qml logic when running in the background. Yes, it’s that lazy and bad.

While I will keep an eye out for how to possibly change that wretched little thing for Koli, the point for bugging you was that apparently for some reason mpris Infos don’t get pushed to @j_sarkari s car stereo with the Koli implementation.


Well, that mpris-proxy isn’t a perfect solution - that’s why it didn’t get it in for so long. But we thought it was better having a mostly working solution than nothing at all. It’s a beta really - hopefully we can spot some bugs in it and fix them. These occasional loss of data seems to be quite difficult to track down though. But at least it’s all open-source there, so people can mess around with it.

Ok a further development - so I decided to take this Sony Xperia 10 Plus back to stock android 9 to ensure everything is working correctly. So for some reason the music or time lapsed etc isnt showing on the ford car stereo now even on Android 9 which is strange as it always used to. So that suggests there is something up with the device itself.

I tested deleted the paired device, de-bonding on the stereo and that didn’t work.

Then switched to my Google Pixel 3a XL - now on Android 12 and that shows all the music playing, aritist, song, time elapsed etc no issues at all.

Not sure how to recover the bluetooth on this device now.

But previously when I reset device back to Android 9 then back up to the latest Sailfish OS everything worked - so will try that route now.

Ok so I have now got Bluetooth working correctly on my Car Stereo and the same workaround applies in Sailfish OS 4… as it did in Sailfish OS 3…

It appears that when I upgrade from one version of Sailfish OS 3 or 4 to another then I hit problems and cannot see music playing etc.

But today after going back to Android 9 then install the latest version of Sailfish OS now the music is displaying on the car stereo again as it did last time I installed Sailfish OS from Android 9.

So the take-away is something is happening during upgrades which is causing this issue.

I will monitor this but at least there is a work-around. Also I haven’t installed BTtons at all so as mentioned above this is no longer required for OS 4…