No Ringback tone when calling with VoLTE



Since I enabled VoLTE, I can’t hear a ringback tone when I call someone, even though their phone is ringing.


Call someone


In my phone I should hear a tone, that indicates, that the phone of the called party is ringing.


Nothing to hear. Silence until the called party answers.


Xperia 10 II
German t-mobile SIM
VoLTE enabled and working


Since the update on, and enabled VoLTE I can’t hear a ringtone when I call one person (also Croatia T-mobile SIM), even though their phone is ringing.
Two phone numbers on TELE2 Croatia SIM, I can hear normal ringtone.

Xperia 10 III
Croatia t-mobile SIM

You mean the tone that indicates that the other phone is ringing, correct? The toooot toooot toooot?

Not the ringtone of your phone.

Correct! That is what I meant.

Right. The tone that indicates that the other phone is ringing.

You could call it a ringback tone or ringing tone to eliminate the confusion.

1 Like

When using my Pinephone is the US after the 2g/3g shutdown (and regardless of what distro I’m testing at the time) I’ve noticed that not all network providers supply the ringback tone when using VoLTE. It’s pretty disorienting to listen to silence and waiting for a “hello” from the other end . . .

1 Like

I have the same. When I try it with an android (same operator sim and settings, same position) U get a ringback tone.
Meaning 2 Phones, one Android, one SFOS.
Same Operator (

Calling from SFOS to Android: no ringback tone on the SFOS device
Calling from Android to SFOS: ringback tone on the Android device.

Maybe we can make a proper bug report from that post and have it in the correct place?

For now I changed the category into bugreport.

Just create a new post and fill in the bug report template

There are generally two ways (responses) in a SIP/VoIP/VoLTE setting with implications how the ringback tone is supposed to be generated when calling a remote party. One is “Session Progress” (including early media) which not only signals to the local device that something is happening on the other side but also provides the audio data stream that can be played to the user - the other is “Ringing” which just indicates that the remote phone is ringing but requires the local device to locally generate the appropriate tones itself. Maybe one of them is poorly implemented which could help explain why some people have issues with missing ringing indication and others don’t. (but that’s pure speculation)


For me it’s not 100%, but maybe 50%. Sometimes I hear the calling sound, sometimes I don’t. It seems to be dependant on who I call (callee’s operator?).

1 Like

Her are my experiences.
It depends from network connection: 2g 3g ring back tone is ok because of no VOLTE is used for calling

4g no ring back tone when VOLTE is enabled

In summary it means no ring back tone with VOLTE.

My providers are Mobilcom (telekom) and Mobilcom (Vodafone) both from Germany.

1 Like

I confirm this behavior. My provider is Telefonica Germany.

1 Like

Xperia 10 II Volte enabled and in a range of lte signal. In my case I can hear the ring back tone if the other party do not have volte. If they also does have volte enabled, there is no tone.

Thanks for all the reports on this. I’ve created an internal report and tagged it as “tracked”. We’ll do my best to post back here if there are any updates to report on it.


@flypig is there an update on this issue?

I could get ringback back by disabling settings->mobile-network->4G-calls as described in this thread.
This solution does not work with providers that enforce VoLTE thus a full bugfix is still needed.

Hi @Andrwe. Thanks for asking and sorry that you’re still experiencing this. I’m afraid I can’t give an update as I no longer have access to the internal bug database. However, the fact that it’s still tagged as “tracked” rather than “fixed” would suggest that work on a fix still isn’t completed yet I’m afraid.

@jovirkku, would you be able to help here?

I don’t get the ringback tone (just silence) when I call someone who also is on a VoLTE / 4G network.

I get the tone when I call someone who is on 2G or 3G network, or if my phone gets dropped to 2G.

To recap, the tone is heard only if either of the parties ISN’T using VoLTE. If both parties use VoLTE, there’s just silence.