New Issue - On reboot > First security code > ... endless circular sand timer (no desktop)

REPRODUCIBILITY: 100% (so far)
HARDWARE: Xperia 10 iii
REGRESSION: Yes. Although I have had a wealth problems with this new handset/install, this has only started now after five days of use.


I’ve been restarting my phone a lot - due to trying to diagnose a bunch of issues including (but not limited to!), a lack of mobile data.

Restarting the phone this time I was presented by the first security code prompt.
No problem.
Then you get the brief circular sand timer while the phone loads the desktop and presents you the lock-screen.

Only now it never reaches the desktop lockscreen, instead the circular sand timer just continues to whirl around. I can top-swipe and get the task-bar, but if I swipe away i got back to the circular sand timer (not the desktop).

This condition has persisted after a restart.


Reboot phone


  1. Reboot phone
  2. Enter first security code
  3. … do some waiting


Enter code security code, then you get the brief circular sand timer while the phone loads the desktop and presents you the lock-screen.


Enter code security code, but it never reaches the desktop lockscreen, instead the circular sand timer just continues to whirl around.


I have enabled developer mode, but all i have done is enter “ifconfig”, and i have restarted the phone several times since successfully without encountering any (new!) problems.


Having an absolute ball with my shiny new sailfish device:

How do I force it to load the desktop?
Give the list of calamity so far, have I just got really unlucky, and need to reflash the device?

Had the same problem , solved by a soft reset, check the key combo for your device, hopefully it works , on my xa2 ultra it did.

1 Like

This function?

Nope thats another and final step u could take , a soft reset is different , on my xa2 ultra i pressed powerbutton + vol down simultaneous , u see led become red or feeling a triple vibration , that worked for me, i did not lose data or any settings.

Hopefully it works for u, otherwise u need to ask an expert for other solutions, good luck .

1 Like

Not sure what it is for a 10iii, but i opted for a re-flash and still stuck in more or less the same situation.

upgraded from to no Xperia 10 III. The device got stuck on a white horizontal lane during upgrade forever. Not responding to anything. not even pressing power button for over 2 min! totally hang. Options? open the phone (how?) and disconnect / reconnect the battery internally? Wait until it powers to zero? any advice?

Vol Up + Power (Vol Down + Power on some devices), release buttons after the phone vibrates.

thanks, tried button combos, but alas, no button combination helped. What helped: watch-repair type screw driver. I managed to open the Sony back side, unscrew 12 screws and lift the motherboard cover enough, so I can unplug the battery.
(the video here Sony Xperia 10 III Disassembly Teardown Repair Video Review - YouTube)
then re-connected battery back screws back in and cover back in. booted and Jolla is fine, upgraded now. All works. Minus water proofing of the case, of course it is gone now, since I don’t have a right glue to put it back in properly. What an upgrade! from .64 to .68… +))

Unnecessary tear down, now u have lost waterproof and insurance of yr device , u should have asked and wait or google for key combo for soft reset, but hey its your device , wouldn’t make that one, if soft reset not able then reflash is a better choice .

May have been related to a dodgy sim that was progressively failing.
As the same behaviour was seen on two separate re-flashes of the device, while the sim card was left in the device. The device then booted normally after the sim was removed, and later the sim would not be recognised in three different phones.

Q - should we expect a dodgy sim to prevent SFOS completing boot and login?

1 Like

An error message indicating the fault would be preferable. Certainly preferable to cracking open the device and pulling out the battery.

Also, I don’t believe my SIM to be faulty since it’s occurred with two different new chips, but I’ve had the problem as well. Fortunately the power+volume rocker reset has always bailed me out.

1 Like

I am occasionally experiencing a similar problem with a different xperia model (xz3). It is a h/w related issue that prevents the OS booting completely. In my case it seems to lose the modem and the wifi component functionality. Reverting to Android didn’t fix the problem either.

The best is to claim for sony service repair, but with an unlocked bootloader that might be impossible.

1 Like

i was managing to restart the device, but it would just get back to the same endless sand timer after first security code.