Network broken for some Android Apps in

thank you. I have been using Osmand+ and ZVV all the time, too. Don’t know if installed by F-Droid or by Aurora Store however.
I am aware of the network connection problem for android apps, and I tried restarting Android app support several times. So far, without success ;(. In previous versions of SFOS both apps worked very well.
Funny thing is, in Osmand I deleted the local offline map and I can’t get to map downloads anymore.
Regarding detailed information, like EV charging stations, Osmand is much better than pureMaps, and they update their maps more frequently, too.

Uninstalled Osmand+ and reinstalled Osmand+ and now it works as it should under circumstance of
2. Disappearing of network connection using wifi
I did not find a reason why Osmand+ would stop to have access to downloadble maps, however.

I’ve also got this issue.
when it firefox says no internet, i can still get to my router via ip address, so this looks like it may be dns issues for the alien environment .

1 Like

I also have this “No internet over Wifi for AD apps” issue on my XA2 (never used EA releases), and I found out the following:
When launching Android settings via
It tells me that WLAN is off and when trying to turn it on there, it just says “Error”. However, I can select my network and connect to it from the saved networks. It then tells me that WLAN is on, but WLAN is still off in the setting above, and still can’t be turned on. Seems like there’s something not right within how AD is set up for networking?

1 Like

This would be a perfect moment to try out Fernschreiber by @werkwolf. :wink:
Works fine on wifi and GSM.

1 Like

I am the kind of paranoid who switches off Wifi before leaving my premises and switching on mobile at the same moment. So maybe that’s why I do not experience this kind of problems. :ghost:

1 Like

A bit off topic: Can I use Fernschreiber at the same time as android telegram app? Or do I have to remove or somehow deactivate the android telegram app?

At home I lose from time to time wifi connection. At home this happens quite often. Now I have to check regularly if wifi is working correctly. So I have to open firefox and check a web page. Only after that I can be sure that network is working correctly.

The interesting thing is, that the last days there where no problems. So maybe the problem is somehow “self fixing” after some time…

For testing I just walked away from my fritzbox until I lost wifi connection. When I got back connection android wifi was broken. And I can confirm the following:

  • As @gaidheal sad: It still is possible to reach with firefox the router using the ip adress. URL is not working.
  • As @Norman sad: In android settings wifi is switched off. When I try to switch it on an error occurs.

@luddwig27 Yes, you can use Fernschreiber at the same time as AD Telegram, I have done it many times.

For me, the problem persists, but restarting lipstick from the utilities menu seems to fix it (that way, AD will also be restarted, while restarting just AD from the settings won’t fix it). Also, the fact that one AD app has internet access doesn’t mean that all the other AD apps can also access it, in some cases it works only for some, but not for others, so the Firefox test might possibly not be significant for all other AD apps.

I do not know how.Telegram and Fernschreiber react when struggling for the same account for a longer period of time.

But one really nice feature of Fernschreiber is that it keeps you informed on the status of your network connection. Even in iconised view.

This might come in handy in your situation.

Recently i have installed latest version on xperia 10II and the ebay app has not internet connection, also chromium sometimes but this after reboot work correctly.

So we have now allot of informations. There are quite allot of people dealing with this issue. But how to solve it? What changed between SFOS 4.1 and 4.2 that the wifi (DNS, …?) in android is broken? What kind of log is needed for deeper investigation?

Just to make it clear. When I want to use firefox at the moment, there are several possibilities:

  1. I open firefox and use it.
  2. I open firefox and see that there is not network connection.
    2.1. I switch wifi off and on. After that I can use the firefox.
    2.2. If this is not working I restart android support and can use the firefox.
    2.3. If this is not working I have to restart my phone. After that finally I can use firefox.

The same case with all other android apps. In case of the signal messenger I even don´t know, is it connected right now or not. So in some cases it takes few hours to receive a message instead of regularly few seconds.

So in worst case I have to reboot my phone to get an app working. How can solve this? Who we/I can help?


i often do the same but experience the described problems when coming back and switching to wifi again.

i then have to restart android support.

yes, in other Linux Systems someone would maybe create a Shell script to restart Android support on changing Networks. I don’t have skills to do that, but imagine it might be a quick fix…

Nice ambience. Where did it come from?

Thank you. It’s just a photo I have taken in Berlin. I did not use the camera of my phone, though. :slight_smile:

And finally it happened to me, too!
Today I switched off WiFi and switched to LTE as I left home and a minute later I found out that Android had lost all network connection.

Coming back home I turned off LTE and switched to WiFi and again: no network connection for Android apps.

In both cases the remedy was to turn either LTE or WiFi off and on again.

“Hello? Roy, IT. Are you sure it’s plugged in? Have you tried turning it off and on again?”

same here ( Xperia XA2)

the strange thing is some apps are more funerable than others. Telegram often is ‘waiting for network’ when I switch Wifi on after it has been off for a while (never after reboot), but WhatsApp or Firefox never give any problems.

So, not all Android apps suffer this is my experience.

All my apps are installed with Aptoide.

I also have this telephone audio problem which is a lot discussed here at the forum. Sometimes, I am called, and the other site doesn’t hear me, until I reboot, than it works for a while. I can always hear them.

Same here, and the best workaround for me, too.

There are other threads reporting the same issue which became prevalent after the upgrade to

and here

I investigated the problem and maybe this might help. I usually switch WiFi and mobile Networks on and off manually when I enter or leave home.

If I allow a short period of time of a minute or so for both connectivity settings to be active, I seem not to have any disconnects with Android apps.